Results 1 to 6 of 6

Starting the car for the 1st time in years

This is a discussion on Starting the car for the 1st time in years within the General Help forums, part of the LSx Technical Help Section category; ...

  1. #1
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,394

    Red
    2001 ws6

    Starting the car for the 1st time in years

    Whatís up guys, been a while since Iíve been on here and about the same amount of time since Iíve started the car up. Finally ready to get it on the road again after about 6 years. Over that time itís just been sitting in a garage and Iíve started it about 5-6 times in that span but the last time was about 2 years ago. Besides the oil and half tank of gas in there what else should I change before driving it? Tires need to be changed as well but anything else that may have dried out that I should change? Feels good to be talking about the car again, been way to long. Hope you guys have all been good over the years

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,664

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Starting the car for the 1st time in years

    change the coolant as well. the lifespan is about 3 yrs. the rear going to leak. if it isn't good chance it's empty. look at the brake fluid. should be clear not cloudy or dark. expect Dryrot on hoses and tires.

    Gas only last 6 months. you may have clogged lines. change fuel filter a few times.
    http://www.ls1.com/forums/f7/my-6-liter-build-174257/

    http://www.ls1.com/forums/f8/my-8-8-rear-build-165553/

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, 104mm Air Lid & Line Lock, Catch Can, Stage 2 T56 w/Viper shaft, PRO 5.0 Shifter, Tick MC, SPEC Stg3+ Clutch, QT SFI BH, MWC DSL, UMI: Sway Bars, SFC, PHB, LCA's, LCA Relocation Brackets & TA, Belstein Shocks, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    00 FB Vert - Stock

    Horsepower never lies, but is often lied about!

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,664

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Starting the car for the 1st time in years

    pay attention for leaks around the front plate, oil pan and around the bell housing. valve covers too.


    Pull the fuel pump fuse and crank up a few times after you change oil. You going to need to prime the oil some. Pay attention to oil pressure gauge in the 1st few minutes, especially the first 30 seconds. If no oil pressure shut down immediately.
    Last edited by SMWS6TA; 04-23-2018 at 07:57 PM.

  4. #4
    11 years of bangin gears cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    North Jersey
    Posts
    11,496

    Phantom Black Metallic
    2004 GTO M6

    All of what Scott said and once you get to the tires, inspect your brake rotors as they could have developed rust from sitting and you might have a brake pulsation. If they are pitted, or have what I call "solder spots" as the rotors look like someone took a soldering iron to them, either replace them or have them cut if possible.


    extreme dimensions, driveshaft shop, harrop, hid(35watt/6k) lows, hurst, k&n, led fogs, maverick man, mishimoto, nitto, revshift, slp, stern st-1, smoked sidemarkers, whiteline poly radius rod bushings

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,664

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    or at the minimum run some steel wool over them to knock off the rust so it doesn't Fwak the pads.

  6. #6
    Super Moderator pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    22,146

    Black & Blue
    '02 WS.6 / '07 Suburban

    Welcome back!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First time in 2 years
    By Orcus79 in forum Drag Racing
    Replies: 15
    Last Post: 08-27-2013, 08:19 AM
  2. starting the car for first time in over a year and a half
    By basballny2 in forum General Help
    Replies: 8
    Last Post: 04-24-2013, 01:12 PM
  3. First time at track in almos 2 years
    By devildogws6 in forum Firebird / WS6
    Replies: 3
    Last Post: 09-16-2010, 04:31 PM
  4. I'm clean for the first time in 3 years
    By LgndKller20073 in forum Almost Anything Goes
    Replies: 26
    Last Post: 03-01-2009, 04:48 PM
  5. Car Not Starting All The Time...
    By ls1camino in forum General Help
    Replies: 3
    Last Post: 01-05-2008, 08:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •