Results 1 to 3 of 3

Oil pressure sensor failing

This is a discussion on Oil pressure sensor failing within the General Help forums, part of the LSx Technical Help Section category; Hello guys new to this forum thing but needing some help. Long story short I installed a high flow melling ...

  1. #1
    Junior Member
    Join Date
    Oct 2021
    Location
    Cleburne, texas
    Posts
    1

    Oil pressure sensor failing

    Hello guys new to this forum thing but needing some help.
    Long story short I installed a high flow melling oil pump on my truck and since have been going through oil pressure sensors like crazy. They basically blow themselves up and oil just poor out of the sensor itself leaving all my oil on the ground.
    Question is is there a after market sensor that can handle the higher volume and pressure of the upgraded pump.

    05 silverado LM7 5.3L 240k miles.
    Runs about 60-70 psi all the time 80+ on a hard pull.
    Mods--- pace setter shorty headers
    762 heads cold air and a tune rebuilt top end new rockers push rods all new gaskets arp head bolts new timing chain and high flow oil pump.

    Any help is greatly appreciated.

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,673

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Oil pressure sensor failing

    I've been using a Melling 10296 HF/HV pump for over 10 yrs and had zero issues. What brand of sensor are you using?
    http://www.ls1.com/forums/f7/my-6-liter-build-174257/

    http://www.ls1.com/forums/f8/my-8-8-rear-build-165553/

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, 104mm Air Lid & Line Lock, Catch Can, Stage 2 T56 w/Viper shaft, PRO 5.0 Shifter, Tick MC, SPEC Stg3+ Clutch, QT SFI BH, MWC DSL, UMI: Sway Bars, SFC, PHB, LCA's, LCA Relocation Brackets & TA, Belstein Shocks, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    00 FB Vert - Stock

    Horsepower never lies, but is often lied about!

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,673

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Oil pressure sensor failing

    High engine temps, sometimes oil filter issues can cause high pressure. Also oil weight.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pressure sensor
    By johnfin in forum External Engine
    Replies: 17
    Last Post: 06-23-2019, 01:40 PM
  2. Oil Pressure sensor
    By mrpckrb in forum External Engine
    Replies: 7
    Last Post: 06-24-2008, 07:40 AM
  3. Oil Pressure Sensor
    By CWW17 in forum General Help
    Replies: 5
    Last Post: 04-20-2007, 07:06 AM
  4. Knock Sensor/Oil Pressure Sensor Issue
    By Slow '99 in forum External Engine
    Replies: 1
    Last Post: 04-04-2007, 08:28 AM
  5. Oil pressure sensor
    By blomeup647 in forum General Help
    Replies: 5
    Last Post: 04-03-2007, 03:42 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •