Results 1 to 1 of 1

Need help with ignition problem!

This is a discussion on Need help with ignition problem! within the General Help forums, part of the LSx Technical Help Section category; I’m new to the forum, so first let me say hello and thanks in advance for any solutions someone may ...

  1. #1
    Junior Member
    Join Date
    Dec 2021
    Location
    Mississippi
    Posts
    1

    Black
    2002 Firebird

    Need help with ignition problem!

    I’m new to the forum, so first let me say hello and thanks in advance for any solutions someone may have to my problem.

    I have a 2002 Pontiac Firebird Trans Am WS6. I bought the car brand new, so it’s a one owner. The problem I’m having is starting. It was running fine, but over the years the key switch started getting harder to work right. It got hard to turn, almost locked up even. I eventually had to do the the VATS resistance bypass and that was fine as well. Eventually the key got to were it was just not working right and i had to wiggle and play with it to engage and crank. Finally it got to point where it just slipped and something broke. The key would turn all the way but no resistance and starter would not engage. It didn’t have that springy feel.

    Ok, so now I’m thinking , we’ll I guess I got to break down the steering column and replace the cylinder. So I bought a new ignition key cylinder and I’ve installed and I can see it’s turning the slot but still nothing is happening with starting. The key turns all the way and will reset but no resistance where you normally expect it. Is something stripped in the ignition housing? I’ve also had problems with the tilt steering bushings being worn and since I’ve broken everything down so far I may as well address that. This repair is evolving into a real pain.

    Any advice at this point?
    Last edited by Flash02WS6; 12-22-2021 at 07:22 AM. Reason: Misspelled word

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ignition problem on 02 Transam, Please help!
    By jayfire in forum General Help
    Replies: 13
    Last Post: 10-23-2013, 07:09 AM
  2. Ignition Lock problem
    By slims00ls1z28 in forum GTO
    Replies: 36
    Last Post: 07-24-2009, 08:37 AM
  3. ignition problem
    By mctcash in forum General Help
    Replies: 5
    Last Post: 06-11-2008, 06:31 PM
  4. Lt1 Ignition Problem.
    By 1993RedLt1 in forum LT1
    Replies: 16
    Last Post: 05-05-2007, 08:12 AM
  5. Ignition Problem/ Concern ??? Help
    By 01JameSS in forum General Help
    Replies: 5
    Last Post: 01-10-2006, 10:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •