General Help

This is a list of discussions in the General Help forums at the LS1.com | GM LSx Performance Forum. The General Help forum Get help with your Problems and Installs

  1.   Sticky Threads  

  2. Sticky Thread Sticky: Vibrating Headlamp?

    Started by Whamhammer, 08-19-2019 05:03 AM
    • Replies: 12
    • Views: 5,866
    09-21-2020, 07:12 PM Go to last post
  3. Poll Sticky Thread Sticky: Poll: I'm a Oil Junkie

    Started by Sarge, 08-21-2005 07:50 AM
    70 Pages
    1 2 3 4 5 ... 70
    • Replies: 1,384
    • Views: 381,784
    09-05-2020, 02:26 PM Go to last post
  4. Sticky Thread Sticky: Foot Well Lighting

    Started by SMWS6TA, 07-26-2016 08:34 AM
    • Replies: 7
    • Views: 12,963
    12-29-2019, 06:32 PM Go to last post
  5. Sticky Thread Sticky: How to bring your car out of the dark ages...HID/LED

    Started by SMWS6TA, 07-07-2016 01:16 PM
    • Replies: 11
    • Views: 15,629
    01-22-2019, 07:04 AM Go to last post
  6. Sticky Thread Sticky: List of Sensors and What They Do

    Started by Knight, 08-18-2011 03:43 PM
    2 Pages
    1 2
    • Replies: 24
    • Views: 69,023
    10-15-2018, 08:32 AM Go to last post
  7. Exclamation Sticky Thread Sticky: Body Control Module - Repairing Bad Solder Joints

    Started by gokillyourself, 04-29-2012 12:10 PM
    • Replies: 9
    • Views: 17,429
    01-25-2018, 09:13 AM Go to last post
  8. Sticky Thread Sticky: Technical info write-ups and stickies

    Started by 0rion, 02-27-2008 06:02 PM
    • Replies: 4
    • Views: 30,624
    05-29-2014, 07:18 AM Go to last post
  9. Sticky Thread Sticky: Torque specs for LS1 motors

    Started by konigandy6, 06-27-2013 06:34 AM
    • Replies: 2
    • Views: 54,803
    06-28-2013, 06:43 AM Go to last post
  10. Sticky Thread Sticky: General info write-ups and stickies

    Started by 0rion, 02-27-2008 06:14 PM
    • Replies: 0
    • Views: 24,976
    02-27-2008, 06:14 PM Go to last post
  11.   Normal Threads  

  1. Help: Car won't start after warm.

    Started by DMAN, 06-29-2010 05:34 PM
    • Replies: 12
    • Views: 2,323
    07-02-2010, 03:23 PM Go to last post
  2. Question: rocker arms

    Started by william45, 07-02-2010 01:02 PM
    • Replies: 1
    • Views: 860
    07-02-2010, 02:13 PM Go to last post
  3. Help: Need a part

    Started by SMWS6TA, 06-26-2010 05:57 PM
    2 Pages
    1 2
    • Replies: 25
    • Views: 3,406
    07-02-2010, 04:47 AM Go to last post
  4. O2 sensors keep going out

    Started by dennis ss, 06-27-2010 07:33 AM
    2 Pages
    1 2
    • Replies: 26
    • Views: 8,129
    07-01-2010, 07:05 PM Go to last post
  5. 2000 camaro ss owner and new member!

    Started by saucycrossover1, 06-29-2010 03:45 PM
    • Replies: 5
    • Views: 984
    07-01-2010, 05:56 PM Go to last post
  6. Where to start?

    Started by crebrosseau, 06-30-2010 05:37 PM
    • Replies: 3
    • Views: 764
    07-01-2010, 05:02 PM Go to last post
  7. Moved: Got bit by the mod bug !!!!!

    Started by stew215, 06-30-2010 07:28 PM
    •  
    •  
  8. knock sensor

    Started by AB'sLs1, 06-29-2010 03:58 PM
    • Replies: 9
    • Views: 2,961
    07-01-2010, 06:11 AM Go to last post
  9. ls1 to ls6 swap help needed

    Started by nvmybird, 06-30-2010 10:19 PM
    • Replies: 1
    • Views: 915
    07-01-2010, 04:59 AM Go to last post
  10. lifter noise

    Started by rick50, 06-22-2010 02:33 PM
    2 Pages
    1 2
    • Replies: 33
    • Views: 16,947
    06-30-2010, 01:50 PM Go to last post
  11. Got a squeek

    Started by bsteff, 06-25-2010 07:12 PM
    • Replies: 10
    • Views: 872
    06-30-2010, 12:49 PM Go to last post
  12. Coolant sensor

    Started by F55c6, 06-29-2010 01:15 PM
    • Replies: 3
    • Views: 1,041
    06-30-2010, 09:58 AM Go to last post
  13. 4 speed or not?

    Started by tg580, 06-30-2010 02:51 AM
    • Replies: 5
    • Views: 1,196
    06-30-2010, 08:30 AM Go to last post
  14. Anyone using a 160amp alternator or higher?

    Started by JayTA98, 06-28-2010 06:34 PM
    • Replies: 5
    • Views: 1,214
    06-30-2010, 12:45 AM Go to last post
  15. Help: "service ride control"

    Started by periodoc95, 06-29-2010 02:14 PM
    • Replies: 4
    • Views: 2,497
    06-29-2010, 07:15 PM Go to last post
  16. P0102 & p0122

    Started by shady milkman, 06-29-2010 12:45 PM
    • Replies: 8
    • Views: 3,870
    06-29-2010, 06:25 PM Go to last post
  17. Help: No start / spin issue

    Started by ramairjohnny, 06-27-2010 06:53 PM
    • Replies: 5
    • Views: 970
    06-29-2010, 03:54 PM Go to last post
  18. My 2002 Z28

    Started by fastlane, 06-19-2010 10:58 AM
    • Replies: 15
    • Views: 2,382
    06-29-2010, 02:29 PM Go to last post
  19. ABS, BRAKE, and ASR lights coming on

    Started by JRENIGAR, 06-27-2010 07:27 AM
    • Replies: 15
    • Views: 9,277
    06-29-2010, 02:05 PM Go to last post
  20. Question Spark plug torque specs

    Started by firemandan1700, 06-29-2010 05:02 AM
    • Replies: 1
    • Views: 1,787
    06-29-2010, 05:15 AM Go to last post
  21. Bleeding system

    Started by zeetwentyeight, 06-23-2010 05:22 PM
    2 Pages
    1 2
    • Replies: 30
    • Views: 4,627
    06-29-2010, 01:07 AM Go to last post
  22. torque relocating bracket

    Started by JayTA98, 06-28-2010 06:45 PM
    • Replies: 0
    • Views: 454
    06-28-2010, 06:45 PM Go to last post
  23. Help: Rough Start

    Started by TransAmPhantom, 06-28-2010 06:04 PM
    • Replies: 4
    • Views: 638
    06-28-2010, 06:41 PM Go to last post
  24. WTF is this guy talking about?

    Started by Dewman, 06-27-2010 05:06 PM
    • Replies: 11
    • Views: 1,200
    06-28-2010, 06:22 PM Go to last post
  25. so my 98 ls1 idles at about 1025 when warm.

    Started by goof4080, 06-26-2010 09:33 AM
    • Replies: 15
    • Views: 1,044
    06-28-2010, 05:49 PM Go to last post
  26. Question: Emission question

    Started by 98maro, 06-28-2010 11:29 AM
    • Replies: 6
    • Views: 894
    06-28-2010, 12:12 PM Go to last post
  27. HID's flickered out

    Started by transAMchubby, 06-20-2010 07:05 PM
    • Replies: 1
    • Views: 554
    06-27-2010, 08:18 PM Go to last post
  28. SES and a tstat?

    Started by zeetwentyeight, 06-26-2010 07:38 AM
    2 Pages
    1 2
    • Replies: 21
    • Views: 1,960
    06-27-2010, 07:06 PM Go to last post
  29. Idle problem

    Started by richard head, 06-26-2010 07:18 PM
    • Replies: 7
    • Views: 906
    06-27-2010, 04:14 PM Go to last post
  30. injectors

    Started by mike keller, 06-26-2010 07:39 PM
    • Replies: 1
    • Views: 830
    06-27-2010, 06:50 AM Go to last post

Page 137 of 467 FirstFirst ... 378797107117133134135136137138139140141157167177187237287337387437 ... LastLast

Forum Information and Options

Moderators of this Forum
Users Browsing this Forum

There are currently 46 users browsing this forum. (0 members & 46 guests)


Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •