General Help

This is a list of discussions in the General Help forums at the LS1.com | GM LSx Performance Forum. The General Help forum Get help with your Problems and Installs

  1.   Sticky Threads  

  2. Sticky Thread Sticky: Vibrating Headlamp?

    Started by Whamhammer, 08-19-2019 06:03 AM
    • Replies: 10
    • Views: 2,276
    Yesterday, 07:59 PM Go to last post
  3. Sticky Thread Sticky: Foot Well Lighting

    Started by SMWS6TA, 07-26-2016 09:34 AM
    • Replies: 7
    • Views: 9,049
    12-29-2019, 07:32 PM Go to last post
  4. Sticky Thread Sticky: How to bring your car out of the dark ages...HID/LED

    Started by SMWS6TA, 07-07-2016 02:16 PM
    • Replies: 11
    • Views: 11,315
    01-22-2019, 08:04 AM Go to last post
  5. Sticky Thread Sticky: List of Sensors and What They Do

    Started by Knight, 08-18-2011 04:43 PM
    2 Pages
    1 2
    • Replies: 24
    • Views: 58,566
    10-15-2018, 09:32 AM Go to last post
  6. Exclamation Sticky Thread Sticky: Body Control Module - Repairing Bad Solder Joints

    Started by gokillyourself, 04-29-2012 01:10 PM
    • Replies: 9
    • Views: 12,877
    01-25-2018, 10:13 AM Go to last post
  7. Poll Sticky Thread Sticky: Poll: I'm a Oil Junkie

    Started by Sarge, 08-21-2005 08:50 AM
    70 Pages
    1 2 3 4 5 ... 70
    • Replies: 1,383
    • Views: 354,634
    10-17-2017, 07:32 AM Go to last post
  8. Sticky Thread Sticky: Technical info write-ups and stickies

    Started by 0rion, 02-27-2008 07:02 PM
    • Replies: 4
    • Views: 26,471
    05-29-2014, 08:18 AM Go to last post
  9. Sticky Thread Sticky: Torque specs for LS1 motors

    Started by konigandy6, 06-27-2013 07:34 AM
    • Replies: 2
    • Views: 44,957
    06-28-2013, 07:43 AM Go to last post
  10. Sticky Thread Sticky: General info write-ups and stickies

    Started by 0rion, 02-27-2008 07:14 PM
    • Replies: 0
    • Views: 21,534
    02-27-2008, 07:14 PM Go to last post
  11.   Normal Threads  

  1. Running Warm

    Started by SamD_Ind, 07-03-2010 06:45 AM
    • Replies: 3
    • Views: 721
    07-03-2010, 08:59 AM Go to last post
  2. ls1 wont start

    Started by FutureWS6, 07-02-2010 06:58 PM
    • Replies: 4
    • Views: 800
    07-02-2010, 09:07 PM Go to last post
  3. Help my centering pin fell out of the cam

    Started by sedric, 07-02-2010 06:20 PM
    • Replies: 4
    • Views: 788
    07-02-2010, 07:53 PM Go to last post
  4. Oil level sensor questions

    Started by johngoodman, 07-02-2010 03:07 PM
    • Replies: 1
    • Views: 987
    07-02-2010, 04:25 PM Go to last post
  5. Help: Car won't start after warm.

    Started by DMAN, 06-29-2010 06:34 PM
    • Replies: 12
    • Views: 2,251
    07-02-2010, 04:23 PM Go to last post
  6. Question: rocker arms

    Started by william45, 07-02-2010 02:02 PM
    • Replies: 1
    • Views: 766
    07-02-2010, 03:13 PM Go to last post
  7. Help: Need a part

    Started by SMWS6TA, 06-26-2010 06:57 PM
    2 Pages
    1 2
    • Replies: 25
    • Views: 3,264
    07-02-2010, 05:47 AM Go to last post
  8. O2 sensors keep going out

    Started by dennis ss, 06-27-2010 08:33 AM
    2 Pages
    1 2
    • Replies: 26
    • Views: 7,796
    07-01-2010, 08:05 PM Go to last post
  9. 2000 camaro ss owner and new member!

    Started by saucycrossover1, 06-29-2010 04:45 PM
    • Replies: 5
    • Views: 909
    07-01-2010, 06:56 PM Go to last post
  10. Where to start?

    Started by crebrosseau, 06-30-2010 06:37 PM
    • Replies: 3
    • Views: 728
    07-01-2010, 06:02 PM Go to last post
  11. Moved: Got bit by the mod bug !!!!!

    Started by stew215, 06-30-2010 08:28 PM
    •  
    •  
  12. knock sensor

    Started by AB'sLs1, 06-29-2010 04:58 PM
    • Replies: 9
    • Views: 2,885
    07-01-2010, 07:11 AM Go to last post
  13. ls1 to ls6 swap help needed

    Started by nvmybird, 06-30-2010 11:19 PM
    • Replies: 1
    • Views: 889
    07-01-2010, 05:59 AM Go to last post
  14. lifter noise

    Started by rick50, 06-22-2010 03:33 PM
    2 Pages
    1 2
    • Replies: 33
    • Views: 16,001
    06-30-2010, 02:50 PM Go to last post
  15. Got a squeek

    Started by bsteff, 06-25-2010 08:12 PM
    • Replies: 10
    • Views: 845
    06-30-2010, 01:49 PM Go to last post
  16. Coolant sensor

    Started by F55c6, 06-29-2010 02:15 PM
    • Replies: 3
    • Views: 1,006
    06-30-2010, 10:58 AM Go to last post
  17. 4 speed or not?

    Started by tg580, 06-30-2010 03:51 AM
    • Replies: 5
    • Views: 1,141
    06-30-2010, 09:30 AM Go to last post
  18. Anyone using a 160amp alternator or higher?

    Started by JayTA98, 06-28-2010 07:34 PM
    • Replies: 5
    • Views: 1,175
    06-30-2010, 01:45 AM Go to last post
  19. Help: "service ride control"

    Started by periodoc95, 06-29-2010 03:14 PM
    • Replies: 4
    • Views: 2,339
    06-29-2010, 08:15 PM Go to last post
  20. P0102 & p0122

    Started by shady milkman, 06-29-2010 01:45 PM
    • Replies: 8
    • Views: 3,727
    06-29-2010, 07:25 PM Go to last post
  21. Help: No start / spin issue

    Started by ramairjohnny, 06-27-2010 07:53 PM
    • Replies: 5
    • Views: 929
    06-29-2010, 04:54 PM Go to last post
  22. My 2002 Z28

    Started by fastlane, 06-19-2010 11:58 AM
    • Replies: 15
    • Views: 2,353
    06-29-2010, 03:29 PM Go to last post
  23. ABS, BRAKE, and ASR lights coming on

    Started by JRENIGAR, 06-27-2010 08:27 AM
    • Replies: 15
    • Views: 9,036
    06-29-2010, 03:05 PM Go to last post
  24. Question Spark plug torque specs

    Started by firemandan1700, 06-29-2010 06:02 AM
    • Replies: 1
    • Views: 1,710
    06-29-2010, 06:15 AM Go to last post
  25. Bleeding system

    Started by zeetwentyeight, 06-23-2010 06:22 PM
    2 Pages
    1 2
    • Replies: 30
    • Views: 4,429
    06-29-2010, 02:07 AM Go to last post
  26. torque relocating bracket

    Started by JayTA98, 06-28-2010 07:45 PM
    • Replies: 0
    • Views: 437
    06-28-2010, 07:45 PM Go to last post
  27. Help: Rough Start

    Started by TransAmPhantom, 06-28-2010 07:04 PM
    • Replies: 4
    • Views: 616
    06-28-2010, 07:41 PM Go to last post
  28. WTF is this guy talking about?

    Started by Dewman, 06-27-2010 06:06 PM
    • Replies: 11
    • Views: 1,140
    06-28-2010, 07:22 PM Go to last post
  29. so my 98 ls1 idles at about 1025 when warm.

    Started by goof4080, 06-26-2010 10:33 AM
    • Replies: 15
    • Views: 999
    06-28-2010, 06:49 PM Go to last post
  30. Question: Emission question

    Started by 98maro, 06-28-2010 12:29 PM
    • Replies: 6
    • Views: 857
    06-28-2010, 01:12 PM Go to last post

Page 136 of 466 FirstFirst ... 368696106116132133134135136137138139140156166176186236286336386436 ... LastLast

Forum Information and Options

Moderators of this Forum
Users Browsing this Forum

There are currently 51 users browsing this forum. (0 members & 51 guests)


Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 15 replies or 150 views
Hot thread with unread posts
More than 15 replies or 150 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •