Results 1 to 3 of 3

6 liter problems

This is a discussion on 6 liter problems within the General Help forums, part of the LSx Technical Help Section category; Hi all. I'm new to the forum so if this is not the correct place to ask this, please let ...

  1. #1
    Junior Member
    Join Date
    Jun 2022
    Location
    Buote
    Posts
    3

    red
    67 c10

    6 liter problems

    Hi all. I'm new to the forum so if this is not the correct place to ask this, please let me know. I am hoping someone can help me. I recently put a 6L twin turbo in my c10 with a standalone harness and an e38 ecm. My problem is from the first cold start up the engine will reach 200 deg. in 2 min. 13 seconds (I timed It) and it will continue to clime. I thought it might be a lean issue so I added fuel in 5% increments until it was very rich and it still will overheat in 2 min. from cold. I then thought it might be airlocked so I drained the cooling system and refilled it using a vacuum filler. the engine is a fresh rebuild with ls9 head gaskets a Holley mid mount serpentine system. I did some looking and it looks like the ls9 gaskets have a tab that stick out buy the second cylinder back and that is where the tabs are so I be leave the gaskets are in correct. I have also replace the thermostat that came with the Holley kit with a gm unit with no change. If anyone has any thought I would really appreciate it.

    Thanks Jason
    Last edited by c10sb; 06-21-2022 at 05:33 PM.

  2. #2
    Junior Member
    Join Date
    Jun 2022
    Location
    Buote
    Posts
    3

    red
    67 c10

    Im still fighting this problem. I have yet to see my thermastat open. I replace the thermasta that came with the holley kit with a gm unit but it still will not open. I have line connect to all four steam ports on the heads and have steady coolant flow at all four corners. I also remove a heater hose at the heater core (the one that retuns coolant back to the thermastat and poured coolant down the hose until it started running out of the heater core to make sure I had coolant at the thermastat. still the thermastat will not open, please if anyone has any thought Im willing to try anything at this point

    thank you
    jason

  3. #3
    Junior Member
    Join Date
    Jun 2022
    Location
    Buote
    Posts
    3

    red
    67 c10

    I just removed the thermostat and drilled 3 1/8" holes in it to see if that would help get hot coolant to the back of the thermostat no change still getting hot without thermostat opening

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 6.4 liter hemi?
    By Ramairgod84 in forum Kill Stories
    Replies: 16
    Last Post: 06-09-2010, 02:53 PM
  2. 408 Liter??
    By afattitude in forum General Help
    Replies: 1
    Last Post: 10-30-2008, 05:49 AM
  3. V-6 3.8 Liter Ram Air?
    By Maro99 in forum External Engine
    Replies: 1
    Last Post: 06-23-2006, 05:28 AM
  4. GM 8.0 liter's Who has them?
    By Blown25thT/A in forum GM Trucks
    Replies: 18
    Last Post: 03-30-2006, 07:49 PM
  5. 6.0 liter ram air car from the factory
    By wildmann003 in forum General Help
    Replies: 14
    Last Post: 11-30-2005, 03:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •