Results 1 to 2 of 2

4 codes follow LS9 cam,head,header swap on LM4 5.3 in SSR

This is a discussion on 4 codes follow LS9 cam,head,header swap on LM4 5.3 in SSR within the General Help forums, part of the LSx Technical Help Section category; Began project to add OBX SS headers w/Cats to 2004 Chevy SSR 5.3 LM4 engine. Took off heads to clean ...

  1. #1
    Junior Member
    Join Date
    May 2021
    Location
    Tulsa
    Posts
    4

    Red
    2004 Chevy SSR

    Red face 4 codes follow LS9 cam,head,header swap on LM4 5.3 in SSR

    Began project to add OBX SS headers w/Cats to 2004 Chevy SSR 5.3 LM4 engine. Took off heads to clean up ports while there. Added GM LS9 Cam as what I thought to be an inexpensive add while in there for $175. once assembled it had starting difficulties. I realized then I had to add the Gen IV timing cover with Cam sensor, correct cam sprocket, and related wire to run from new cam sensor on front, back to the original cam sensor plug on the back of my Gen 3 block (with great difficulty once intake was on). Started great but after an hour of break-in it started adding codes. Realized my starter wire was on a header tube and melted into the wire. As I pried it off the tube and to get clearance, it sparked with a huge pop!. unhooked battery...looked again, seems okay, just a huge dent in it. After finishing the radiator stuff and starting...Now getting following 4 codes tonight after driving it for a day.
    P0343 Cam Pos sensor circuit HIGH voltage
    P0342 Cam Pos sensor circuit LOW voltage
    P0155 H02S Heater Performance Bank 2 sensor 1
    P0135 Heated O2 sensor (HO2S) Heater Perf Bank 1 sensor 1

    Deleted them all and they come back.
    Does not run right. sounds okay, but no low end power. Starts difficult like it did before I added the cam sensor relocation to the front.

    could the spark from the starter mess have shorted something? where do I start testing? the starter? the cam sensor? I'm not an electrical guy....and i really don't want to drop a header to remove a starter and starter wire....

    Any help appreciated.
    Last edited by TJmoneybags; 05-25-2021 at 08:27 AM.

  2. #2
    Junior Member
    Join Date
    May 2021
    Location
    Tulsa
    Posts
    4

    Red
    2004 Chevy SSR

    so I figured out that i have the wrong cam sprocket and need to change that to a 1x sprocket. any electrical assistance?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Broken header/head bolt.
    By 98maro in forum General Help
    Replies: 14
    Last Post: 01-14-2011, 11:12 PM
  2. Header bolt broke off in head?
    By usafshelley in forum External Engine
    Replies: 10
    Last Post: 04-27-2010, 07:48 AM
  3. Intake swap and no codes thrown?
    By Wheeler99WS6 in forum External Engine
    Replies: 1
    Last Post: 06-18-2007, 09:47 PM
  4. Header Help / Cam Help / Head Help
    By HOUPTIE03 in forum Corvette
    Replies: 2
    Last Post: 02-19-2007, 04:07 PM
  5. after header install, throwing a few codes...need help
    By groundpoundinlt1 in forum General Help
    Replies: 6
    Last Post: 11-10-2006, 11:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •