Page 335 of 335 FirstFirst ... 3585135185235285295305315331332333334335
Results 6,681 to 6,690 of 6690
Like Tree1610Likes

What did you do with your Trans Am today?

This is a discussion on What did you do with your Trans Am today? within the Firebird / WS6 forums, part of the Vehicle Specific category; pan hard bar?...

  1. #6681
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,318

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    What did you do with your Trans Am today?

    pan hard bar?
    http://www.ls1.com/forums/f7/my-6-liter-build-174257/

    http://www.ls1.com/forums/f8/my-8-8-rear-build-165553/

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, 104mm Air Lid & Line Lock, Catch Can, Stage 2 T56 w/Viper shaft, PRO 5.0 Shifter, Tick MC, SPEC Stg3+ Clutch, QT SFI BH, MWC DSL, UMI: SFC, PHB, LCA's, LCA Relocation Brackets & TA, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    00 FB Vert

    Horsepower never lies, but is often lied about!

  2. #6682
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,318

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Quote Originally Posted by pajeff02 View Post
    That is beyond destroyed.

    Gotta love the southern heat and cheap plastic.

    To be honest not sure what I want to do. I wish they made a carbon fiber replacement. I'd buy it knowing that won't crack.

  3. #6683
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,479

    Cayanne
    98 Z28 Vert M6

    Quote Originally Posted by SMWS6TA View Post
    pan hard bar?
    I greased that up (along with the upper bar)... I'm thinking that it's the spring making metal to metal contact on the spring perch on the axle. I'm going to try lowering the axle and putting a piece of hose around the bottom of the spring.

    Only thing I'm worried about is torquing down the shock nut after putting it back together. Last time, I had a hard time getting that thing to the right torque (I think for whatever reason the bolt/nut on the other side was slipping or something...)
    Lid, Throttle Body, LS6 Intake, Heads, Cam, Magnaflow, LS7 Clutch, SFCs, STB, Panhard Bar, Strano Springs, Hollow Sway Bars, Poly/Roto LCAs, Konis, MGW Shifter

  4. #6684
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,318

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Oh the joy of vert ownership.



    Hairline crack has caused all the fluid to leak out and down the fender.

    Made a trip to Lowes and got a new t fitting and a new extension





    which failed, too long. So another trip to another store this morning, this time the local NAPA store had what I needed.



    Success, well after bleeding the air and refilling the fluid.
    pajeff02 likes this.

  5. #6685
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    11,318

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    I swear to God my Trans Am is a vindictive, jealous bitch. Every time I work on another car it decides it wants more "attention".

    Drove to Pensacola and as I was leaving the damn radiator blew the upper hose off, the tube broke off. I hate plastic radiators.


    This time I'm getting an all aluminum. Found one for a decent price, just have to wait till the beginning of the month to get it.


  6. #6686
    Moderator
    Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Age
    34
    Posts
    3,625

    2016 Camaro SS - Summit
    2001 Trans Am WS6 - NBM

    Installed LEDs on all taillights and fog lights, and installed an electronic flasher. Still hunting a weird issue on the front right DRL/blinker that's been bugging me for a while now. It works with lights/parking lights on, and blinks when it's supposed to. It does not work at all without the lights on. I've got replacement LEDs coming in today, we'll see if that helps. The ones in the front now are cheap Sylvania LED.

    2016 Summit White 1SS - The DD - Mishimoto catch can, Solo axleback & secondary cat delete, LED sidemarkers & reverse lights, head/taillight blackout, RCC custom badges
    2001 NBM Trans Am WS6 - Torquer V2 cam, Yank 3000 stall, Transgo kit, Racetronix fuel pump, TSP LTs, Magnaflow catback, 17x9.5/17x11 TTII's
    2000 Arctic White SS #1667 - Sold

  7. #6687
    Veteran 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,530

    Red
    02 35th LE Camaro SS

    If you stop driving them, the problems go away =)

    Sent from my SM-G955U using Tapatalk
    pajeff02 likes this.
    Boost gets you laid, unless your name is Jon.

  8. #6688
    Moderator
    Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Age
    34
    Posts
    3,625

    2016 Camaro SS - Summit
    2001 Trans Am WS6 - NBM

    We're gluttons for punishment Jon.

    Replaced reverse lights, side markers and front turn signal/DRL with new LEDs. New lights solved the no DRL/blinker problem on the front passenger side. Old Sylvania LED pin got stuck in the socket, had some fun getting it out. Never again. Last incandescent bulbs are the headlights and third brake, but I've spent too much on both cars lately, so it will have to wait a bit.

  9. #6689
    Member TransAmTerry's Avatar
    Join Date
    May 2010
    Location
    Abingdon, Md
    Posts
    247

    black
    02 TransAm Ramair WS6

    Quote Originally Posted by Naaman View Post
    Trying to hunt down a God-awful squeak in the rear passenger side area. From the driver seat, it sounds like it's coming from inside the fender...

    Got under the car and greased up all the rear suspension parts, but still the squeak remains... grumble, grumble...

    Has anyone else had such a squeak and/or have any other clues?
    Yes, mine sounds like crickets coming from that area. Never had it until I had aftermarket performance suspension parts installed. Kinda comes and goes. One of these days I'm gonna back it up on ramps to see what I can see. Until then that kick-ass sound system I have handles that noise quite nicely !
    '02 Black RamAir M6--Kooks LTH, Magnaflo, Lowered Eibach springs and Bilstien shocks, Tuned By Frost, K&N & SLP box, Smooth bellows, polished TB, Spohn perf. suspension, shock tower brace. UMI 3point SFC. Front & side splitters w/ canards. American Racing 18" wheels & Mich. Pilot SS titres
    '76 LagunaS3 - 355ci , 350 turbo, 3:55's

  10. #6690
    Senior Member Whamhammer's Avatar
    Join Date
    Sep 2010
    Location
    Bel Air, Maryland
    Posts
    1,484

    Silver
    '02 Trans Am WS-6, 6M

    Quote Originally Posted by TransAmTerry View Post
    Yes, mine sounds like crickets coming from that area. Never had it until I had aftermarket performance suspension parts installed. Kinda comes and goes. One of these days I'm gonna back it up on ramps to see what I can see. Until then that kick-ass sound system I have handles that noise quite nicely !
    Mine is usually left front, I think mine is the shock mount or something.
    SLP Air Lid/Smooth Bellows
    Kooks Emissions LT Headers/Catted Y pipe
    NGK TR55 plugs
    Magnaflow Cat-back
    Spohn Front Upper Tubular Control Arms
    UMI Front Lower Tubular Control Arms
    UMI Front Sway Bar
    UMI Rear Lower Control Arms/ Adjustable Panhard Rod
    UMI Welded-on Two Piece Subframe Connectors
    Factory C5 Z06 17x9.5 wheels w/ 285-40-17 Continental Extreme Contact DW's all the way around.
    Dyno Dynamics dynoed @:
    356 rwhp, 360 rwlb/tq

Page 335 of 335 FirstFirst ... 3585135185235285295305315331332333334335

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. new guy just got my first trans am today
    By roger_johnson2002 in forum New Member Introductions
    Replies: 9
    Last Post: 07-14-2011, 08:35 AM
  2. Found this on the windshield of my Trans Am today
    By ls1camino in forum Almost Anything Goes
    Replies: 60
    Last Post: 03-10-2009, 12:11 PM
  3. Got into an accident in the Trans Am today
    By ls1camino in forum Almost Anything Goes
    Replies: 30
    Last Post: 09-21-2008, 04:32 PM
  4. Just got my Trans Am today!
    By vannatte in forum Firebird / WS6
    Replies: 34
    Last Post: 09-20-2007, 09:57 AM
  5. First time at Track today!!! 2000 Trans Am ws6
    By gimmeadonut in forum Drag Racing
    Replies: 1
    Last Post: 11-12-2005, 01:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •