Results 1 to 1 of 1

P0650, P1626, U1000 - No Speedo, Tach, Radio and more

This is a discussion on P0650, P1626, U1000 - No Speedo, Tach, Radio and more within the Firebird / WS6 forums, part of the Vehicle Specific category; Hello All, I am kind of lost of where to even start on my 2001 Trans Am Ws6 Vert...... Car ...

  1. #1
    Junior Member
    Join Date
    Jul 2016
    Location
    Florida
    Posts
    10

    Navy
    2001 Pontiac Trans Am WS6

    P0650, P1626, U1000 - No Speedo, Tach, Radio and more

    Hello All,

    I am kind of lost of where to even start on my 2001 Trans Am Ws6 Vert...... Car ran great last night. Heading to work this morning and the Dash light where not working. I figure its a fuse, no big deal. Turned the radio on and drove to work. At work I popped the trunk pulled out my scuba tanks and pressed on.

    When I was leaving work, the Trunk Switch on Key Fob would not work, I used the key dropped gear in and got into the car. This time, no gauges and worse no Radio, no speedo or Tac. Found the Power Accessories fuse was blown. I replaced it and the oil, tmp gauges started working, no Gas Gauge. Drove the 45 miles home with no engine issue. Put the scanner on it and got these 3 codes.

    Anyone have an idea? Ignition switch, maybe? or Computer? I have a 2001 Firebird V6, could I swap the ECM?

    Another post lists - 650-the mil light needs to be fixed. Whats the Mil Light?



    P0650 - Malfunction Indicator Lamp Control Circuit Malfunction
    P1626 - Theft Deterrent Fuel Enable Signal Not Received
    u1000 class 2 data link malfunction
    Last edited by MikadoWu; 02-27-2021 at 04:29 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Autometer speedo and tach
    By 65ls1 in forum Stereo and Electronics
    Replies: 3
    Last Post: 12-21-2008, 07:04 AM
  2. GTO Speedo run. 53-114
    By juiced99ws6 in forum Almost Anything Goes
    Replies: 9
    Last Post: 06-07-2008, 02:31 PM
  3. Replies: 29
    Last Post: 01-31-2008, 11:45 AM
  4. trouble code p0650
    By Chevy350 in forum Camaro / SS
    Replies: 1
    Last Post: 07-10-2007, 06:10 PM
  5. tach and speedo not working
    By hrsepwrfrk in forum General Help
    Replies: 3
    Last Post: 03-26-2006, 10:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •