No Recent Activity

2 Visitor Messages

  1. Hello Steve,

    Thank you very much for the advice. I checked the wiring yesterday and will do a cleaner inspection today. Not sure what that is but will look it up. I cleared the code yesterday and the SES came back on again as the engine idle at a stop light. Yah, there are too many little variables to check out in diagnosing this symptom.

    It did cross my mind that the IAT sensor could be the cause....... My engine had knocks so I Seafoam the Tank, the heads, and did MAF clean 2 months ago. This actually eliminated the knocks... when I pulled the intake apart, I found out the previous owner through one of those Tornado gadgets in between the intake hose....... more than that, I found out that the lot mechanic didn't quite connect the air hose running from the filter into the throttle properly...... the upper part of the hose was connected while the lowered was loosely not adjoined. My engine was sucking in bay air bypassing the filter. I'm afraid of these mechanics. I bought this TA used off of a lot where the engine had to be dropped to fix the engine seal that was leaking.

    At any rate, the throttle was filthy as hell from the poor hose connection. Do you have any suggestions on how to check the IAT to see if it's properly working? That's the Thin Stringy gadget in the throttle right?

    Thanks buddy,
    Matthew
  2. View Conversation
    Well, they both could be related to the hesitation you are talking about. Is your IAT unplugged? It is the Intake Air Temperature sensor, it helps your PCM determine how much fuel, spark tables. It is located in your air intake, just behind the air filter. A two wire sensor. Generally the Cat Eff. code is from just that, the efficiency. It usually causes no problems besides the Check Engine light on, but if it is broken internally causing a restriction that could also cause your acceleration problem. I would look at the IAT code first for your problem.
    Steve
Showing Visitor Messages 1 to 2 of 2
About matthewaqui

Basic Information

Date of Birth
February 4
About matthewaqui
Color of Car:
Red/Silver/Black/Red
Year & Model Car:
TA-G8-Expe-L200-Camaro
Biography:
Enjoy Driving my TAs and Connecting with others on this Forum
Location:
Lakewood, California
Interests:
Working on my Trans Am and meeting Local TA Owners
Occupation:
Web Developer, CAD Drafter

Statistics


Total Posts
Total Posts
779
Posts Per Day
0.20
Last Post
Red Birds Unite 11-06-2009 12:11 PM
Visitor Messages
Total Messages
2
Most Recent Message
03-03-2008 08:15 AM
General Information
Last Activity
03-23-2017 10:43 AM
Join Date
07-09-2007
Referrals
1
iTrader Profile Recent Ratings
iTrader:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback For matthewaqui
View Complete Feedbacks for matthewaqui
  Past
Month
Past
6 Months
Past
12 Months
  0 0 0
  0 0 0
  0 0 0