Results 1 to 18 of 18
Like Tree2Likes
  • 1 Post By ShadeTreee
  • 1 Post By ShadeTreee

First Build, I tried to Be different

This is a discussion on First Build, I tried to Be different within the New Member Introductions forums, part of the Site Feedback / Administrative Requests category; New guy here from Martinsville, Indiana. My very first build is something a little different. I came across a Rolling ...

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Location
    Indiana
    Posts
    8

    Red
    2010 Titan

    First Build, I tried to Be different

    New guy here from Martinsville, Indiana.

    My very first build is something a little different. I came across a Rolling Chassis of a Nissan Titan at an auction. So I'm dropping a 5.3L out of a 2005 Avalanche total.

    I don't have a mentor but I do have a couple guys to bounce a question off of every once in a while. I'm building this for a daily driver and a Graduation Present for my Son as he get's our of College.

    Does anyone Else know if anyone else has done a Titan. I like to think I'm the only one.

    engine.jpgenginefit.jpg
    SMWS6TA likes this.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,792

    Black & Blue
    '02 WS.6 / '07 Suburban

    Damn nice work. On a four month countdown?

    Welcome to the site!

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Awesome.

  4. #4
    Member hardtrailz's Avatar
    Join Date
    Jul 2016
    Location
    SE IN
    Posts
    173

    Blue Green Chameleon
    2001 Trans Am Vert

    Welcome from a fellow Hoosier.

    I have not seen a Titan yet, Best of Luck!
    2001 Trans Am Vert

  5. #5
    Junior Member
    Join Date
    Jan 2018
    Location
    Indiana
    Posts
    8

    Red
    2010 Titan

    I think as soon as I get a fuel pressure issue fixed, I'm roadworthy, (said everyone)

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,792

    Black & Blue
    '02 WS.6 / '07 Suburban

    What's the suspected issue?

  7. #7
    Junior Member
    Join Date
    Jan 2018
    Location
    Indiana
    Posts
    8

    Red
    2010 Titan

    Quote Originally Posted by pajeff02 View Post
    What's the suspected issue?
    Right now I don't quite understand the problem, I'm getting 19lbs at the fuel rail but the pump, filter/regulater/, and lines in front of the pump are all new. the fuel pump is lower than the tank.

    The only thing I found is that there is a restriction in the return fuel line, Which doesn't seem to me that it should cause that much problem.

    I'm going to replace the rest of the fuel lines behind the pump this weekend.

    Right now I know the symptom but am not 100% sure of the cause that I have found.

  8. #8
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    Yeah there should be around 56-60 psi at the rails for stock LS base engines.

    Are you using the Titan fuel pump and filter?

  9. #9

  10. #10
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    They seem to be right.

  11. #11
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,792

    Black & Blue
    '02 WS.6 / '07 Suburban

    Kind of an odd issue. Curious as to what you find.

  12. #12
    Junior Member
    Join Date
    Jan 2018
    Location
    Indiana
    Posts
    8

    Red
    2010 Titan

    AAAAAAHHHH Got the truck running today. It was the BRAND NEW fuel filter/pressure regulator was only passing 19lbs, I re-plumbed all the fuel lines before I jumped around the pressure Regulator and the truck started right up.

    I've spent 2 weeks tracking down everything but the regulator. I bought it New so I wouldn't have to worry about the regulator and pump. I even bought new heavier gauge wire Just in case I was getting a voltage drop. What a pain!!!!
    pajeff02 likes this.

  13. #13
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    First Build, I tried to Be different

    I feel ya'. I spent 4 months chasing that issue on mine. But it would just cut off randomly.
    http://www.ls1.com/forums/f7/my-6-liter-build-174257/

    http://www.ls1.com/forums/f8/my-8-8-rear-build-165553/

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, 104mm Air Lid & Line Lock, Catch Can, Stage 2 T56 w/Viper shaft, PRO 5.0 Shifter, Tick MC, Monster Stg 4 Clutch, QT SFI BH, MWC DSL, UMI: SFC, PHB, LCA's, LCA Relocation Brackets & TA, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    00 FB Vert

    Horsepower never lies, but is often lied about!

  14. #14
    Junior Member
    Join Date
    Jan 2018
    Location
    Indiana
    Posts
    8

    Red
    2010 Titan

    Is there a reliable fuel pressure regulator out there?

  15. #15
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    First Build, I tried to Be different

    hard to say with this being a hybrid of a build.

    I'm wondering if you can take the regulator from f body or a truck and swap over to the vehicle's system.

  16. #16
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,792

    Black & Blue
    '02 WS.6 / '07 Suburban

    Chasing down issues is always a learning experience. Nice work.

  17. #17
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,934

    Navy Blue Metallic
    98 T/A w/ mods, 00 FBVert

    My regulator kept shorting out, I chased everything, Racetronic wire harness, grounds, fuel pump, finally pulled the whole thing out of the tank and with a multimeter test the out puts on the regulator. MPITA. It passed, I was like WTF and wanted to burn the car to the ground at this point. Lucky for me calmer thoughts prevailed and I said F' it and got a new regulator. Put it in and all fixed.

  18. #18
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    37
    Posts
    2,004

    Red
    1998 Pontiac Trans Am

    Some guys have tried to use a Vortech or Procharger FMU. Might be something to look into. I'm a little iffy on it because if I'm correct that regulator is PCM controlled. There is a rumor about an AC Delco FPR that has a mechanical adjustment that will work but I couldn't find any info. Just unicorn rumors. Nice swap though looks really good and welcome to the board!
    98 WS6 M6 ASC #2647
    Forged Custom 408 w/Vortec YSi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 440 LSX build
    By cam02ss in forum General Help
    Replies: 6
    Last Post: 07-30-2012, 05:34 PM
  2. If you build it
    By Speedy_Gonzales in forum Almost Anything Goes
    Replies: 6
    Last Post: 04-03-2011, 12:23 PM
  3. new build est. hp?
    By 96z28man in forum LT1
    Replies: 4
    Last Post: 03-13-2011, 03:54 PM
  4. 500CI Chevy LS1 Engine Build - How To Build A 500C
    By Ed Blown Vert in forum Camaro / SS
    Replies: 0
    Last Post: 02-17-2009, 07:10 PM
  5. I want to build up the .....
    By clg82 in forum Drivetrain
    Replies: 8
    Last Post: 09-01-2007, 11:06 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •