Results 1 to 4 of 4

Trouble code, need help

This is a discussion on Trouble code, need help within the Computer & Tuning forums, part of the LSx Technical Help Section category; The check engine light came on in my 99 T/A. I bought an OBDII code reader and the code PO442 ...

  1. #1
    Member wicked1's Avatar
    Join Date
    Oct 2005
    Location
    West Virginia
    Posts
    104

    Black
    1999 Trans Am

    Trouble code, need help

    The check engine light came on in my 99 T/A. I bought an OBDII code reader and the code PO442 came up. The book says that this is Evaporitive EmissionControl system leak. I also noticed the car makes a whining noise kind of like a small vacume cleaner from the drivers side while at idle. As you rev it up the noise goes away, at idle it comes back. Does anyone know exactly what this code is? Thanks

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Buddy of mine had P0442. He tried replacing the gas cap first, kept coming back - ended up getting the system pressurized with smoke at a shop to find it (was a small leak in the gas fill tube somewhere). Yours could be something different. www.gearchatter.com/viewtopic8854.php Whining/vacuum cleaner noise on start up sounds like the air pump, but should go off by itself after a couple minutes.

  3. #3
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    Quote Originally Posted by 2001NBMZ28 View Post
    Buddy of mine had P0442. He tried replacing the gas cap first, kept coming back - ended up getting the system pressurized with smoke at a shop to find it (was a small leak in the gas fill tube somewhere). Yours could be something different. www.gearchatter.com/viewtopic8854.php Whining/vacuum cleaner noise on start up sounds like the air pump, but should go off by itself after a couple minutes.
    Whining noise is the air pump going on/off for the 1st couple of minutes at start-up--
    Evap codes are usually gas cap or tank vent hose---you could have a leak in one of the hoses or one may have fallen off check them all from the routing from tank to engine compatment

  4. #4
    Member
    Join Date
    Apr 2007
    Location
    San Diego
    Posts
    177

    Red
    2002 T/A

    +2
    Have you filled up since this code appeared?
    Tighten the gas cap and reset the codes.
    See if this helps.
    Remember not to leave the engine running or the ignition in the on position while refueling.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trouble code
    By chevy2001 in forum GM Trucks
    Replies: 0
    Last Post: 10-31-2007, 08:57 PM
  2. Trouble Code Help?
    By SS_Crazy in forum Camaro / SS
    Replies: 1
    Last Post: 05-27-2007, 12:02 PM
  3. Trouble Code
    By zachjl in forum General Help
    Replies: 1
    Last Post: 04-24-2006, 01:50 PM
  4. Trouble code help
    By GLUMAKER in forum General Help
    Replies: 5
    Last Post: 04-10-2006, 06:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •