Results 1 to 8 of 8

Trip odometer resets itself

This is a discussion on Trip odometer resets itself within the Computer & Tuning forums, part of the LSx Technical Help Section category; My wife and I just bought a 99 T/A and when ever the key is turned off then back on ...

  1. #1
    My Last Name is a Drink! Martini2's Avatar
    Join Date
    Oct 2007
    Location
    Converse, TX
    Age
    36
    Posts
    27

    Red
    1999 Trans Am

    Trip odometer resets itself

    My wife and I just bought a 99 T/A and when ever the key is turned off then back on again the trip odometer is reset to 0? Also after strarting the car, the tach and speedo jump up and wont read until they 0 out. Also the gas gauge will drop to E after startup then read what ever ammount of fuel is in the tank.
    From what the owner told me, the comp. has been changed once. Any help would be great.

    B

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    sounds like the battery is starting to give out. check the cable connections for being loose/corroded.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Yep, have the battery tested. Low voltage on the '99 cars can cause the trip to reset/gauge sweep on startup if the cluster wasn't changed - there is a TSB on it.

  4. #4
    My Last Name is a Drink! Martini2's Avatar
    Join Date
    Oct 2007
    Location
    Converse, TX
    Age
    36
    Posts
    27

    Red
    1999 Trans Am

    Thanks guys, I did some searching of the interweb after I posted this and came up with the same solution. I am going to my dads to use is battery charger to see what it is at.

  5. #5
    My Last Name is a Drink! Martini2's Avatar
    Join Date
    Oct 2007
    Location
    Converse, TX
    Age
    36
    Posts
    27

    Red
    1999 Trans Am

    Does anyone know if I can just change the cluster to a different year? Would that fix the problem?

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I wouldn't worry about changing the cluster, a good battery will keep it from happening. Just bring the battery to some place like autozone, they'll load test it for free.

  7. #7
    My Last Name is a Drink! Martini2's Avatar
    Join Date
    Oct 2007
    Location
    Converse, TX
    Age
    36
    Posts
    27

    Red
    1999 Trans Am

    Quote Originally Posted by 2001NBMZ28 View Post
    I wouldn't worry about changing the cluster, a good battery will keep it from happening. Just bring the battery to some place like autozone, they'll load test it for free.
    Cool, thanks. It was just an idea. At least with the problem I will know when the bateery is starting to go.

    B

  8. #8
    Junior Member
    Join Date
    Jan 2016
    Location
    Seymour,Texas
    Posts
    11

    White
    1999 Trans Am

    I just posted the same problem earlier before I saw your post and my 99 was doing just fine up until my last battery failed. Only after I replaced it with a known good battery did my odometer start it's funny business. I have already had issues with headlight connections after fixing the motors...corrosion. Does anyone think that the constant 12 volt memory lead could be corroded causing the odo to reset? Or does it not need 12v to maintain memory?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trip Odo Resets Every Time I Start the Car
    By Nitro13 in forum General Help
    Replies: 5
    Last Post: 01-25-2016, 06:38 AM
  2. Hot Rod Road Trip - Trip Starts January 20th 2011
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 0
    Last Post: 01-14-2011, 08:10 PM
  3. Help: Trip odometer
    By 97txaggie in forum General Help
    Replies: 3
    Last Post: 04-15-2010, 06:52 PM
  4. Interesting..Tripometer Resets itself
    By Zapper2003 in forum Stereo and Electronics
    Replies: 8
    Last Post: 04-09-2007, 05:21 PM
  5. No more Predator resets
    By jjnada in forum Parts Review
    Replies: 0
    Last Post: 11-12-2005, 09:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •