Results 1 to 5 of 5

Strange 10HP loss up top...

This is a discussion on Strange 10HP loss up top... within the Computer & Tuning forums, part of the LSx Technical Help Section category; Had it tuned at Vengeance Racing in Atlanta. Great guys, brilliant tuning, and famed creators of the Vindicator cam grinds. ...

  1. #1
    Junior Member blackwidow99's Avatar
    Join Date
    Jun 2007
    Location
    Atlanta Gawga
    Posts
    75

    Black
    1999 Camaro SS

    Strange 10HP loss up top...



    Had it tuned at Vengeance Racing in Atlanta. Great guys, brilliant tuning, and famed creators of the Vindicator cam grinds.

    Couldn't figure out the cause of this 10HP loss up top. The car is a 1999 Camaro SS with Hooker LTs, SLP LM1, LS6 Intake, TB P&P, SLP Lid, NGK tr55's, K&N, and an SLP MAF plus the Vengeance Dyno-tune.

    We tried removing the SLP MAF because they are known to be crappy, but it didn't solve the problem.

    Any ideas?

  2. #2
    Junior Member blackwidow99's Avatar
    Join Date
    Jun 2007
    Location
    Atlanta Gawga
    Posts
    75

    Black
    1999 Camaro SS

    TTT for day crowd

  3. #3
    Junior Member
    Join Date
    Oct 2006
    Location
    Mesquite, TX
    Age
    38
    Posts
    36

    Black
    2001 Z28 M6

    The dip in HP came from the sudden drop in TQ, then it came back up a little. Remember HP is directly related to TQ. Just guessing it looks like you may be picking up some knock and getting some KR, which will reduce torque. I guessing you made multiple runs, so that should eliminate a glitch in the dyno reading.
    To get a better understanding of exactly what is going on, a run with A/F logged would be helpful in understanding the source of the problem.
    The pattern fits KR theory. If it is the problem, why are you getting it? Maybe it is going lean at that point.

  4. #4
    Junior Member blackwidow99's Avatar
    Join Date
    Jun 2007
    Location
    Atlanta Gawga
    Posts
    75

    Black
    1999 Camaro SS

    Hmmm I know less about tuning than anyone you know, but I'll do my best to answer your questions...

    Mike (the tuner) said there was no knock and compression was good. You are correct assuming we did multiple runs, and it was actually worse to begin with. This is the best he could get it.
    I'll have to ask him about getting the log, but I'm assuming if it was running lean he would have fixed that.

  5. #5
    Junior Member MNR-0's Avatar
    Join Date
    Aug 2005
    Location
    Australia
    Age
    48
    Posts
    80

    BLACK
    2004 Monaro

    First look is that its detonation or valve float.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. STRANGE,STRANGE Trans Ams
    By fbodyNATION in forum Firebird / WS6
    Replies: 4
    Last Post: 08-27-2013, 04:29 PM
  2. At a Loss
    By Orrin's Z in forum Internal Engine
    Replies: 16
    Last Post: 01-22-2010, 07:29 PM
  3. Question: does the bigger Oil filter give you 10HP extra?
    By SVG210 in forum General Help
    Replies: 10
    Last Post: 09-11-2008, 01:21 AM
  4. My loss
    By odinsonthor in forum Almost Anything Goes
    Replies: 21
    Last Post: 09-02-2008, 02:22 PM
  5. My first loss.
    By GotN2O in forum Kill Stories
    Replies: 7
    Last Post: 10-29-2005, 11:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •