Results 1 to 6 of 6

SES light and P1415 code that comes back

This is a discussion on SES light and P1415 code that comes back within the Computer & Tuning forums, part of the LSx Technical Help Section category; I have read through the threads by using the search here, but none really match what is happening on my ...

  1. #1
    Junior Member
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    5

    black

    SES light and P1415 code that comes back

    I have read through the threads by using the search here, but none really match what is happening on my car.

    It is a 96 Buick Roadmaster with the LS1 engine. Distributor in the front and all the goodies.

    I keep having a recurring P1415 code even after doing the following:

    1. Changed out the drivers side check valve. Light stayed off for about 100 miles then came back on with same trouble code.

    2. Changed out driverside catalytic converter. Drove the car about 100 miles and the ses light came back on with the same trouble code coming on.

    Using my scanner I can turn on the air pump and get good air flow. The tube behind the check valve is not clogged. The hoses from the air pump to the check valves appears in good condition. The front O2 sensors appear to work as they are supposed to, but the passenger side O2 sensor generally reads lower than the driver side after the car is fully warmed up.

    Could the check valve I installed be the wrong one for this car causing the code to come back?

    This car did have a miss in it that was finally cured by installing another distributor. Seems the water pump had been leaking. New plugs and wires, cap and rotor were installed also. Runs great. Just can't keep it from throwing a trouble code on this one side. All this was done prior to the cat.

    Thanks for any help.

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    well your car has the LT1 motor, not the LS1 motor, unless you swapped the motor and put a front drive distributor ion it.

    DTC P1415 Secondary Air Injection (AIR) System Bank 1

    after replacing all of the parts associated with that side, might be a hole in the hose allowing air to come in.

    here's some reading
    http://www.gearchatter.com/viewpost13513.php
    http://www.automotiveforums.com/t396...ode_p1415.html

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    P1415 is usually a restriction in the bank 1 air system, could be the check valve, could be the pipe coming off the exhaust manifold. Don't think that Roadmaster has an LS1 in it.

  4. #4
    Junior Member
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    5

    black
    Thanks for the relies. I'll look at those. This engine does have the distributor mounted behind the water pump. Fun to do though not real hard. I was told this was a Corvette set up in this car from the factory. At any rate, I'll study more about this to se what can be done to correct this code. I'll double check the hose too.

    Thanks again.

  5. #5
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    you mean the distributor is mounted behind the crank pulley and under the water pump? it is the LT1.

    1996 Buick Roadmaster

    this motor


  6. #6
    Junior Member
    Join Date
    Aug 2007
    Location
    Texas
    Posts
    5

    black
    See, I learned something new. So it's an LT1 instead of LS1. Maybe I'll get my consonants figured out one of these days. lol That is the engine that is in this car. Runs good, just can't get that code cleared for any lenght of time.

    I do appreciate the help and the correction on engine type. Will help me further down the road.

    I'll look closer at the things mentioned here and see if I can clear that code once and for all.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ses light came on, come in to help with code
    By krese in forum General Help
    Replies: 25
    Last Post: 04-28-2008, 12:47 PM
  2. P1415 Code, Tuning it Out
    By ViperJ in forum General Help
    Replies: 1
    Last Post: 11-22-2007, 08:48 PM
  3. SES code P1415
    By dkroshko in forum General Help
    Replies: 3
    Last Post: 04-03-2006, 08:09 PM
  4. P1415 SES code HELP!
    By y2kformula in forum Computer & Tuning
    Replies: 15
    Last Post: 02-17-2006, 06:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •