Results 1 to 3 of 3

Pinging - tune problem?

This is a discussion on Pinging - tune problem? within the Computer & Tuning forums, part of the LSx Technical Help Section category; I have a 99 T/A with basic mods (flowmaster, K&N cold air, mild tune - egr/air off, fan speeds, a ...

  1. #1
    Junior Member
    Join Date
    Oct 2007
    Location
    Yulee, FL
    Posts
    26

    Pinging - tune problem?

    I have a 99 T/A with basic mods (flowmaster, K&N cold air, mild tune - egr/air off, fan speeds, a little touch here and there).

    Now that the cool weather has arrived I have a horrible ping under heavy throttle. Sounds pretty bad. I first suspected that I had a bad tank of fuel so I waited out on the tank and re-filled with good premium and it is still pinging. The car has been well maintained. Recent plugs (NGK TR55), injection cleaning, fuel filter.

    Fuel pressure at the rail is 52psi with ignition on and 62psi running. I unplugged the MAF and the pinging has been reduced a little bit, but not much. Any ideas?

  2. #2
    Racer/Tuner San Diego
    Join Date
    Feb 2007
    Location
    San Diego
    Posts
    18

    Yellow
    05 GTO A4

    HI,

    I would do a fuel pressure check under load.
    I use a 3 foot long hose and gauge set up(taped to the windshield)
    and go for a drive. The fuel pressure at full throttle
    should maintain(around 58 psi) and not drop off.
    If the pump and or filter are not keeping up,
    the pressure will drop quickly under full throttle conditions.
    If that test is aok then I would want to data log and evaluate.

    Gary

  3. #3
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pinging problem
    By shepss217 in forum General Help
    Replies: 10
    Last Post: 06-26-2010, 02:53 PM
  2. Help: With problem after tune.........
    By clg82 in forum Firebird / WS6
    Replies: 54
    Last Post: 02-25-2009, 06:12 AM
  3. Help with pinging problem
    By Jglisson in forum General Help
    Replies: 8
    Last Post: 03-10-2008, 01:30 AM
  4. Pinging Problem
    By FormulaFiend in forum General Help
    Replies: 7
    Last Post: 08-12-2006, 09:07 AM
  5. Car pinging with stock tune after shorties install?
    By mikes ss in forum Western Members
    Replies: 15
    Last Post: 03-16-2006, 05:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •