Results 1 to 18 of 18

P0131, P0137, P0151, and P0157

This is a discussion on P0131, P0137, P0151, and P0157 within the Computer & Tuning forums, part of the LSx Technical Help Section category; I had these codes for a while. When I first got them I changed all my 02 sensors (3 of ...

  1. #1
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    P0131, P0137, P0151, and P0157

    I had these codes for a while. When I first got them I changed all my 02 sensors (3 of them, so why the P0157 code I don't know), this did not fix the problem (It had hard starts, and would bog out at full throttle.) Utah winter set in so I parked if for the winter, once the weather started warming up I changed the spark plugs which didn't do anything either, I tested the fuel pressure and it was only at 26 psi and wouldn't hold so I replaced the the fuel pump. Once I did that I got a new code for the ECT, I replaced it and it ran a little better but still running rough. Then I got a new code P0507, So I found a vacuum leak and fixed it, clean the MAF, IAC, and throttle body, it got rid of the P0507 but not other problems. It runs better but still really sluggish. I am thinking of changing plug wires and pressure regulator but thats kind of expensive if thats not the problem. Please Help.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    any mods on the car?

  3. #3
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    SLP air lid, tsp tumbler cat back, b&m electronic shift improver

  4. #4
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Running good gas? Checked fuel pressure since the new pump? Any exhaust leaks that could be introducing air into the exhaust before the O2s? Sure you got all vac. leaks fixed?

    Otherwise, check this from gearchatter.com:

    http://www.gearchatter.com/viewtopic8755.php

  5. #5
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Only looked a couple up, but running out of fuel/low pressure was one common denominator. Like said above check fuel pressure, was fuel filter replaced?

  6. #6
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Yeah, basically all four come back to the engine running lean for some reason...

    -Eagle

  7. #7
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    I will check pressure again tonight, I pretty much coated my engine with starting fluid and couldn't find any other after I fixed the one, and can't hear any obvious leaks coming from the exhaust, thanks for the input guys it is greatly appreciated. I'll post another reply once I've done a few more things.

  8. #8
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    ok my pressure is reading about 35 while idling but drops when I push the throttle, it also doesn't hold pressure with the key turned on not running

  9. #9
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    35psi? Isnt that low?

  10. #10
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    I thought that too, but it is better then the 25 on the old pump, this one is brand new 255lph so I am thinking regulator now.

  11. #11
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    fuel pressure should be ~58psi. If your pressure falls like that then most likely the regulator is bad. When you did the pump did you swap out the entire module or just transplant the actual pump itself?

  12. #12
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    just the pump itself, its been in there for about 2 weeks and has about 5 miles on it. I will get a regulator on the way see if that does it.

  13. #13
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    You sure the pump went in correctly?

  14. #14
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    as far as I can tell it did, I'll change the regulator and see if anything changes.

  15. #15
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    Sorry it took so long to get back but it took a while to get the regulator. I put it on and it runs awesome. I turned on my electronic shift kit on 2 and it slid sideways going into 2nd and lost it a little in 3rd which had never happened before, it was nice. Thanks for all your input.

  16. #16
    Just another Joe Eagle's Avatar
    Join Date
    Mar 2007
    Location
    NW Chitown
    Posts
    757

    Pewter
    2002 WS6

    Congrats!

  17. #17
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    48
    Posts
    416

    navy blue metallic
    2001 trans am

    Im having this problem too, I replaced my pump as well w/out doing the regulator. Where is it and what does it look like? That sounds like my problem low pressure, when I blip the throttle under load it makes a noise and bogs down.
    GMPP LS6 crate motor,racetronix,Wilwood 6 piston,HID's,200mph speedo,full dynomat, GY F1's,17" Y2K, Alpine audio upgrade,3" ele cutout, LT's, catted-Y, full suspension

  18. #18
    Junior Member SuperStock's Avatar
    Join Date
    Apr 2008
    Location
    Utah
    Posts
    16

    Red
    1998 Formula

    http://www.autopartswarehouse.com/de...QQSIPR207.html here is a link for a pic, I wouldn't order from here, I got mine from autozone for $34 and it came the next day. . Glad I got it going, finally got to race and ran a 13.23 at a 4200ft elevation on street tires which is down from my best of 14.3 on street tires


LinkBacks (?)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: ls1 codes P0131 p0137 p0151 p0157 help please
    By skinypuppy in forum General Help
    Replies: 37
    Last Post: 06-16-2011, 03:09 PM
  2. p0131, p0137, p0151, p0157
    By NE98LS1 in forum General Help
    Replies: 10
    Last Post: 06-07-2011, 09:15 PM
  3. P0131 and p0151 help
    By brp57 in forum General Help
    Replies: 6
    Last Post: 09-10-2010, 09:29 AM
  4. BBH02S22 Codes P0161 & P0157
    By rene817 in forum Computer & Tuning
    Replies: 2
    Last Post: 10-29-2009, 10:29 AM
  5. P0137 and p0157
    By Red99TA in forum Computer & Tuning
    Replies: 3
    Last Post: 01-30-2009, 05:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •