Results 1 to 17 of 17

owned by idle tuning

This is a discussion on owned by idle tuning within the Computer & Tuning forums, part of the LSx Technical Help Section category; Been working this week on getting my car to idle correctly after the cam and heads ( 228R cam). Not ...

  1. #1
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    owned by idle tuning

    Been working this week on getting my car to idle correctly after the cam and heads ( 228R cam). Not having a whole lot of luck with it. I've made several changes and I'm not much better off than before I started. I'm using edit and logging with efilive. Right now my cold idle really sucks for about 10-15 seconds after start up. I have to feather it to keep it running but after that it idles perfect. I'm also gonna have a cruise effect problem if/when I ever take it out of the garage. When I put it in gear it idles up and wants to pull the car. Right now my idle is set at 900 but I would like to get it down to 850 at some point. I know these are pretty much all air flow issues. I just need to figure out which tables to start working on for each individual problem. I won't get into all the adjustments I've made so far but I've did the standard Nogo idle tune like the first 3 columns of the ve and stuff like that. I started playing with the iac park position, idle air, and MAF tables tonight. Not much luck so far. Last night using the set screw I had my warm IAC counts at 55 but after fooling with it tonight they're up around 95-100 now. I'll start all over tomorrow night and see what I end up with. I'll update the thread as I go and hopefully you guys can give me some input and we'll get a decent idle tuning thread going.

  2. #2
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    hi---With cammed cars that i tuned i usually work on these tables to cure the most common errors--
    B5933 Base timing in P/N add 2-4 * in all RPM ranges in idle area
    B5932 base timing in gear same
    B4307 desired airflow ADD % in both P/N and in gear but work on 1 table at
    a time--start by adding 5% at a time---If you are getting a "cruise
    control" affect or hanging idle in either-you went too far and start subtr.
    5% at a time back
    B3605-Comm. AFR in open loop--for cold start up--From 68* on--what worked best for me was to start the AFR's at about 13.50 and scale up to about 13.85 up to around 200*--accross to 18 MAP

    B4317 throttle follower in gear---adding % gets rid of hainging idle
    B4319 throttle follower in P/N same

    B4309 Throttle cracker in gear "0" out 0 to 4 MPH rows
    B4310 Throttle cracker in P/N "0" out 400 to 1000 RPM rows

    Thott. cracker seemed to not do much--I would only tryit if nothing else worked

    I finally get most to idle perfect and no surging or hanging idle anywhere--Not saying this will cure your ills but these corrected most all of mine and I had the same symptoms

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I tried a few other things tonight including your advice. It's definitely better but still needs some work. I'm letting the car sit for a couple of hours to cool all the way down since that's where most of my problems are. Warm or hot starts are excellent. It's just the first few seconds. My IAC counts are ~55 again and I will probably have to lower those a little more. Logging with my wideband I was seeing 11.5 to 12:1 AFR on start up. I think if I fix that my cold start will get much better. I have another issue that I'll have to tackle also. I'm seeing up to 5 degrees of KR on initial start up. It's at the exact point the engine starts. It's 1 blip that shoots up and comes straight down. I'm wondering if when the engine jumps on start up something is banging somewhere and causing that. I'm not worried about it at the moment. I want to get the start and idle dialed in first.

  4. #4
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    Does the engine flare up at cold start up ??? say like go up to 2400 RPM's then drop down to normal after 5-10 seconds ??
    If so this is a common problem --most tuners will adjust table b5915 (minimum spark advance) as part of a tune---I found that you must leave the table from 0 to 2400 stock or you will get a flare at start--and if you dial in too much timing-- KR will try to take it out---The table b5009 (spark timing while cranking) is over-ridden by table b5915---so if the tune included adding timing to b5915 then it takes precidence over whatever you have in the timing while cranking file b5909

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    It doesn't flare, it kinda struggles to get going. The KR I'm seeing is right when the engine first fires. I played with it some more tonight but will have to wait until tomorrow to see how the cold start is. I let it set 3 hours or so and went and it started right up, the coolant temp was 43C and cold start up is about 20 colder than that I think. I dropped my idle to 850 which is where I wanted it to begin with. I figure there's no reason to set up an idle point and get this all dialed in then move the idle. I'll try to make it work there. It idles fine at 850 and to be honest I could probably come off of that a little more but 850 is fine. I did notice after the last round of adjustments that my idle dips after a rev now. It would dip down to ~600 then come back up. If it starts up without issues tomorrow I'll address that problem along with my start up KR next. I did test drive it up and down the road a little bit ago. I didn't throw p0300 this time but I did notice my convertor wasn't acting quite right. The tranny wasn't really up to temp either so that may have been part of what was causing it. I addressed the p0300 code by changing the low rpm table to 32000 but I'm still throwing the code every now and then.

  6. #6
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    I feel like I'm re-liveing my life all over again as on my own hds/cam C5 I had all these same issues--I was told to do a "crank position re-learn procedure for the p0300--and I did with my EFILIVE and it quit popping up THEN--with an A4 I set table C5601 ( misfire detection max temp ) to "1" When doing that though make sure that your engine is really not missing and the code is false--You'll have to use yout engine knowledge to make sure that it is a false misfire---If so then set c5601 as i reccomended--If you think you really do have a miss--then obviously you need to correct the miss----

  7. #7
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Yeah, I knew about disabling the misfire stuff but I want to try and avoid that if I can. I was hoping the 32000 trick would work but no luck. I'm gonna log misfires across the cylinders before doing anything else to see if it's in fact a misfire but everything tells me it's not. There's a learning curve here. I'll get it eventually and I'm not new to tuning. Just new to starting from scratch on a heads/cam car. I have a few different issues I'll have to deal with too. Mines a 98 which had EGR on it at one time. I'll have to rework the timing tables again I'm sure. When I first pulled the EGR I was seeing tip in KR in certain spots of the table. I calculated where the knock was on the table and got rid of it that way.
    I'm seriously considering just ordering HpTuners and being done with it. The problem is I don't want to have to buy a new laptop too and my laptop doesn't really meet Hp's minimum requirements. It would work but not be optimum. Now you're looking at $700 for Hp plus another $500 for a laptop. Edit works so I'll get it eventually with that. Just takes a lot longer.

  8. #8
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    Table b5907 is the EGR spark correction table--It adds up to 10* timing in certain areas---If you didn't already try "0" ing out this entire table--I always do wether the EGR is active or disabled---

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by tblu92 View Post
    Table b5907 is the EGR spark correction table--It adds up to 10* timing in certain areas---If you didn't already try "0" ing out this entire table--I always do wether the EGR is active or disabled---
    I use LS1edit to tune with so I don't have the spark correction table. I had to calculate the cells I was seeing KR in and remove timing that way then smooth the table. I have the car pretty close now. Still a small issue on start up but after that it idles really well. I drove it a little Saturday morning and have a slight surge and my convertor still isn't acting right so those are my next 2 things I'm going to tackle.

  10. #10
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I've made some progress the last 2 nights. Fixed the convertor issue which I knew what was wrong there. My idle is great except for those first 5-10 seconds at start up. Issues I still need to work on.
    Still seeing a few degrees of KR on start up every now and then.
    Slight surge when cruising at a steady throttle. It's a very slight surge but I can tell it's there.
    I have tip in knock and seeing a little knock here and there.
    I'm wondering how much my 98 knock sensors are playing into this. I know I've read where the 98 knock sensors have had these issues. I'm not gonna mess with the timing to much until I get my part throttle fueling done so I can run some hi-octane gas to see if the knock goes away. The 98's had a more aggressive table but I would think with the cam and heads I would be able to run that spark without knock issues. My compression went up a little bit (10.75:1) but I would think it should be able to run that table.

  11. #11
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    the 98 sensors got an update later in the year. the 99-up knock sensors are completely different. may want to look into investing in updating. also, may want to look at desensitizing the knock sensors.

    there is a burst knock table as well. i don't have my stuff in front of me, but i think there should be a fuel multiplier type table thingy for tip in/acceleration. like the pump shot for a carb.

  12. #12
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    just so people can get an idea of what's all involved in idle tuning:

    http://fla-thirdgen.org/targetidlespeed.htm

    orion, have you looked into messing with the proportional and integral portions of the idle tables?

  13. #13
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    the tables in edit are considerably different than with tuners ( read crappier ). Here's what I have to work with on the idle side. I'm getting closer with it. It's a rock solid idle at 850 now, just a little screwed up on startup but I'll get it eventually. This isn't my actual file loaded. This is one that I downloaded a while back.

  14. #14
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    After seeing the files for idle in HP Tuners and In LS1Edit I am sure glad I bought EFIIVE----so much easier to follow and to understand and learn

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    when I bought edit neither of the other 2 even offered tuning software for the 98's. I don't even think efilive had tuning software period when I bought mine so it wasn't really an edit choice. It was the only choice at the time. EFIlive has great stuff and have always been cutting edge. I use their datalogger to log but they really need to work on their pricing scale because HPtuners blows them away in that category. If/when I get different software it will be tuners.

  16. #16
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    Quote Originally Posted by 0rion View Post
    they really need to work on their pricing scale because HPtuners blows them away in that category. If/when I get different software it will be tuners.

    the exact reason why i went hptuners. i downloaded the efilive demo and it looked pretty good. just price schedule is up there.

  17. #17
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I'm getting much closer on this tune. I finally got the cold start up worked out. I made a boat load of changes trying to figure out why it would start, surge, then die on a cold start. I took an additional 3% out of the ve table at 1000rpm and it cleared it right up.
    My stall is still acting funny. I've changed the low rpm tables to 32767 and I thought that got it but evidently not. I have 1 more thing I want to try then I'm gonna turn misfire detection off altogether and see if that does the trick.
    This last tune had a few timing changes at part throttle made but I haven't taken the car out to log yet. I basically just smoothed my table a little bit to see if it helps with the knock I'm seeing at part throttle. I think some of my knock is cells from the !EGR that I wasn't really cruising in with my stock cam so I never changed.

    My driveability the way it sits isn't very bad at all. I still have a slight surge holding constant tps ~1500-1800 rpm ( cruising at 35-40mph). I'll have to try to figure out if that's fueling or timing related.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issues... idle high. unplugged tps runs good?
    By okiels1 in forum Firebird / WS6
    Replies: 2
    Last Post: 12-31-2016, 04:36 AM
  2. Idle hanging up/ tuning problems.
    By Red Z28 in forum General Help
    Replies: 9
    Last Post: 10-28-2011, 08:04 PM
  3. Help: intermittant rough idle, off idle hesitation
    By Matto4785 in forum General Help
    Replies: 1
    Last Post: 09-21-2009, 06:12 AM
  4. Have you gotten owned by the owned smiley??
    By 86 IROC-Z in forum Almost Anything Goes
    Replies: 18
    Last Post: 06-14-2007, 12:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •