Results 1 to 12 of 12

O2 sensors

This is a discussion on O2 sensors within the Computer & Tuning forums, part of the LSx Technical Help Section category; My engine light is on and the codes read that all four O2 sensors are bad. I hollowed out my ...

  1. #1
    Junior Member
    Join Date
    Aug 2007
    Location
    Homosassa, Florida
    Age
    32
    Posts
    10

    silver
    2000 camaro Z28

    O2 sensors

    My engine light is on and the codes read that all four O2 sensors are bad. I hollowed out my cats and I havent replaced my O2's. Is this affecting my A/F ratio or my performance?

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    all four? usually when you gut the cats, it'll throw the codes for both rear o2s. did you plug all the sensors back in?

  3. #3
    Junior Member sreve's Avatar
    Join Date
    Aug 2007
    Location
    St. Louis Area
    Posts
    38

    Black
    '02 B4C Camaro

    an O2 code does not nessasarily mean its bad. there are alot of O2 codes.
    which ones do you have?
    rubbed wires or a blown heater fuse is not uncommon.

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    When you say haven't replaced the 02's you don't mean the fronts also right? Make sure the fronts are plugged into the right connectors too. An exhaust leak near an 02 will also throw codes.

  5. #5
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    yup prepare for the richness and loss of mpg... ok solution will be ...headers,y pipe and a good effing tune...and your car is back where it was but alot more beefier ...its worth it

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    first post up what codes you have

  7. #7
    Senior Member Justin23454's Avatar
    Join Date
    Aug 2007
    Location
    Virginia beach
    Age
    33
    Posts
    1,963

    SOM
    1998 Trans Am

    I have the same thing but says its my back 2. Ive done nothing to the car as of yet cept for a new lid. Also I have noticed im gettin alot less MPG. Should I just replace them? (I took it to autozone and they told me its the rear ones)

  8. #8
    Junior Member
    Join Date
    Aug 2005
    Location
    Kalamazoo, MI
    Age
    37
    Posts
    7

    Red
    1998 Camaro Z28

    hey im having kind of same problems. y-pipe,rear o2 delete getting codes p0131 nad p0151 for both o2 sensors. just replaced both with new ac-delco and took it out to drive and both codes came back. any thoughts. seems like it is really lean and stumble at low rpms.

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by ladunnkity View Post
    hey im having kind of same problems. y-pipe,rear o2 delete getting codes p0131 nad p0151 for both o2 sensors. just replaced both with new ac-delco and took it out to drive and both codes came back. any thoughts. seems like it is really lean and stumble at low rpms.
    those are lean codes for the front sensors. Have you checked your fuel pressure at the rail? Any leaks in the exhaust before the front O2's? A.I.R. pump working properly?

  10. #10
    Junior Member
    Join Date
    Aug 2005
    Location
    Kalamazoo, MI
    Age
    37
    Posts
    7

    Red
    1998 Camaro Z28

    no exhaust leaks that i can find, A.I.R was delted from computer also. checking pressure tonight.

  11. #11
    Junior Member
    Join Date
    Aug 2005
    Location
    Kalamazoo, MI
    Age
    37
    Posts
    7

    Red
    1998 Camaro Z28

    Well When I First Start It Up Goes Right To 43 Pounds But As It Sits There It Slowly Drops Down To About 22 And Starts Bucking And Dying. So I Guess I Need A New Fuel Pump. Any Recomendations And Does Anyone Know What The Difference Is Between A 98 And 99-02? Thanks

  12. #12
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    yeah, I highly recommend a racetronix kit from Harris Speed Works ( sponsor). Matt is great to do business with. There's a thread on HSW in the sponsor feedback section right now.

    The 98's have metal tanks with baffles and the 99+ have plastic tanks with the pump sitting in a bucket and a venturi feed to the bucket.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. O2 sensors
    By c5z28 in forum Computer & Tuning
    Replies: 27
    Last Post: 10-06-2010, 02:35 PM
  2. O2 sensors
    By Soltakr in forum External Engine
    Replies: 19
    Last Post: 05-20-2008, 10:09 PM
  3. 02 sensors
    By 02sscamaro in forum General Help
    Replies: 25
    Last Post: 04-16-2008, 05:02 AM
  4. o2 sensors
    By ls1_02 in forum General Help
    Replies: 9
    Last Post: 01-10-2008, 09:51 AM
  5. Should I buy new sensors?
    By EastTNZ28 in forum General Help
    Replies: 0
    Last Post: 06-15-2007, 10:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •