Results 1 to 5 of 5

Maf not reading

This is a discussion on Maf not reading within the Computer & Tuning forums, part of the LSx Technical Help Section category; So I had an slp maf and now it don't read anything. I switch to stock and still it didn't ...

  1. #1
    FASTER THNA SPEEDINtICKEt BANDITO's Avatar
    Join Date
    Apr 2008
    Location
    A, A
    Age
    28
    Posts
    281

    White
    2002 trans-am

    Maf not reading

    So I had an slp maf and now it don't read anything. I switch to stock and still it didn't work. What do you recommend? My car is running like sh*T. Also If I get a ls2 engine harness from scoggin dickeys will my gauges and lights ect. work?

  2. #2
    Junior Member whitetrashbird's Avatar
    Join Date
    Dec 2010
    Location
    Tx
    Posts
    65

    Blue
    02 Firebird Transam

    I'd look at the little terminals on the plug for the MAF.

    Dan

    "Timid men prefer the calm of despotism to the tempestuous sea of liberty"....Thomas Jefferson

  3. #3
    FASTER THNA SPEEDINtICKEt BANDITO's Avatar
    Join Date
    Apr 2008
    Location
    A, A
    Age
    28
    Posts
    281

    White
    2002 trans-am

    They seem good.

  4. #4
    FASTER THNA SPEEDINtICKEt BANDITO's Avatar
    Join Date
    Apr 2008
    Location
    A, A
    Age
    28
    Posts
    281

    White
    2002 trans-am

    this was a fuse haha fixed it now after a year....damn a fkin fuse under the hood.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Didn't look at the original post date -- I was going to guess that the ENG SENS fuse cooked off.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Ohm reading
    By my1stss in forum General Help
    Replies: 3
    Last Post: 01-27-2012, 08:35 PM
  2. Good reading.
    By mbrownin in forum Almost Anything Goes
    Replies: 8
    Last Post: 05-23-2011, 12:54 AM
  3. Been on here a while reading
    By texas97z in forum New Member Introductions
    Replies: 6
    Last Post: 02-18-2011, 12:34 PM
  4. Been reading for a while, just never posted here.
    By faze in forum New Member Introductions
    Replies: 2
    Last Post: 02-01-2010, 07:55 PM
  5. Speedometer reading way off???
    By camarolvr69 in forum General Help
    Replies: 15
    Last Post: 11-20-2007, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •