Results 1 to 8 of 8

LS1 ruunning rich on Bank 1

This is a discussion on LS1 ruunning rich on Bank 1 within the Computer & Tuning forums, part of the LSx Technical Help Section category; Hi, I have an issue with a 2002 LS1 (from a Firebird). It is running rich on one bank, Bank1, ...

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Location
    Denver, CO
    Posts
    5
    2002 Firebird

    LS1 ruunning rich on Bank 1

    Hi,
    I have an issue with a 2002 LS1 (from a Firebird). It is running rich on one bank, Bank1, in closed loop only (runs fine cold in open loop).
    I first tried switching the existing O2 sensors sise to side and that made Bank2 deteriorate and run rich, but did not improve Bank1.

    I have replaced the MAF and the two O2 sensors with OE parts. Bank1 continues to run rich. I have taken off the fuel rail and tested it and it operates perfectly.

    Can anyone shed any light on what I should try next, or if someone can offer a service to resolve?
    Thanks so much for reading.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    any modifications to the engine?

  3. #3
    Junior Member
    Join Date
    Jun 2010
    Location
    Denver, CO
    Posts
    5
    2002 Firebird

    No modifications to engine. Has Street & Performance reprogram the ECM for tire size but kept emissions intact.
    Have had to replace OE log manifolds with custom to clear suspension.


    Aftermarket cats (one month old).
    Last edited by MTT700; 06-26-2010 at 11:33 AM. Reason: image link broken

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    a leaky weld on that manifold could cause outside air to enter the exhaust and fool that O2 sensor into thinking that bank is lean and cause it to dump more fuel in

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by Cutlass View Post
    a leaky weld on that manifold could cause outside air to enter the exhaust and fool that O2 sensor into thinking that bank is lean and cause it to dump more fuel in
    +1

  6. #6
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    What these guys said.


    Quote Originally Posted by MTT700 View Post
    .. Has Street & Performance reprogram the ECM for tire size but kept emissions intact....
    I hear that's pretty expensive

  7. #7
    Senior Member 01ws6er's Avatar
    Join Date
    Oct 2007
    Location
    The 717
    Age
    30
    Posts
    2,471

    Red
    2001 Trash Can

    Quote Originally Posted by 0rion View Post
    +1
    Or a blown out manifold gasket

  8. #8
    Junior Member
    Join Date
    Mar 2010
    Location
    texas
    Posts
    5

    navi blue
    2001 firebird ws6

    Yeah

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SES CODE running rich bank 2...
    By GNICTRY in forum General Help
    Replies: 47
    Last Post: 01-03-2011, 08:12 AM
  2. One Bank Running Rich
    By Boostd1 in forum Computer & Tuning
    Replies: 3
    Last Post: 12-23-2010, 01:29 PM
  3. 1 bank runs rich
    By anuka in forum General Help
    Replies: 6
    Last Post: 03-05-2009, 04:20 PM
  4. 04 GTO Diablo Tuner SES L/R Bank to Rich
    By ctbeiser in forum Computer & Tuning
    Replies: 6
    Last Post: 01-16-2006, 07:04 AM
  5. bank 1&2 runnung rich codes????
    By 98ls1 in forum Computer & Tuning
    Replies: 1
    Last Post: 10-15-2005, 02:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •