Results 1 to 13 of 13

How much will replacing my computer cost??

This is a discussion on How much will replacing my computer cost?? within the Computer & Tuning forums, part of the LSx Technical Help Section category; Got a 98 TA A4. Its been turning off on me while driving. I Pull over to the side, wait ...

  1. #1
    Junior Member
    Join Date
    Aug 2006
    Location
    N.Hollywood
    Age
    35
    Posts
    27

    black
    98 Trans Am

    How much will replacing my computer cost??

    Got a 98 TA A4. Its been turning off on me while driving. I Pull over to the side, wait a minute and it starts right up. I take it to the mechanic and says everything is perfect, but that my computer is possibly not sending the signal to the fuel pump correctly. How much will a new computer cost ?? Can I just get it reprogrammed to fix the problem??
    It could also possibly have a bad fuel pump, but the diagnostics said it was fine.

  2. #2
    URDRSRMINE Method's Avatar
    Join Date
    Nov 2007
    Location
    Ottawa, Canada
    Age
    35
    Posts
    266

    Black
    2001 Trans AM WS6 M6

    I don't think I can ever remember anyone replacing a computer, sure for performance ones etc, but not just for a busted one. Your guess is as good as mine, I can only imagine it'd be like $800

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    If it's starving for fuel and shutting off I'd suspect something else before condemning the PCM. Did he check for any codes and get the correct fuel pressure during the diagnostics? How old is the fuel filter?

  4. #4
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Well, here's a link on E-Bay for 165.00 , but I never heard of that either...

    http://cgi.ebay.com/ebaymotors/1997-...QQcmdZViewItem

  5. #5
    Junior Member
    Join Date
    Aug 2006
    Location
    N.Hollywood
    Age
    35
    Posts
    27

    black
    98 Trans Am

    The SES light came on and went away, I checked the code and it was for the Crankshaft sensor. I bought a new one, and the mechanic replaced it for me. I also changed the fuel filter before I took it. The old was fine though. When he ran the diagnostics, everything checked out. He said the fuel pump was fine. He drove it for 10 minutes and everything was fine. As soon as I drive it down the block, it dies again. When I turn it on again it runs fine for the rest of the day, and then later at night dies again.
    Is it all possible that the fuel pump is overheating and dying, then starts back up again???
    I'm taking in the car again tomorrow. The car threw another code yesterday, so will check when i get the scanner later.
    He told me that it could be a computer problem, personaly i dont want to spent 800 bucks.

  6. #6
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Could add a fuel presure gauge. Or get a testing gauge and temporally mount it behind the hood, so you can watch it...Tap right off your fuel rail. You can even use refrigeration gauges. Same fitting... Should be around 58lb or so...

  7. #7
    Member red99ws6's Avatar
    Join Date
    Jul 2007
    Location
    tazewell, tennessee
    Age
    39
    Posts
    312

    red
    1999 Trans Am WS-6

    could also be a fuel pump relay. cheap fix if it is.

  8. #8
    Junior Member
    Join Date
    Aug 2006
    Location
    N.Hollywood
    Age
    35
    Posts
    27

    black
    98 Trans Am

    I was thinking about investing in the fuel pressure gage, but it would only thel me if my fuel pressure goes down. It could still be either fuel pump, or a computer issue.
    The fuel relay is good, I switched it with the AC one and acted the same.
    I'm going tomorrow moring to the shop, so i'll post up the results.

  9. #9
    Senior Member 01ws6er's Avatar
    Join Date
    Oct 2007
    Location
    The 717
    Age
    30
    Posts
    2,471

    Red
    2001 Trash Can

    I have a similar question about my friends 2000 T/a... He keeps throwing codes, and they're all over the place..he replaced all four 02 sensors, and it still throws codes for all four, a skip shift selonoid code, and upshift something or other are the constant ones, but every time he gets them cleared, random codes pop as well??? The scan tool his mechanic uses says a possible cause (for most of the codes) is a faulty ground, bad connection to pcm, or bad pcm...? Any thoughts?? Frost???

    breakking...I think advance auto, O'reilly's, checkers, etc sells them for around the $160 mark.

  10. #10
    Junior Member
    Join Date
    Aug 2006
    Location
    N.Hollywood
    Age
    35
    Posts
    27

    black
    98 Trans Am

    The code was for a bad crankshaft sensor, I already replaced it with one from autozone and guy said it was shit.. Hes ordering me an ac delco one and it will be on in a couple hours.. I hope thats it.. I will keep you guys updated

  11. #11
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    If the code was P0336 for the CKP sensor read www.gearchatter.com/viewtopic8727.php if that doesn't fix it. Running out of fuel can cause it, and according to the link replacing it requires a variation relearn procedure.

  12. #12
    Junior Member
    Join Date
    Aug 2006
    Location
    N.Hollywood
    Age
    35
    Posts
    27

    black
    98 Trans Am

    got my car back from the mechanic.. Even though it threw a code for the crankshaft sensor, there was nothing wrong with it. Since I had installed headers, there were a couple cables that were werent secure and got burned..they look like speaker cable.. I have to ask what cables these are for exactly.. once he cut them and resoldered new cable, the car worked perfectly, no more wanting to turn off while driving.. tomorrow i will ask the mechanic what cables, so hopefully anyone experiencing similar symptoms might check these cables to see if their headers burned them.. thanks for all the feedback.

  13. #13
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Probably a + wire in the 02 harness, heater or signal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: truck computer versus car computer
    By BBCCarguy in forum Computer & Tuning
    Replies: 1
    Last Post: 11-03-2011, 09:47 AM
  2. Question: How much this going to cost me?
    By thegerberbaby in forum General Help
    Replies: 8
    Last Post: 10-08-2011, 10:07 AM
  3. How much does it cost
    By Spikito in forum Appearance Section
    Replies: 15
    Last Post: 02-15-2008, 02:22 PM
  4. Replies: 10
    Last Post: 10-29-2007, 04:50 AM
  5. what should this cost?
    By imprtkillr2810 in forum Firebird / WS6
    Replies: 4
    Last Post: 02-13-2007, 09:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •