Results 1 to 3 of 3

How much power loss ?

This is a discussion on How much power loss ? within the Computer & Tuning forums, part of the LSx Technical Help Section category; Well, i wanted to know how much power do you lose from pulling 2 degrees of timing so i can ...

  1. #1
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    How much power loss ?

    Well, i wanted to know how much power do you lose from pulling 2 degrees of timing so i can run nitrous safely. I can use what Frost has send me which allows the computer to only pull timing once i activate the switch on my nitrous but for my curiousity id like to know either way is there a significant power loss from pulling 2 degrees of timing.
    1993 Z28 M6: K&N Intake, 52mm TB, TB Bypass, No Cats, Exhaust Cutout, Flowmaster Muffler, 3.90 Gears, 160 Thermo, Tune, BMR Springs, Bilstein Shocks, 3 Point SFC,s & MGW Shifter.

  2. #2
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Hey Mike,

    That's not a question with a solid answer; there are more variables than you would be able to provide...

    With that said, I'd expect 5-9 rwhp depending on the combo, how close the timing was to optimal to begin with, etc.

  3. #3
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    Thanks Frost i was actually going to start the post by saying a message to FROST. I think once i install my headers im gonna send my computer back out to you to get it tuned for LT's, ORY and the tune for a 150 shot. I still have that thing you gave me to activate the tune for nitrous only when the nitrous system is activated and when im N/A it will not pull timing. The only problem i had with the that tune is even though i didnt install the LT's but was running the tune for LT's it seemed like i was hitting the rev limiter early in 1st and 2nd gears only. I think maybe because our cars tend to run rich after LT's install maybe some fuel was pulled in the top end and when i installed the computer without installing the LT's it was running too lean, maybe not sure. I need to get back to work and start making money been out for a couple of months, im lucky i work at a dealer and they give good pricing when it comes to labor.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Power loss
    By davidz28 in forum Camaro / SS
    Replies: 3
    Last Post: 09-11-2010, 09:00 AM
  2. Loss of power
    By 99RTA in forum General Help
    Replies: 0
    Last Post: 05-19-2009, 06:52 AM
  3. Help: Power loss
    By BIG GUNS in forum Internal Engine
    Replies: 1
    Last Post: 10-20-2008, 01:44 PM
  4. is this why i have power loss???
    By 02sscamaro in forum General Help
    Replies: 1
    Last Post: 09-13-2007, 02:15 PM
  5. Power loss
    By Even10Flow in forum Convertible
    Replies: 5
    Last Post: 05-16-2007, 08:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •