Results 1 to 7 of 7

ECU problems / Wth do I do now?

This is a discussion on ECU problems / Wth do I do now? within the Computer & Tuning forums, part of the LSx Technical Help Section category; Ok so I am no amazing car guru, I know general information that one should know about cars. How the ...

  1. #1
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    ECU problems / Wth do I do now?

    Ok so I am no amazing car guru, I know general information that one should know about cars. How the parts work what things are and such. I took my 01 TA to a good friend of mine here in town who owns a shop and races funny cars and dragsters. My car has been running like crap lately so he put my car on his diag equipment and told me that my car refuses to trim back at higher end and he doesn't know why. The 02 sensors are not reading anything stable at all either. He said they are random numbers from 0 on up. We cant figure out what is going on. He said he would need more time to run more tests as he had other appointments that day. He mentioned he was going to check the values at the sensors if possible then at the computer to see if they were the same or what not in attempt to determine weather or not the computer had gone bad. My car does have quite a bit of aftermarket mods on it that were there when i purchased the car and apparently the ecu was not replaced in it (we dont think) will have to pull it out to be sure.

    So any advice on where to go with this to try to figure out why the car wont trim back at all and where to go with diagnostic would be great.

    As well, if the computer is in fact in need of replacement could anyone suggest a reasonably priced computer I could pick up? Perf a good performance computer as the car has a ton of HP and I would like to enhance it rather than put just another stock computer in it.

    Any help or comments would be nice. Can never have enough leave mark her the more help the better.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by SilentTrouble View Post
    Ok so I am no amazing car guru, I know general information that one should know about cars. How the parts work what things are and such. I took my 01 TA to a good friend of mine here in town who owns a shop and races funny cars and dragsters. My car has been running like crap lately so he put my car on his diag equipment and told me that my car refuses to trim back at higher end and he doesn't know why. The 02 sensors are not reading anything stable at all either. He said they are random numbers from 0 on up. We cant figure out what is going on. He said he would need more time to run more tests as he had other appointments that day. He mentioned he was going to check the values at the sensors if possible then at the computer to see if they were the same or what not in attempt to determine weather or not the computer had gone bad. My car does have quite a bit of aftermarket mods on it that were there when i purchased the car and apparently the ecu was not replaced in it (we dont think) will have to pull it out to be sure.

    So any advice on where to go with this to try to figure out why the car wont trim back at all and where to go with diagnostic would be great.

    As well, if the computer is in fact in need of replacement could anyone suggest a reasonably priced computer I could pick up? Perf a good performance computer as the car has a ton of HP and I would like to enhance it rather than put just another stock computer in it.

    Any help or comments would be nice. Can never have enough leave mark her the more help the better.
    I'll take a quick stab even though I have no idea what that last line says.

    I'm a little confused on what you mean by it "refuses to trim back at higher end"? Is he reading the O2's in the upper rpm's? If so the O2's aren't used for fueling during power enrichment, the MAF sensor is. Do you have an oil based filter on there such as a K&N? Might just need to be cleaned with maf cleaner which you can get at parts stores. Typically a sign of a bad O2 is it'll flatline at 450mv for extended periods ( at least that's been my experience with them).
    The pcm would probably be the extremely very last thing I would look at. MAF first and if you have many miles on those O2's it might be a good idea to change those anyhow.

  3. #3
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    can never have enough comments leave your mark is what it should have read. however, i should have been more specific about what i ment with top end. Around town at slower speeds its not near as bad has highway and exceeding highway speeds the car wont trim back at all. he said he checked the vain MAF and it was fine so im not sure what to do.

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    can you describe what exactly your car is doing? How many miles are on it? What mods you have? Any new mods on it? Has the car thrown any codes (ses light on)? If you're running a K&N filter or other oil based filter the MAF should be cleaned on a fairly regular basis. It'll get a thin layer of oil on it and cause it to misread airflow. That's neither here nor there though because that's just maintenance. Are you exhaust tips sooted up more than they should be? There will be some soot in there but is it excessive? A description of exactly what the car is doing will help some.

  5. #5
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    Quote Originally Posted by 0rion View Post
    can you describe what exactly your car is doing? How many miles are on it? What mods you have? Any new mods on it? Has the car thrown any codes (ses light on)? If you're running a K&N filter or other oil based filter the MAF should be cleaned on a fairly regular basis. It'll get a thin layer of oil on it and cause it to misread airflow. That's neither here nor there though because that's just maintenance. Are you exhaust tips sooted up more than they should be? There will be some soot in there but is it excessive? A description of exactly what the car is doing will help some.
    Ok background on the car, as far as I know. When i purchased the car I paid 10k for the car. It has some interior blemishes that i fixed myself which was why the price was fairly cheap. From what i can tell its got an After market exhaust, tips, headers, heads, cam,stall, ( and was told it had rockers). The car it self has 45k miles on it an 01 TA. It had 42.5k miles on it when i purchased it. I have since replaced the oil and oil filter and cleaned out the air filter which had been replaced recently as it was quite clean. It looked to be just a standard napa issue paper air filter. As the intake is still stock (which with these mods is quite surprising) and i will be putting a new intake on it once i get the other things figured out. The SES light is on and Im not sure which codes its throwing exactally but i will be sure to find out. I know the car does not have a catalytic converter (illegal in most states im sure but dont tell.) When it was in the shop the MAF vain was cleaned although the thin layer was not really apparent which was our first thought so we cleaned it just to be sure. I havent had the car that long so I am not sure how sooted the exhaust tips should be for this vehicle. There is a nice coat of black soot around the inside of the tips though. I think the brand name is still visible as ractive or something like that.

    As far as what the car is doing, the car idle is rough while in park and very rough when in gear. It idles at about 750 in park and about 600 in gear when the car is warm and its warm outside. The problem is that the tac bounces because the idle is not steady it varies. It has a bad lunge when idleing through parking lots and what not which from what i can tell is because the idle on the car drops down below 450-500 and the car compensates and runs it back up to 1100 or so then it falls rapidly back to 450-500 rinse and repeat. the only way I have been able to deal with that lately is to hold the idle on the car with the gas pedal to about 800 and have other foot on the brake until i come to a complete stop. Once I come to a complete stop the car idles steady but still rough. this used to be so bad that i would kill the car when you put it in gear but that doesnt seem to happen anymore happened the first week i had it only. The gas mileage is pretty bad its getting 14-18mpg with most of that highway miles. I drive it from home to work which is about 15miles each way 5 times a week and thats pretty much all it gets driven while the weather isnt great outside. The car is running quite rich as it will smoke (not like an oil burn) when your just idleing and smells of unburnt fuel when behind it or in a semi enclosed area. Im actually calling the guy right now to see if he remembers what codes exactally it was throwing.

    Other than that the power is all still there, it drives great down the road when your cruising down the highway you can put the pedal down and start spinning your tires at 55 so theres no huge power loss.

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    I don't guess you know what size cam is in there do you? That idle sounds pretty low to me for any decent cam. 750 ain't bad but 600 seems pretty low to me. Everything you're describing to me sounds like the tune might need some work, do you know who tuned it? Also, where's the car from? Is it a local car or did you drive somewhere to pick it up? I'm not talking 100 miles though, is it a texas or colorado car or anything where the elevation and climate is much different to effect the tune?

  7. #7
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    Quote Originally Posted by 0rion View Post
    I don't guess you know what size cam is in there do you? That idle sounds pretty low to me for any decent cam. 750 ain't bad but 600 seems pretty low to me. Everything you're describing to me sounds like the tune might need some work, do you know who tuned it? Also, where's the car from? Is it a local car or did you drive somewhere to pick it up? I'm not talking 100 miles though, is it a texas or colorado car or anything where the elevation and climate is much different to effect the tune?
    Naw i got it in Kentucky and live in indiana couple hundred miles so that shouldnt be the problem. Im not sure the cam size but talking with others I came to conclusion that the idle is too low for the cam size they put in which is a minor adjustment. Im oddly afraid it didnt get a tune after the upgrades. Which is what i was going to have my shop friend do is tune. But he seemed strangely surprised that the car refused to trim back no matter what he did. Im not entirely sure what that means but he said that we have to find why it wont trim back and why the 02s are giving random non stable readings, before we try to tune and make the fuel atomize better.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •