Results 1 to 2 of 2

Vibration, I think I've tried it all, no luck

This is a discussion on Vibration, I think I've tried it all, no luck within the Drivetrain forums, part of the LSx Technical Help Section category; I have a 96 Formula convertible M6. It has a VERY strong vibration at 145 KPH (about 90 MPH) The ...

  1. #1
    Junior Member
    Join Date
    Mar 2006
    Location
    Calgary, Alberta
    Posts
    4

    Dark Teal
    96 Formula Convertible

    Question Vibration, I think I've tried it all, no luck

    I have a 96 Formula convertible M6. It has a VERY strong vibration at 145 KPH (about 90 MPH) The car has an aluminum driveshaft (changed years ago under warranty) I had the wheels balanced, no change. Then I checked the trans mount, it's good. Then I installed a Spohn torque arm and confirmed that the pinion angle is within 1 degree of the trans angle. This actually made the vibration feel worse, but I think it's because of the new mounting location and poly bushings. Next I changed the U-joints and had the driveshaft balance checked. Still no change. Finally I switched rims and tires to some old camaro take-offs that I had with Bridgestones on them. Still no change. What else can I do? The car drives well other than this, and the vibration dissapates a bit over 160 KPH (about 100 MPH) but at 145(90) it's VERY pronounced. Any ideas?

  2. #2
    Old Enough to Know Better Crimson Sin's Avatar
    Join Date
    Feb 2006
    Location
    Seattle..Land of Constant Rain..
    Posts
    1,426

    Red Fire
    2007 Mustang GT/CS

    Hmm I don't know if it will help, but I had a similar issue with my old 93 Cobra, made me crazy for about 9 mos, then one day a really old grizzled tech laughed at me and said change yer tranny.. I laughed and went on my way, 2 mos later and a new DNE ( Doug Nash Engineering) trans, vibration went away, speed shop I took it to said the undermain shaft was bad or somesuch, this is about10 years ago so the details are a bit hazy. Just something to think about..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oh My Bad Luck!
    By XcamaroZ06X in forum Camaro / SS
    Replies: 7
    Last Post: 05-19-2008, 02:43 PM
  2. Wtf!!!!!!!!!!! More Bad Luck
    By 01ls1ws6 in forum Firebird / WS6
    Replies: 22
    Last Post: 05-15-2008, 08:37 PM
  3. wish me luck
    By pecha in forum Almost Anything Goes
    Replies: 5
    Last Post: 03-28-2008, 08:01 PM
  4. no luck
    By F-Bomb in forum Almost Anything Goes
    Replies: 3
    Last Post: 02-03-2007, 09:26 AM
  5. Vibration, I think I've tried it all, no luck
    By 1 of 302 in forum Drivetrain
    Replies: 10
    Last Post: 11-05-2006, 07:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •