Results 1 to 10 of 10
Like Tree3Likes
  • 1 Post By DarrenWS6
  • 1 Post By pajeff02
  • 1 Post By cpop98ws6

Umi tourqe arm issues

This is a discussion on Umi tourqe arm issues within the Drivetrain forums, part of the LSx Technical Help Section category; So I installed my UMI tourqe arm relocation brace last weekend and I followed their instructions on mounting location for ...

  1. #1
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    47
    Posts
    1,078

    Silver
    1999 Trans-Am, 2012 Sonic

    Umi tourqe arm issues

    So I installed my UMI tourqe arm relocation brace last weekend and I followed their instructions on mounting location for the tourqe arm ( second hole from bottom for factory location) and I'm having some issues and not at all happy with it.....issue #1 there is a extreme amount of gear noise coming from the rear especially on deceleration, VERY LOUD in cabin...
    #2 when you hit 60-70 vibration is transferred through out the whole car feels like the drive shaft.
    #3 Y-Pipe is hitting the bracket and making all kind of noise, I can fix that with a little adjustment or trim a little from the bracket ( shouldn't have to) !!!!!!

    It is the T56 model, I'm thinking the pinion angle is off!!!
    I also have a UMI NON ADJUSTABLE TOURQE ARM , with a -2 degree angle...has been on car for 2 years with 0 issues
    If anyone has some insight on this please share I'm also going to contact UMI next week but as of Now for the first time I'm completely dissatisfied with this part....
    99 Trans Am, SLP Lid, Blackwing filter, smooth bellow, Ported TB, LS6 intake, Ws6 lower ram air box, OBX LT's, Magna Flow cat back, LS7 clutch, Tick MC, Hurst Shifter, Frost Tune, UMI SFC,LAC, STB, PB, Torq Arm, Super Hawk hood, Torq Thrust II, Kee Audio.
    Strange S60 4:10's, D&S Rotors, S/S Brake Lines.
    Nitto NT05R Track Tire's, 12.7 @ 108 / 1.82 60'
    Wish list.
    Coil overs, Heads & Cam

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,251

    Navy Blue Metallic
    98 T/A w/a little mods...

    Agree with the pinon angel being off. All classic signs of it.

    Did you install it while the rear suspension was under a load or have the jack stands under the axle?

    I found that when installing it the 1st time and again with installing my 8.8 rear doing it this way mention above lead to minimal issues and adjustments to correct pinon angle.


    Also mine is set from 2nd from the top. It may be because I'm lowered and have an adjustable TA

  3. #3
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    47
    Posts
    1,078

    Silver
    1999 Trans-Am, 2012 Sonic

    Car was on a lift so suspension was loaded

    I did some looking and seen a lot of write ups on the same exact problem also some insight from UMI and it looks as if I need to do a little trial and error until it's right.
    Hopefully I can get it back on the lift because it was a pain in the ass getting it in not to mention there is absolutely NO ROOM to get your hands in there to move the TA up or down so it will have to just about come out completely....
    Also seen where UMI tells guys to use 3rd hole others had to shim with washers where it mounts to the car to get it right!!!!! Performance stuff has its trade offs but for the first time of all the stuff I've changed on the car and there's a lot I'm disappointed!
    Thanks Scott and if anyone who is not lowered please feel free to share your install..

  4. #4
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    47
    Posts
    1,078

    Silver
    1999 Trans-Am, 2012 Sonic

    Well been extremely busy here working on the house so I decided a brake was needed and got after the car Friday night and removed the mount , tried removing the left side of the Y pipe but there was still no room to get to bolts...So I readjusted it and clearances were made for the exhaust so on the drive home there was no banging of the exhaust however the gear noise was still there on deceleration but not as bad so I think I went in the right direction...Saturday morning I took it out on the highway and 65-70 came back the vibration all the way through 125 seemed not as bad but still not acceptable!!!!! Rain here yesterday and today so I don't want to drive it to my friends house may possibly jack it up and do it here probably not...hahahaha the lift is dam nice for doing this job. One more adjustment left up and one all the way to the bottom don't think that is at all the way to go....one more time and then it's coming off.....

  5. #5
    Member DarrenWS6's Avatar
    Join Date
    May 2015
    Location
    Blossburg, PA
    Age
    27
    Posts
    396

    Silver Metallic
    2000 Trans Am WS6

    Well this is discouraging since i'm about to make a $650.00 order for some parts, the torque arm relcation kit being one of the items. Hopefully you get it figured out. I'll post about how my experience goes here soon.
    kingls1 likes this.
    2000 Trans Am WS.6 M6

    SLP lid & bellow w/ K&N, GMMG catback w/ Corsa Clones, UMI SFC, UMI Adj. Panhard, UMI Adj. TQ arm w/ relocation kit, Eibach prokit, Bilstein HDs, Nitto NT555s, skip shift elim, whiteface overlays, 20% tint, matte black decal/overlays

  6. #6
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    47
    Posts
    1,078

    Silver
    1999 Trans-Am, 2012 Sonic

    Decided to run up to my buddies despite rain all around and removed the brace and readjusted to the top holes on the adjustment so that is 4th hole from the bottom up or 1st holes from top down left me with 91* on the pinion and 89* on the drive shaft so that's a -2* swing... After test driving all gear noise is gone and seem to be No vibration at 70 mph...It feels a lot more raw but expected due to it now being mounted to the body and not to Trans with rubber mounts and rubber motor mounts....so as of now I believe it is fixed and ready for a track pounding that is coming shortly....as far as the rain I got caught just before arriving home so as soon as it slows I will be washing it!! Hahaha will be easier seeing how I'm not so angry anymore...

    Darren you'll definitely need the adjustable TA witch you were probably already getting so do some reading on pinion angle adjustments and do it before you lower it down. It should be a lot easier for you to adjust with a adjustable TA...also look for a digital angle finder before you do it should make it easier also.. You can pick one up for about $30 online. I was going to order one but didn't want to wait so I just used a needle guage

  7. #7
    Senior Member kingls1's Avatar
    Join Date
    Apr 2011
    Location
    Johnstown,PA
    Age
    47
    Posts
    1,078

    Silver
    1999 Trans-Am, 2012 Sonic

    After some drives and some spirited ones I'm pretty sure I'm making a track day and probably going back to stock in the spring!!! I love driving my car and hate it now after this one change. The idea is right but if your building a race car!! I am but not this one....

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,305

    Black & Blue
    '02 WS.6 / '07 Suburban

    Glad you got it figured out. If you ever think your torque arm is noisy again... drive our car and you'll never say another word about it.
    Last edited by pajeff02; 09-29-2016 at 03:13 AM.
    kingls1 likes this.

  9. #9
    Senior Member raynor139's Avatar
    Join Date
    Aug 2007
    Location
    Greensboro, NC
    Age
    32
    Posts
    1,288

    Pewter
    2002 Trans Am WS6 M6

    Quote Originally Posted by pajeff02 View Post
    Glad you got it figured out. If you ever think your torque arm is noisy again... drive our car and you'll never say another word about it.
    Tunnel mount?
    Mods - Lid, Skip Shift Eliminator, MGW shifter, UMI SFCs, Founders Lower Control Arms, Founders Panhard Bar, Founders Adj. Torque Arm, UMI Torque arm mount, MWC Drive shaft safety loop, KONI Yellows, Strano Springs, Strano Sway bars, UMI Upper and lower A Arms, 160 thermostat, TSP headers and TSP true duals Monster stage 2 clutch, racetronix fuel pump, Strange S60 rear axle and tune by Frost.

  10. #10
    Senior Member cpop98ws6's Avatar
    Join Date
    May 2010
    Location
    Wilkes-Barre, PA
    Posts
    1,545

    Black/Black
    98 WS6/04 Sierra Dmax

    Quote Originally Posted by pajeff02 View Post
    Glad you got it figured out. If you ever think your torque arm is noisy again... drive our car and you'll never say another word about it.
    Mine is pretty damn noisy also, but I live with it.
    kingls1 likes this.
    Callies 383, Trick Flow 225, Rapid Motorsports Dominatior 2 X cam, ls6 ported oil pump,42lb injectors, FAST 92/92 , ASP underdrive pully, eletric water pump, Pacesetter LT's, Pacesetter ORY, Magnaflow catback, e-cutout, Yank SS 3600, Performabuilt stage 2 4l60e, Strange S60 ,4.10s, Detroit Truetrac, (UMI) - Adj. LCA, Adj. tunnel mount torque arm, Adj. panhard bar, Drag bar, subframe conectors, shock tower brace. 465rwhp-438rwtq 11.09@119.90.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Help with Tourqe Sequince
    By bh400ex in forum Internal Engine
    Replies: 9
    Last Post: 01-18-2010, 02:49 PM
  2. how much tourqe am i at?
    By lookngoodSS in forum Camaro / SS
    Replies: 5
    Last Post: 01-08-2010, 03:54 PM
  3. tourqe thrust ll
    By TransamDemon2000 in forum Wheels and Tires
    Replies: 7
    Last Post: 12-30-2007, 06:10 AM
  4. tourqe converter
    By bigboy T/A in forum Automatic Transmission
    Replies: 2
    Last Post: 06-04-2007, 08:39 AM
  5. i snapped my stock tourqe arm...
    By Spaz in forum Suspension and Handling
    Replies: 6
    Last Post: 05-27-2006, 12:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •