Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29

the trans mount saga

This is a discussion on the trans mount saga within the Drivetrain forums, part of the LSx Technical Help Section category; Originally Posted by INMY01TA Why? Not hard to switch it back if you don't like it.... Then I have a ...

  1. #21
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Quote Originally Posted by INMY01TA View Post
    Why? Not hard to switch it back if you don't like it....
    Then I have a mount left over, i could spend that money on LCAs or something

  2. #22
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Quote Originally Posted by allbaugh_04 View Post
    Then I have a mount left over, i could spend that money on LCAs or something
    I think mine was like $15...

  3. #23
    Junior Member 2002blackz28's Avatar
    Join Date
    Jun 2009
    Location
    michigan
    Posts
    76

    black
    2002 camaro z28

    I just installed the prothane tranny mount sunday morning. Lots of vibrations gets worse at highe RPM. I went to the local advance auto the guy there told me it might not be adjusted right. I told him I don't think it can be adjusted. He said that It threw of the angles in the drive shaft and the U-JOINTS are causing the vibration. There is a bolt that gets screwed in the mount and then I bolt the crossmember in . I screwed it in all the way then tightened down the nut. I guess I will take it in the ass at the dealer monday

  4. #24
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    They soften up really fast. I didn't like it when I first installed mine, soon after I didn't notice it at all. Give it some time.

  5. #25
    Junior Member 2002blackz28's Avatar
    Join Date
    Jun 2009
    Location
    michigan
    Posts
    76

    black
    2002 camaro z28

    Do you have the prothane one installed? I just got off the phone with JEGS. They claim that they have not had any complaints about vibrations. I find that hard to beleive . I thought about putting some 1/8th'' thick rubber shims between mounting point on the mount and cross member, thinking maybe it would take car of the vibrations av little more. I will try it out later today. If not the vibrations are pretty annoying and will replace with dealer one.

  6. #26
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Quote Originally Posted by 2002blackz28 View Post
    I just installed the prothane tranny mount sunday morning. Lots of vibrations gets worse at highe RPM. I went to the local advance auto the guy there told me it might not be adjusted right. I told him I don't think it can be adjusted. He said that It threw of the angles in the drive shaft and the U-JOINTS are causing the vibration. There is a bolt that gets screwed in the mount and then I bolt the crossmember in . I screwed it in all the way then tightened down the nut. I guess I will take it in the ass at the dealer monday
    If the mount is thicker or thinner than the OEM mount, yes, it can throw off the angle and create vibrations.

  7. #27
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    I believe mine is Energy Suspension, but not sure.

  8. #28
    Junior Member 2002blackz28's Avatar
    Join Date
    Jun 2009
    Location
    michigan
    Posts
    76

    black
    2002 camaro z28

    I just changed it back to the old G.M one. Its not worn out, yet just signs of a little tearing. I did notice almost a 1/4'' differance between the two. I will purchase the dealer one monday. Just to much vibration for me. I don't want bolts to start falling out.

    Thanks for all the input guy's

  9. #29
    Member TRANS-DAD's Avatar
    Join Date
    Mar 2008
    Location
    PASADENA,TEXAS
    Posts
    391

    BLACK
    2001 T/A VERT.

    If you don't mind spending money you can run a stock trans mount & chang the crossmember to a BMR & take the torque arm off the tail shaft of trans! you wont
    need a prothane mount.
    With this set up trans basicly just sit's on rubber w/no stress

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Saga of the Trans Am Parking light
    By GULLETT17 in forum Firebird / WS6
    Replies: 222
    Last Post: 09-01-2016, 02:08 PM
  2. I think I got a Bad Trans Mount!
    By Adam_WS6_ in forum Manual Transmission
    Replies: 0
    Last Post: 07-30-2008, 12:21 PM
  3. M6 Trans mount
    By ss~zoso~ss in forum Manual Transmission
    Replies: 3
    Last Post: 04-10-2007, 08:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •