Results 1 to 6 of 6

Torque Arm Mount??

This is a discussion on Torque Arm Mount?? within the Drivetrain forums, part of the LSx Technical Help Section category; I've made other threads before about a clunking sound that I thought was coming from the drivetrain somewhere. It would ...

  1. #1
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Torque Arm Mount??

    I've made other threads before about a clunking sound that I thought was coming from the drivetrain somewhere. It would happen anytime I depressed the clutch quickly or something.

    Now I'm starting to wonder if its maybe the TA mount. I haven't had a chance to actually unbolt it to see if its broken yet.

    The clunking sound happens really bad when I pulsate the gas pedal to make the car buck. I can also make it happen if im slowing down in 1st gear (engine breaking kinda) and a quickly press the clutch down. Its coming from somewhere under the car but I can't pinpoint it for the life of me. Any ideas?

  2. #2
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Forgot to mention I already swapped out the tranny mount.

  3. #3
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    Torque arm mount. The rubber bushing on the back of the transmission. Could also be binding U joints on the drive shaft. Check torque arm and see if it's loose first.

  4. #4
    Junior Member FLEX3269's Avatar
    Join Date
    Aug 2006
    Location
    Orlando, Florida
    Age
    38
    Posts
    49

    Black
    2002 Trans Am

    Do you have an ORY pipe with no cats for your exhaust syatem? Right after i had mine installed i noticed that if i hit the gas really quick there would be a banging noise under the driver side. I was from the engine torquing when i hit the gas, it made the pipe slam up and hit the floor board.

  5. #5
    Senior Member Rhinohuey's Avatar
    Join Date
    Mar 2007
    Location
    Glendale, AZ
    Posts
    1,460

    Black
    1999 Trans Am

    Quote Originally Posted by FLEX3269 View Post
    Do you have an ORY pipe with no cats for your exhaust syatem? Right after i had mine installed i noticed that if i hit the gas really quick there would be a banging noise under the driver side. I was from the engine torquing when i hit the gas, it made the pipe slam up and hit the floor board.
    nope stock exhaust.

    i still haven't found the problem...this is driving me crazy

  6. #6
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    Could be the front yoke not sliding on the splines of the tranny's output shaft too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. For Sale: umi tunnel mount torque arm brace and on car adj torque arm
    By 99yellowz28 in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 07-10-2011, 09:33 AM
  2. UMI Torque Arm Mount (Tunnel Mount)
    By Z28boy2000 in forum Parts For Sale / Trade
    Replies: 2
    Last Post: 01-15-2011, 04:28 PM
  3. Body Mount Torque Arm
    By 95GreenZ28 in forum Parts For Sale / Trade
    Replies: 1
    Last Post: 09-30-2007, 08:22 AM
  4. Need a good T56 (LS1) Stock Tranny mount & Torque arm mount..
    By 1slosnake in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 06-19-2006, 04:04 PM
  5. Need a good T56 (LS1) Stock Tranny mount & Torque arm mount..
    By 1slosnake in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 06-13-2006, 06:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •