Results 1 to 16 of 16

thud shifting from 1st to second

This is a discussion on thud shifting from 1st to second within the Drivetrain forums, part of the LSx Technical Help Section category; my car often makes a loud THUD when shifting hard near red line from 1st to second..i have an aftermarket ...

  1. #1
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    thud shifting from 1st to second

    my car often makes a loud THUD when shifting hard near red line from 1st to second..i have an aftermarket aluminum driveshaft lingenfelter installed. What do u think this thud could be? and how come my tires arnt breaking loose instead.....somtimes both happens.....thud and they break loose.and somtimees they just break loose.....but MOST of the time it makes that thud ..its a god awful sound...other than that everything seems perfect with the car/tranny ..any suggestions???

  2. #2
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    forgot to mention...prolly important to know car isnt running drag rads ....mich pilot sports with about half tred life left.....they grip well but THEY should be giving in second not somthing else

  3. #3
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    m6 car as well....lol im good at lacking info..and the clutch holds VERY well....spec 3 barely broken in

  4. #4
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    check you trans and torque arm mount.

  5. #5
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    hum..still new to this stuff...any explaination on where i can find the tranny mount and tourqe arm would help tons n tons..i certianly have an idea but ill take all the advise i can get..lol.....suspension is stock btw in reguards to the tq arm ..thank you

  6. #6
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    at the back of the transmission

  7. #7
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    ty for the pic..ill check it out tomorrow....am i looking for it to be loose? broken? looks pretty simple

  8. #8
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Good pic...I believe my torque arm bushing/mount is falling apart, last time I was under there the rubber part was all split apart pretty bad.

    Wheres a good place to get a replacement torque arm mount??

  9. #9
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    energy suspension make a poly version for stock arms. other than that, back to the dealer for a stock replacement. the two halves are riveted on to the brackets. so, you may have to buy the whole assembly from the dealer.

  10. #10
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    ok went to new era performace today..great guys over there...they took a look and the tranny mount was fine and i had a bmr tq arm put in..after doing both the thud is still present...they think it could be the spec clutch as theve seen them do this before where they grab then skip and it makes a thud....have u guys heard of this out of spec? it was made in 01 spec 2 or 3 maybe? dunno what to do....if i spend the money on a new clutch and the prb is still there im gonna be pissed...as mine feels fine otherwise..whats everyone think?? thanks

  11. #11
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    never heard that bout a clutch before.. i have had a spec 1 and now a spec 2 with their billet steel flywheel...and i dont have a thud..only time i did i had ripped my polyeurethane bushings for the torque arm and the tranny mount both..

  12. #12
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    sounds like it could be the slave cylinder

  13. #13
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    really? how could the master slave cylinder cause this prb? and its a 2001 so it already has the updated master slave???? would def be a cheaper fix if that IS the prob...my clutch pedal rides very high as well..feels ok though..thanks for the replies..keepem coming .i want to get this fixed but i dont wanna spend thousands trying diff things to make it happen

  14. #14
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    reason i say that is because when mine was thudding going in and out of first, it was because of my slave cylinder. yes your master is updated, but that doesnt mean it cant and wont fail. New Era is just right there like you said. I got my ram adjustable master cylinder from Mike. It was a simple install..well to me it was.

  15. #15
    Senior Member
    Join Date
    Sep 2005
    Location
    rochester,ny
    Age
    39
    Posts
    2,667

    pewter
    2001 z28 lingenfelter 383

    what do u think of your ram?and which one did u get? total cost? thats what mike suggested to me..im at about 450 flywhl horse now and only plan on adding headers in the future to top it out around 480 so i dont need anything to rediculous....i like a near stock feel with lots of grip.

  16. #16
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    my setup is as follows:
    ram billet flywheel
    ram powergrip HD
    ram adjustable master
    new slave

    Its a great setup, but stiff. I dont mind it though. this is my second ram. I replaced the first because i blew the slave and knew before it went out it had to have been giving uneven pressure causing uneven wear on the clutch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with Thud Sound
    By 99WS6MAN in forum General Help
    Replies: 7
    Last Post: 10-27-2010, 06:42 PM
  2. Thud Thud Thud Thud/ Where is this noise?
    By Hi-Po in forum General Help
    Replies: 27
    Last Post: 04-29-2009, 03:54 AM
  3. Rearend clunk/thud...
    By CamaroFan71 in forum General Help
    Replies: 4
    Last Post: 02-04-2009, 07:32 PM
  4. Thud/knock/bump
    By UKXK189 in forum General Help
    Replies: 4
    Last Post: 07-18-2007, 10:39 PM
  5. thud noise when shifting.
    By johneboy71 in forum Drivetrain
    Replies: 8
    Last Post: 08-20-2006, 04:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •