Page 1 of 2 12 LastLast
Results 1 to 20 of 35

strange scary noise coming from my motor, help.

This is a discussion on strange scary noise coming from my motor, help. within the Drivetrain forums, part of the LSx Technical Help Section category; Ok i have an '02 Z with 30k on it. It does have the piston slap. There is a new ...

  1. #1
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Exclamation strange scary noise coming from my motor, help.

    Ok i have an '02 Z with 30k on it. It does have the piston slap. There is a new noise that has only happened twice but it sounds horrible. Each time i drove my car like 40 miles, then it sat and cooled for like 6 hours or so. It was still like 80 degrees out so it's not like it was that cold. But when i fired it up there was a whine coming from the motor. I know it was the motor. But the first time it did it I thought i was the throw out bearing for the clutch but only because of the initial sound. I was playing with the clutch and it didn't change the sound so i know it wasn't that. The sound sped up so to speak when i gave it gas. I really have no idea what the hell it is, it went away once it warmed up. Help me out guys i don't have a clue. I put 10-30w in the car perhaps the wrong oil if i have the piston slap?

  2. #2
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    I had a similar noise a long time ago that just went away but may not be what you are experiencing. How bad is the piston slap-on a cold start how long does it take till the slap goes away? I use 10-40 in my car.

  3. #3
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    eh, piston slap is pretty loud, i don't have headers and i heard it get louder with headers but i'm not sure. After the car is at norm op. temp. the slap is almost completely gone. Sometimes i don't hear it at all when the car is warm. This noise also changes with the RPM's.

  4. #4
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Damn dude I would be pissed if my car had such low miles and slapped even when it got warm. Any chance it could be a lifter or valvetrain related?

  5. #5
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Quote Originally Posted by BREAKxNECKxSPEED View Post
    Damn dude I would be pissed if my car had such low miles and slapped even when it got warm. Any chance it could be a lifter or valvetrain related?
    You mean the piston slap or the new noise i'm hearing? If anything in the motor is sounds like a bearing whining but i don't know yet. Each time i heard it i was in a rush so i didn't get to check it out that much.

  6. #6
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    take your serpentine belt off and run it like that for a few seconds and see if the noise goes away. you may get lucky and find a bad idler pulley or maybe a pump or something let me know

  7. #7
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by 02ultraZ View Post
    You mean the piston slap or the new noise i'm hearing? If anything in the motor is sounds like a bearing whining but i don't know yet. Each time i heard it i was in a rush so i didn't get to check it out that much.
    I was talking about the pistin slap-seems odd that it doesnt go away when the car gets warm. All I can suggest for the whining problem is letting someone you trust as a mechanic listen to it. I do not suggest taking it to GM service-ever. Maybe you could make a video so we can hear it also.
    Good luck bud.

  8. #8
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Ever think it could be your AIR pump, mine whines like blower till it warms up, I come on if the car has cooled enough to drop below a set range.

  9. #9
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Quote Originally Posted by Orcus79 View Post
    Ever think it could be your AIR pump, mine whines like blower till it warms up, I come on if the car has cooled enough to drop below a set range.
    Thats what it sounds like a blower, i think you guys are right about the air pump, i fired the car up and took it for a spin last night. It didn't make the noise. It sat for an hour and i started it again and still nothing. So if it's my air pump would it be so inconsistent?

    Thanks for all the help guys

  10. #10
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    because all it does is suck fumes from the gas tank, it doesnt always need to do it, its based on engine temperature, and fuel range. i think. but yeah it kinda sounds like a little vacuuum, its located under the relays and fueses on driver side close to the front of the car,

  11. #11
    Run what you brung
    Join Date
    Jan 2006
    Location
    Leesburg va
    Age
    35
    Posts
    82

    Black
    2002 Transam

    Quote Originally Posted by camarojunky74 View Post
    because all it does is suck fumes from the gas tank, it doesnt always need to do it, its based on engine temperature, and fuel range. i think. but yeah it kinda sounds like a little vacuuum, its located under the relays and fueses on driver side close to the front of the car,
    ok, the air pump does not suck fumes from the gas tank (there are no lines running from the pump to your fuel at all). the AIR pump, upon cold starts turns on an electric motor and pumps air from the side of your airbox after the air filter (the tube going into the side of the airlid) to the motor and then pumps that air into the tops of BOTH of your exhaust manifolds directly (Via, A.I.R. Tubes) this is done so that when when vehicles are on rollers for emissions the air pump forces the clean air in to the exhaust so it seems that the vehicle burns cleaner.

  12. #12
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    oh snap my bad, i was thinking of the damn charcoal canister for some dumb reason..

    yeah your right... nice

  13. #13
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Quote Originally Posted by Raven02ta View Post
    ok, the air pump does not suck fumes from the gas tank (there are no lines running from the pump to your fuel at all). the AIR pump, upon cold starts turns on an electric motor and pumps air from the side of your airbox after the air filter (the tube going into the side of the airlid) to the motor and then pumps that air into the tops of BOTH of your exhaust manifolds directly (Via, A.I.R. Tubes) this is done so that when when vehicles are on rollers for emissions the air pump forces the clean air in to the exhaust so it seems that the vehicle burns cleaner.
    So do you still think this would be making this noise? And then what shuts the air pump off when the vehicle is warm. And also when it does shut off does it slow down then shut off, or shut off completely instantly. The reason i ask that is if i listen to the car when i hear this whine and the whine slowly goes away, or the whine stops instantly, i will know it's the air pump. And i still haven't heard it again. So it's pissing me off.

  14. #14
    Run what you brung
    Join Date
    Jan 2006
    Location
    Leesburg va
    Age
    35
    Posts
    82

    Black
    2002 Transam

    Its actuated by a relay which i think is kicked over by the coolant temp reading in the pcm. the pump winds down when it turns off.

  15. #15
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Quote Originally Posted by Raven02ta View Post
    Its actuated by a relay which i think is kicked over by the coolant temp reading in the pcm. the pump winds down when it turns off.
    So it winds down only taking a few seconds, meaning that the airpump only has one speed-on.

  16. #16
    Run what you brung
    Join Date
    Jan 2006
    Location
    Leesburg va
    Age
    35
    Posts
    82

    Black
    2002 Transam

    Quote Originally Posted by 02ultraZ View Post
    So it winds down only taking a few seconds, meaning that the airpump only has one speed-on.

    Thats correct.

  17. #17
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    cool thank for all the help guys.

  18. #18
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    Ok update guys, it's not my air pump. I pulled the fuse for the pump the last time it made the noise. It was the same type of scenario too, i drove it for a while and parked it for maybe two hours. Started it and the noise started, i pulled the fuse it didn't stop...I popped the hood and it sounds like its coming from inside the motor! No matter which side of the car i stood on i put my ear right down to the motor and it sounded like it was coming right from the middle of the motor. What do you guys think!?

  19. #19
    Senior Member 02ultraZ's Avatar
    Join Date
    Jun 2007
    Location
    Harrisburg, PA
    Age
    31
    Posts
    1,515

    Blackety Black
    35th Anniversary SS

    It did stop after about 3-4 minutes, i didn't check the temp but should have.

  20. #20
    Member TACE02's Avatar
    Join Date
    Aug 2005
    Location
    Texas
    Age
    41
    Posts
    568

    ASC #753
    2002 Collector's Edition

    not my area of expertise, but from the way you describe it, it sounds like a bearing (cam) possibly or maybe even harmonic balancer. I would hope not the cam bearing though. balancer is quick and easy comparatively and less expensive of a task. good luck, and hopefully it is something easy and inexpensive. also did this just start happening, and if so was it just after an oil change, if so, maybe start there and change oil.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: strange noise!
    By 98maro in forum Suspension and Handling
    Replies: 4
    Last Post: 05-30-2012, 08:00 PM
  2. Strange sound coming from rear end
    By dreed2 in forum General Help
    Replies: 3
    Last Post: 08-15-2009, 09:54 AM
  3. strange scary noise coming from my motor, help.
    By 02ultraZ in forum Camaro / SS
    Replies: 8
    Last Post: 08-06-2007, 01:31 PM
  4. Easter is coming... strange conspiracies...
    By Spaz in forum Almost Anything Goes
    Replies: 47
    Last Post: 03-30-2007, 01:25 PM
  5. Strange sound coming from brakes...
    By chris5 in forum General Help
    Replies: 5
    Last Post: 12-07-2005, 11:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •