Results 1 to 4 of 4

Still Same Clutch Problem

This is a discussion on Still Same Clutch Problem within the Drivetrain forums, part of the LSx Technical Help Section category; Shop says everything looks good But it isn't It's like this is something that has never happen so long as ...

  1. #1
    Member Fade2Black's Avatar
    Join Date
    Aug 2005
    Location
    Detroit Michigan
    Age
    30
    Posts
    303

    Silver
    2000 TransAM M6

    Still Same Clutch Problem

    Shop says everything looks good
    But it isn't
    It's like this is something that has never happen so long as there have been manual transmissions

    When I hit about 5000 rpm clutch doesn't come back up on its own. (racing or downshifting to get a move on)

    Never happens in 1st gear I can get through that gear clean.

    So far the only possibility anyone has been able to come up with is there may be something wrong internally in the master
    I did get something in the mail though about the catalytic converter failure in the 2000 models I was thinking that could have something to do with it since the problems is at high RPM and the computer did say i was having a converter problem hence the check engine light.

  2. #2
    Junior Member
    Join Date
    Nov 2005
    Location
    pa
    Age
    30
    Posts
    93

    black
    1999 camaro

    samething happened to me, I got a new slave cynlinder and a new clutch and that took care of it. Now I herd alot of guy say just getting the slave will take care of it but I figured might as well spend a couple more bucks and do the new clutch 2.

  3. #3
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by Fade2Black View Post
    Shop says everything looks good
    But it isn't
    It's like this is something that has never happen so long as there have been manual transmissions

    When I hit about 5000 rpm clutch doesn't come back up on its own. (racing or downshifting to get a move on)

    Never happens in 1st gear I can get through that gear clean.

    So far the only possibility anyone has been able to come up with is there may be something wrong internally in the master
    I did get something in the mail though about the catalytic converter failure in the 2000 models I was thinking that could have something to do with it since the problems is at high RPM and the computer did say i was having a converter problem hence the check engine light.
    The computer and cat converter would have nothing to do with the hydraulic clutch system. The ECU doesn't monitor the clutch system at all, its independent from the rest of the powertrain.

    I'd replace the slave cylinder first and bleed the system. If that doesn't fix the issue, then replace the master as well.

  4. #4
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    Quote Originally Posted by Wesman View Post
    The computer and cat converter would have nothing to do with the hydraulic clutch system. The ECU doesn't monitor the clutch system at all, its independent from the rest of the powertrain.

    I'd replace the slave cylinder first and bleed the system. If that doesn't fix the issue, then replace the master as well.
    i've heard the same. somebody else on here said he replaced the master and it took car of it. the same shit happened to my car a few weeks back...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another clutch problem
    By ali pontiac in forum Manual Transmission
    Replies: 2
    Last Post: 09-29-2010, 03:43 AM
  2. LS7 clutch problem.....
    By nmssr08 in forum Manual Transmission
    Replies: 14
    Last Post: 12-16-2008, 05:57 AM
  3. Clutch Problem
    By Blackout01 in forum Manual Transmission
    Replies: 2
    Last Post: 08-07-2007, 03:48 PM
  4. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM
  5. Clutch problem..help please
    By Scorch in forum Manual Transmission
    Replies: 16
    Last Post: 03-02-2006, 10:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •