Results 1 to 5 of 5

possiable U-joint bad?

This is a discussion on possiable U-joint bad? within the Drivetrain forums, part of the LSx Technical Help Section category; Hey guys I'm not really new here but just have been absent for a couple of years while i had ...

  1. #1
    Junior Member
    Join Date
    Jan 2006
    Location
    Louisa, VA
    Posts
    43

    Black
    1999 Camaro Z28

    Arrow possiable U-joint bad?

    Hey guys I'm not really new here but just have been absent for a couple of years while i had a momentary brain fart and sold my old '99 Z28....now 3 years later I've again got a '99 Z28 pretty much exactly the same as my old one it's got the A4 tranny in it and the car seems pretty fast it still had the stock exhaust on it when i bought it but has a K&N intake system and i know it's bound to have some aftermarket gears in the rear. The car came stock with 3.23's in it but at 60mph in overdrive it's taching about 2K seems a little hight for 3.23's i thinking maybe 3.73's? anyways enough rambling on under hard acceleration you hear a sorta THUD when you intially hit the gas. My friend tells me this is most likely the universal joint having some play in it...We are going to check it tomorrow at work just to make sure but I'm kind of looking for a little comforting tonight lmao I love this car and i don't wanna be thinking something else might be wrong? Thanks guys!

  2. #2
    Member Orange SS's Avatar
    Join Date
    Aug 2005
    Location
    Palm Bay, FL
    Age
    43
    Posts
    195

    Ermine White
    1964 Chevelle

    check tranny mount

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    www.f-body.org/gears/ is what I use after tuning to make sure my gear swap takes, it's accurate for my 2.73/3.42


    Forgot to welcome you back!
    Last edited by 2001NBMZ28; 02-07-2006 at 10:40 AM.

  4. #4
    Junior Member
    Join Date
    Jan 2006
    Location
    Louisa, VA
    Posts
    43

    Black
    1999 Camaro Z28

    Well we check the U-joints today at work and they seem to be fine. We are going to look more closley at it Thursday but I'm leaning towards the tranny mount now too. It seems to be almost right below the drivers seat and when it does it you hear a thud like noise and also sort of a screeching sounds almost like a spinning a tire except the tires are not spinning lol.

  5. #5
    Junior Member
    Join Date
    Jan 2006
    Location
    Louisa, VA
    Posts
    43

    Black
    1999 Camaro Z28

    Quote Originally Posted by 2001NBMZ28


    Forgot to welcome you back!

    Thanks it's good to be back and awesome to be behind the wheel of a LS1 again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. u joint help
    By SilverBulletLS1 in forum Drivetrain
    Replies: 4
    Last Post: 01-16-2014, 08:06 AM
  2. So tell me about my u-joint
    By goof4080 in forum Drivetrain
    Replies: 3
    Last Post: 07-03-2012, 04:44 PM
  3. Question: u joint??
    By Karczewski in forum General Help
    Replies: 4
    Last Post: 10-26-2011, 10:22 AM
  4. Question: Bad u-joint???
    By joedude02 in forum General Help
    Replies: 2
    Last Post: 11-02-2008, 10:09 PM
  5. U-Joint
    By 01CalgarySS in forum Drivetrain
    Replies: 3
    Last Post: 09-18-2008, 06:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •