Results 1 to 8 of 8

I'm screwed, right?

This is a discussion on I'm screwed, right? within the Drivetrain forums, part of the LSx Technical Help Section category; Well, I changed out my rear end oil and put in Royal Purple along with the additive. Didn't help at ...

  1. #1
    Junior Member
    Join Date
    Jun 2010
    Location
    Hallsville, MO
    Posts
    26

    Silver
    2002 TA WS6 M6

    I'm screwed, right?

    Well, I changed out my rear end oil and put in Royal Purple along with the additive. Didn't help at all.

    Then drove 6 hours to chicago and then back and it's REALLY making noise noise.

    Video ZIP file removed

    if you can look at this vid and tell me if I'm screwed. I don't really want to have the rear end worked on - would rather take that money and buy a better, more heavy duty one.

    I plan on never having more than 400hp coming out of the engine. About done dumping money in this pit.

    Thanks for your time and opinions. Suggest a good replacement mid line rear end if you can.

    Dan
    Last edited by Cutlass; 07-20-2010 at 05:23 PM.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I'm a little leary of downloading a ZIP file to watch your video. No offense and nothing against you, I'm just trying to protect myself and other members from potential virus problems.
    Can you post your video on Photobucket or YouTube and link to it so we can watch it worry free
    Like I said, no offense to you at all. I'm curious to see the vid!

  3. #3
    Junior Member
    Join Date
    Jun 2010
    Location
    Hallsville, MO
    Posts
    26

    Silver
    2002 TA WS6 M6

    Yeah, i can understand the hesitation.
    Alot of sick people out there.
    I'll see about uploading to youtube. It's 54MB.

    Dan

  4. #4
    Junior Member
    Join Date
    Jun 2010
    Location
    Hallsville, MO
    Posts
    26

    Silver
    2002 TA WS6 M6

    Here's the public vid

    [ame]http://www.youtube.com/watch?v=xNS52OxSjWg[/ame]

    sorry about the .zip guys. There's some sick pupies out there that ruin it for the rest of us.

    Dan

  5. #5
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    Yup, you're boned! Looked like the pinion bearing took a dump.

    I'm no expert though... But you are boned, that's fer sure...
    67 Camaro: K-K + 797-z (look it up), 454/Th400/4.10 12-bolt = 6mpg, PS/PDB/PW tilt, tach, gauges...

    2005 Corvette LS2/M6 Magnetic Red Metallic (What else would it be?) w/ Cashmere interior

    2002 Z28: NBM/Tan, MTI smooth lid, smooth bellows, !AIR, !cats, 1-3/4" QTP SS LT's, 2-1/2" TD's with X-pipe, MagnaFlows dumped at axle, custom welded SFC's, MidWest Chassis body mount adjustable T/A, 3400 stall, 3.23 gears (was 2.73). Tuned: 343rwhp/357rwt (before TD's). Best: 12.559 @ 108+, 1.73 60' @ 3500' DA w/MT ET Street DR's.

    Carbon footprint? CLOWN SHOE!

  6. #6
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Yeppers, Jim is right. Not only are the bearings toast, but that also ruins the gear set. No more nice pattern, and noisy gears from here on out.

    That will have to be completely gone through, new gears, bearings, seals etc....and the housing flushed,,,it's probably full of crap. So I'd replace axle bearings too to be on the safe side.

    I'm even amazed it's not leaking yet. I don't see anything wet around there. The seal can't do it's job with the yoke wobbling around,,,lol. Usually they spew oil.
    Last edited by Firebirdjones; 07-20-2010 at 07:49 PM.

  7. #7
    Junior Member
    Join Date
    Jun 2010
    Location
    Hallsville, MO
    Posts
    26

    Silver
    2002 TA WS6 M6

    Thanks for the info.
    I drove back from CHicago yesterday with it like this [6 hour drive].
    not too bad at 70mph, but in towns and slowing down sounded like it was going to fall apart. lol

    Instead of rebuilding, I'm just going to install a fab'd 9" from Midwest.... Expensive, but looks like it's a one time deal. I want to have fun in the car - not walk on eggshells.

    Dan

  8. #8
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    That's a good idea. You'll never look back after getting a 9".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Am I Screwed??
    By rajiv1998 in forum Almost Anything Goes
    Replies: 17
    Last Post: 10-22-2010, 05:06 AM
  2. Help: OMG how screwed em I?!
    By TransAmPhantom in forum General Help
    Replies: 31
    Last Post: 07-05-2010, 01:26 AM
  3. So am I screwed?
    By burnws6 in forum Almost Anything Goes
    Replies: 94
    Last Post: 07-31-2007, 06:21 AM
  4. Screwed
    By silver98TA in forum General Help
    Replies: 9
    Last Post: 05-28-2007, 11:50 AM
  5. I'm screwed......
    By HASTINGSRJ in forum Western Members
    Replies: 18
    Last Post: 08-18-2005, 03:47 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •