Results 1 to 10 of 10

HELP - Spohn torque arm problems

This is a discussion on HELP - Spohn torque arm problems within the Drivetrain forums, part of the LSx Technical Help Section category; Ok so i have a spohn crossbrace mounted adj. torque arm on my T/A and it has always made alot ...

  1. #1
    Member wesTXwitesnake05's Avatar
    Join Date
    Feb 2006
    Location
    Midland TX
    Posts
    249

    White with silver stripes
    2000 Trans Am WS6

    Exclamation HELP - Spohn torque arm problems

    Ok so i have a spohn crossbrace mounted adj. torque arm on my T/A and it has always made alot of road noise. recently i lost the nuts to the long bolts that go thru the rear ends torque arm mount. i replaced these bolts with spohn torque arm mounting hardware kit. but now when i hit a bump or brake quickly it sounds like the whole damn thing is either going to fall off or come straight thru my center console!! ive checked all the bolts and nuts to make sure there tight and i greased all the bushings.



    WHAT THE HELL IS WRONG!! does anyone running this torque arm have exessive noise from this $435 piece of shit?

  2. #2
    Member Sunset T/A's Avatar
    Join Date
    Oct 2005
    Location
    Spring, TX
    Age
    66
    Posts
    285

    Sunset Orange
    2002 TransAm

    I bought a BMR torque arm and relocation mount, put it on, took it for a drive. Did exactly the same as you said. Drove it less than ONE MILE, and took it off. It's only good for a trailered track car, You can't daily drive it.
    $625 was an expensive trial for a ONE mile trip.

  3. #3
    Wide Open and Sidways 00 Z28's Avatar
    Join Date
    Nov 2005
    Location
    Virginia
    Posts
    33
    2000 Camaro Z28

    Same Problem with the UMI tunnel mounted torque arm. It is a nice product, but it is a lot nicer sitting on my garage floor.

  4. #4
    First of all, check the trans mount. Chances are without the torque on the tailshaft its not broken, but checking it first goes without saying.

    Second, you may think you tightened all the fasteners and adjusters but I assure you that you have not. The adjusters and the rod end bolts must be torqued down to rediculous levels. Moreso than what Spohn recommends.

    I drive my TA everywhere with the chassis mount torque arm. I have not had any problems with it since I went over all the hardware and made sure they were tight. Zero noise.

  5. #5
    Member wesTXwitesnake05's Avatar
    Join Date
    Feb 2006
    Location
    Midland TX
    Posts
    249

    White with silver stripes
    2000 Trans Am WS6

    Quote Originally Posted by Marc 85Z28 View Post
    First of all, check the trans mount. Chances are without the torque on the tailshaft its not broken, but checking it first goes without saying.

    Second, you may think you tightened all the fasteners and adjusters but I assure you that you have not. The adjusters and the rod end bolts must be torqued down to rediculous levels. Moreso than what Spohn recommends.

    I drive my TA everywhere with the chassis mount torque arm. I have not had any problems with it since I went over all the hardware and made sure they were tight. Zero noise.

    how much of a rediculous level must they be torqued to? ft-lbs/in-lbs wise?

  6. #6
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,748

    Black
    383 Procharged & N20 Vert

    Quote Originally Posted by sunsetta View Post
    I bought a BMR torque arm and relocation mount, put it on, took it for a drive. Did exactly the same as you said. Drove it less than ONE MILE, and took it off. It's only good for a trailered track car, You can't daily drive it.
    $625 was an expensive trial for a ONE mile trip.
    I run the same one. Don't have any issues with it.



    Black 1999 Blown Convertible A4
    Forged 383, ATI D-1SC
    NX MAF Kit | 222/226 .585 115
    AS Stage II 6.0L FI Heads
    Moser 9" | 3.70 | Wavetrac | 35 Spline | Vigilante 3600
    548.0 RWHP - 563.8 RWTQ - 10# - D1

    666.0 RWHP - 734.2 RWTQ - 125 Shot - P1

    Black 2009 Escalade Hybrid 4WD
    Black 2008 GMC Yukon Hybrid 4WD (Totaled)

    Black 2013 Chevy Volt (Gone)

  7. #7
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    The Spohn torque arm will really stiffen the car up and you'll hear just about everything.....I have the same one and the same thing is happening.......

  8. #8
    Member wesTXwitesnake05's Avatar
    Join Date
    Feb 2006
    Location
    Midland TX
    Posts
    249

    White with silver stripes
    2000 Trans Am WS6

    Quote Originally Posted by cailey37 View Post
    The Spohn torque arm will really stiffen the car up and you'll hear just about everything.....I have the same one and the same thing is happening.......


    yeah it is noisy and rough as hell but it gave me alot more traction on the wholeshot! my car is an m6 and will catch up with my buddys a4 heads/cam car from a dead and i will actually pull half a length from a roll... so imo its worth it for racing but for normal driving its a bitch

  9. #9
    Quote Originally Posted by 00 Z28 View Post
    Same Problem with the UMI tunnel mounted torque arm. It is a nice product, but it is a lot nicer sitting on my garage floor.
    Are you getting noise with the arm or what? If you are having trouble with it please give us a call and I am sure we can help. We have installed many of these including the one I run on my daily driver with absolutely no road noise or issues. It might not be set up right, bolts not torqued correctly or pinion angle out of wack.

    If you need help just give us a call.

    Thank you

  10. #10
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    34
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    one, make sure the shackle bolts are nice and tight. one issue i know a lot of people run into is that the bracket that mounts to the the pumpkin will clearance itself over time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spohn torque arm problems. need advice
    By MIKEY'S 2002 TA in forum Suspension and Handling
    Replies: 5
    Last Post: 06-25-2009, 04:29 AM
  2. Spohn Torque Arm
    By topgun1851 in forum Suspension and Handling
    Replies: 3
    Last Post: 04-08-2007, 02:29 PM
  3. Spohn Torque Arm
    By topgun1851 in forum General Help
    Replies: 4
    Last Post: 01-18-2007, 08:32 AM
  4. Spohn torque arm
    By u69038 in forum Suspension and Handling
    Replies: 1
    Last Post: 01-12-2007, 04:02 PM
  5. Do SPOHN SFC's mix w/ Torque Arm?
    By ihatemustangs in forum Suspension and Handling
    Replies: 0
    Last Post: 06-25-2006, 02:09 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •