Results 1 to 6 of 6

clutch problem

This is a discussion on clutch problem within the Drivetrain forums, part of the LSx Technical Help Section category; guys,, today i got in my car and pushed in the clutch and the pedal stuck to the floor., after ...

  1. #1
    Junior Member silver35thss's Avatar
    Join Date
    Mar 2007
    Location
    auburn, al
    Posts
    78

    silver
    2002 ss camaro

    clutch problem

    guys,, today i got in my car and pushed in the clutch and the pedal stuck to the floor., after playing around with it a little bit it came loose and the car worked fine while running... After it got cold again the same thing happened! please tell me what is wrong? 2002 ss m6

  2. #2
    Jesus died to save you! Killer_bluebird's Avatar
    Join Date
    Aug 2005
    Location
    North Olmsted, OH
    Age
    43
    Posts
    508

    Navy Blue Metallic
    2000 Camaro Z28

    Try bleeding the clutch. How many miles on the clutch, master cylinder and slave? Any modifications to the car?

    Mine does it at high rpms due to the fact that the 50,000 LS6 clutch can't hold the power anymore. So a new clutch & slave are in my very near future.
    2000 NBM Camaro Z28
    Mods:
    SLP Lid & K&N, AHR Headers + 3" catted Y and Mangaflow, !EGR, !AIR, BMR CM STB, ST Front 35mm and Hellwig Adj. Rear 22mm Swaybar, Adj. Rod/Rod PHB, Koni SA's, Ground Control Springs & Adj. Ride height, and HPTuners.

  3. #3
    2000 Trans AM DW2000TA's Avatar
    Join Date
    Sep 2005
    Location
    Tallahassee, FL
    Age
    33
    Posts
    80

    Indigo Blue
    2000 Pontiac Trans AM WS6

    same here as killer blue bird said... mine wont hold at high RPM's either... sticks to the floor and i use my toe to pop it up... new clutch and slave anr def on order..

  4. #4
    Junior Member
    Join Date
    Mar 2006
    Location
    New Orleans, Louisiana
    Age
    48
    Posts
    6

    Black
    2001 Trans Am Ram Air

    I had a new clutch installed 3 weeks ago which worked great until now. The clutch is stiff which I like but it does not disengage quick enough causing me to ride the gears. Is there an adjustment?

  5. #5
    Junior Member silver35thss's Avatar
    Join Date
    Mar 2007
    Location
    auburn, al
    Posts
    78

    silver
    2002 ss camaro

    finally got the car done. i had a leak in my slave cylinder. my pilot bearing failed and my input shaft on the transmission was ground down. man that was a fun job,.. hope no one else rides there car as hard as i did for all that to happen..

  6. #6
    Jesus died to save you! Killer_bluebird's Avatar
    Join Date
    Aug 2005
    Location
    North Olmsted, OH
    Age
    43
    Posts
    508

    Navy Blue Metallic
    2000 Camaro Z28

    Quote Originally Posted by JoeDenny View Post
    I had a new clutch installed 3 weeks ago which worked great until now. The clutch is stiff which I like but it does not disengage quick enough causing me to ride the gears. Is there an adjustment?
    What Clutch are you using? McLeod has an adjustable master and Ram also has one that is less expensive than the McLeod. Either should allow you to adjust the pedal engagement point I believe. I have not had any experience with a either I'm sure a search on them will yield some info on the mater.

    Quote Originally Posted by silver35thss View Post
    finally got the car done. i had a leak in my slave cylinder. my pilot bearing failed and my input shaft on the transmission was ground down. man that was a fun job,.. hope no one else rides there car as hard as i did for all that to happen..
    Glad to hear the car is done. I'm still babying mine until I get the cash together.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. another clutch problem
    By ali pontiac in forum Manual Transmission
    Replies: 2
    Last Post: 09-29-2010, 03:43 AM
  2. LS7 clutch problem.....
    By nmssr08 in forum Manual Transmission
    Replies: 14
    Last Post: 12-16-2008, 05:57 AM
  3. Clutch Problem
    By Blackout01 in forum Manual Transmission
    Replies: 2
    Last Post: 08-07-2007, 03:48 PM
  4. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM
  5. Clutch problem..help please
    By Scorch in forum Manual Transmission
    Replies: 16
    Last Post: 03-02-2006, 10:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •