Results 1 to 7 of 7

clunk clunk clunk

This is a discussion on clunk clunk clunk within the Drivetrain forums, part of the LSx Technical Help Section category; long story short I tore my driveshaft out when I was at the track. The torque arm was damaged as ...

  1. #1
    Junior Member
    Join Date
    Nov 2011
    Location
    West Palm Beach, FL
    Posts
    1

    black
    1995 Camaro Z28

    clunk clunk clunk

    long story short I tore my driveshaft out when I was at the track. The torque arm was damaged as well. I replaced the driveshaft and torque arm with new ones but now when I drive the car I hear a clunk clunk clunk coming from under the car. It almost feels like it's coming from under my seat which would be where the transmission and driveshaft join. The noise gets faster when I accelerate but goes away when I mash on the clutch....any ideas?

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Internal transmission damage from the broken d/shaft, maybe?

  3. #3
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Check the tranny mount? Might also check the exhaust to see if it's not hitting.

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    May want to check the transmission mount as well. Let us know what you find.

  5. #5
    Old Member, New Username BrownsMillsAntz's Avatar
    Join Date
    Aug 2011
    Location
    Browns Mills NJ
    Posts
    190

    Green
    1995 Z28 w/ LS1 Swap

    I had something similiar and it was the tranny mount...

    Heads/Cam/Intake/Stall.
    404 Rwhp uncorrected @ 6400

  6. #6
    Junior Member EREBUS-SS's Avatar
    Join Date
    Dec 2010
    Location
    San Ramon, CA
    Posts
    12

    Red
    1998 Camaro SS

    Zmandan - I'm having something similiar happening to me as well.. did you ever find out what happened? Or what fixed it?

    Thanks man.

  7. #7
    Junior Member EREBUS-SS's Avatar
    Join Date
    Dec 2010
    Location
    San Ramon, CA
    Posts
    12

    Red
    1998 Camaro SS

    Just wanted to circle back and let those interested know what happened... rear end broke 3 teeth off the ring gear.

    This 'clunk' was the pinion missing those teeth and engaging the others... and I ended up having a scarred left axle, which was a loud 'humming' noise as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clunk in reverse
    By c5z28 in forum General Help
    Replies: 21
    Last Post: 07-19-2010, 12:31 PM
  2. This clunk is making my brain clunk....
    By silversho89 in forum Drivetrain
    Replies: 5
    Last Post: 04-22-2009, 04:51 AM
  3. Rear End Clunk
    By One_Bad_TA in forum Drivetrain
    Replies: 51
    Last Post: 10-23-2008, 10:35 AM
  4. The clunk, that I have feared.
    By JoshieDoom in forum Drivetrain
    Replies: 18
    Last Post: 06-19-2008, 10:15 PM
  5. Help: Clunk in the rear end?
    By GOR1LA in forum Suspension and Handling
    Replies: 1
    Last Post: 05-09-2008, 08:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •