Results 1 to 3 of 3

Broke the spec staage 3...

This is a discussion on Broke the spec staage 3... within the Drivetrain forums, part of the LSx Technical Help Section category; kinda disappointed in it...worked great for about 6k miles...ran it about 3 times at the track and never a problem ...

  1. #1
    Internet Tough Guy Fury_786's Avatar
    Join Date
    Nov 2007
    Location
    Oregon
    Age
    31
    Posts
    698

    Sinister, SixGun
    2001 SS, 2002 L36 M5

    Broke the spec staage 3...

    kinda disappointed in it...worked great for about 6k miles...ran it about 3 times at the track and never a problem

    took it to the track on saturday and its done for...slips all the time now.

    broke it in right and all that jazz.

    all saturdays runs were on motor...just a bolt on SS =[

    so can i get away with a flywheel and a clutch disk? or do i have to spend another million dollars on a whole kit?

  2. #2
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Shoulda done your homework. I've been saying they're junk on here for years.

  3. #3
    Military Muscle :usa: MYSCZ06's Avatar
    Join Date
    Aug 2005
    Location
    Columbia,SC
    Age
    44
    Posts
    511

    Millienum Yellow
    2003 Corvette Z06

    check out Monster Clutches been hearing grreat things about them and they have 6 different stages..Im getting a STG 3 for my Vette going in now!
    Shawn
    Daily: 2003 MY Z06 D1SC | Toy: 2006 Hayabusa Garrett T-3 | Hauler: 2007 Nissan Titan LE CC
    I like being Blown!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: I broke something
    By claytonr in forum External Engine
    Replies: 7
    Last Post: 02-01-2011, 09:20 PM
  2. You broke my d!ck
    By pecha in forum Almost Anything Goes
    Replies: 15
    Last Post: 11-18-2009, 05:45 PM
  3. Broke the GTO........
    By Stone in forum Almost Anything Goes
    Replies: 88
    Last Post: 06-16-2008, 07:46 PM
  4. I think my tcs broke something..
    By pocheasy in forum Suspension and Handling
    Replies: 3
    Last Post: 02-08-2007, 09:32 AM
  5. Please try and tell me what I broke
    By RideZX-6R in forum Manual Transmission
    Replies: 3
    Last Post: 02-01-2006, 11:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •