Results 1 to 4 of 4

Anyone Please Help

This is a discussion on Anyone Please Help within the Drivetrain forums, part of the LSx Technical Help Section category; I put a centerforce clutch, lightweight flywheel, and the pro 5.0 in about 1500 miles ago. And the past few ...

  1. #1
    Junior Member
    Join Date
    Mar 2006
    Location
    ohio
    Age
    34
    Posts
    2

    black
    99 ta

    Anyone Please Help

    I put a centerforce clutch, lightweight flywheel, and the pro 5.0 in about 1500 miles ago. And the past few days ive had to push my clutch pedal down further and further. now i have to push it untill it hits my floorboard and then stand on it and it still has trouble going in gears. Any ideas?

  2. #2
    Junior Member
    Join Date
    Mar 2006
    Location
    ohio
    Age
    34
    Posts
    2

    black
    99 ta

    I dont know if i should try to bleed my clutch or what

  3. #3
    TJEA Retirement Home Dr.Crash's Avatar
    Join Date
    Feb 2006
    Location
    U. S And A Greatest country in all of world
    Posts
    3,383

    Stock
    2002 Camaro

    did you get a new clucth slave cylinder? that could be your problem.

  4. #4
    Corvette Moderator BlownC5's Avatar
    Join Date
    Sep 2005
    Location
    Essexville
    Posts
    464

    Velocity Yellow
    2006 E-Force blown Z06

    did you bleed your master?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •