Results 1 to 10 of 10

4.10's installed...Park Brake?

This is a discussion on 4.10's installed...Park Brake? within the Drivetrain forums, part of the LSx Technical Help Section category; I just got my new rear put in with 4.10's. Took me a little time, but got her done. When ...

  1. #1
    Member Speed_kills_WS6's Avatar
    Join Date
    Feb 2008
    Location
    Anderson, SC
    Age
    37
    Posts
    403

    Black
    2002 TA WS6 M6

    4.10's installed...Park Brake?

    I just got my new rear put in with 4.10's. Took me a little time, but got her done. When I get in to take a spin for the first time, the damn park brake light won't go off. What's the deal? Haven't got to really feel the gears yet, its raining out and my car just spun thru the first three gears, lol.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    The switch for the parking brake is in the console below the actual parking brake handle.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    The switch is at the base of your handle. Its a very simple, grounded switch. Its probably just unpluged and grounding against something.

    If you were to unplug that switch's wire ( blue in color IIRC ) and grounded it, it would pop the brake light on the dash. Pull that center console.
    370 CI - Twin 6766 Turbo - Jakes stage 5 4L80E - MWC 9" - Holley Dominator

    Build in progress...

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Do you have traction control?

  5. #5
    Member Speed_kills_WS6's Avatar
    Join Date
    Feb 2008
    Location
    Anderson, SC
    Age
    37
    Posts
    403

    Black
    2002 TA WS6 M6

    Yes, I do have traction control. I'll check the switch out.

  6. #6
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Check that you didn't smack up a sensor when you removed the axles.

  7. #7
    Member Speed_kills_WS6's Avatar
    Join Date
    Feb 2008
    Location
    Anderson, SC
    Age
    37
    Posts
    403

    Black
    2002 TA WS6 M6

    didnt remove the axles, put a complete different rear in the car. switch turns out ok.

  8. #8
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Two things I can think of. If you put a 3 channel rear in it will usually trip the abs light. Other one is there should be a pressure switch somewhere near the master. If there is low brake pressure, say when a line goes or there is little fluid in, it will illuminate the brake light.

  9. #9
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    the red brake warning light can come on for 2 reasons. The parking brake is on or
    there is low brake fluid level in the master cylinder

  10. #10
    Member Speed_kills_WS6's Avatar
    Join Date
    Feb 2008
    Location
    Anderson, SC
    Age
    37
    Posts
    403

    Black
    2002 TA WS6 M6

    You know what? I bled the rear brakes after switching my calipers over to the new rear. I was rushed and never put any fluid back in the reservoir. Checking that now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Park Brake Cable Dust Boot Sets!
    By sjgreen6 in forum Parts For Sale / Trade
    Replies: 8
    Last Post: 10-12-2014, 04:50 PM
  2. Corvette Brake Rotors - Give Me A Brake
    By Ed Blown Vert in forum Corvette
    Replies: 1
    Last Post: 09-17-2010, 04:39 PM
  3. Camaro Ebay LED 3rd Brake Light Installed
    By The Guz in forum Appearance Section
    Replies: 12
    Last Post: 08-05-2010, 07:04 PM
  4. installed new weiend intake. brake boost
    By apeshitls1 in forum General Help
    Replies: 3
    Last Post: 06-07-2010, 08:08 AM
  5. Replies: 0
    Last Post: 11-30-2007, 07:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •