Results 1 to 4 of 4

starting issue...

This is a discussion on starting issue... within the GM Trucks forums, part of the Vehicle Specific category; I drive an 03 GMC Sierra 1500 with the 4.8liter and automatic tranny. My problem is when I drive it ...

  1. #1
    Junior Member
    Join Date
    Feb 2008
    Location
    Florida
    Posts
    4

    Black
    03 GMC Sierra SLE

    starting issue...

    I drive an 03 GMC Sierra 1500 with the 4.8liter and automatic tranny. My problem is when I drive it for say 20-30 minutes straight(generally when I drive from my town to another town) and then let it sit for a couple hours, when I go to start it it will stall out and the starter kicks over real fast. When I try and start it the second time, 50% of the time it will stall out again. The other 50% of the time it will start, bog/stumble/sputter, and then it will be fine. If it doesn't start the second time it always starts the 3rd time and I won't have another problem with it. I have been told it is either the fuel pressure regulator or the fuel pump. I replaced the fuel pressure regulator and a week later it was having the same issue. I did seem to gain some throttle response after swapping fuel pressure regulators but that was all I noticed. I changed it with a Borg Warner regulator from O'reilly Auto Parts. As far as the fuel pump being the culprit, it doesn't make the notorious whine that these pumps tend to make when they are going out and I have been experiencing this problem for several months now so I think if the pump was on its last leg it would have kicked the bucket by now.

    The truck doesn't have any other problems besides this one and I usually don't experience this problem unless I've specifically driven it for about 20-30 minutes and then parked it for an hour or 2. Even more peculiar is when I drive it back from out of town which is a 30 minute drive, and park it over night, it fires right up in the morning without a problem. Any guidance would truely be appreciated.

  2. #2
    Junior Member
    Join Date
    Feb 2008
    Location
    Florida
    Posts
    4

    Black
    03 GMC Sierra SLE

    I guess no one has run into this problem before then.

  3. #3
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    sounds like a heat realted issue, something is getting confused or not working properly after getting heat soaked then partly cooled. What though I wouldn't know. Suggestion would be a fuel pressure leak down test and seeing what its doing.

  4. #4
    Member
    Join Date
    Dec 2006
    Location
    kansas
    Posts
    107
    +1 on above post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starting Issue
    By DaEvil in forum General Help
    Replies: 15
    Last Post: 03-01-2013, 03:53 PM
  2. Help: Starting Issue
    By TA814 in forum General Help
    Replies: 8
    Last Post: 04-21-2009, 04:19 PM
  3. Question: Starting Issue
    By Wesman in forum GM Trucks
    Replies: 2
    Last Post: 06-12-2008, 09:10 PM
  4. starting issue....
    By KongGMC in forum GM Trucks
    Replies: 0
    Last Post: 02-24-2008, 06:41 AM
  5. 94 Z starting issue
    By 1st TA in forum LT1
    Replies: 8
    Last Post: 03-04-2007, 08:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •