Results 1 to 4 of 4

High Idle P0507

This is a discussion on High Idle P0507 within the GM Trucks forums, part of the Vehicle Specific category; ...

  1. #1
    Junior Member
    Join Date
    Sep 2005
    Location
    Northern California
    Posts
    42

    Arctic White
    98 Z-28

    High Idle P0507

    I recently got my intake manifold gasket replaced...about a month ago. The truck runs well but ever since I got it back from the shop, it has a high idle. It will idle at about 25 mph. It does not do this when the motor is cool, but when it gets to normal operating temperature. I talked to my mechanic and he says its probably something with the IAC since he had the throttle body off and cleaned it. He said he would fix it...no charge but he is about 80 miles away from where I live. Anybody have any ideas before I drive it up there?

    The truck is a 98 K1500 with the 5.7 L31 motor. I have a basic scanner and this is what the freeze frame said:

    DTC for which Freeze Frame was Stored P0507
    Fuel System 1 Status Closed Loop
    Fuel System 2 Status Closed Loop
    Calculated LOAD Value 17.65 %
    Engine Coolant Temp 192.20 F
    Short Term Fuel Trim - Bank 1 -2.34 %
    Long Term Fuel Trim - Bank 1 -3.91 %
    Short Term Fuel Trim - Bank 2 -0.78 %
    Long Term Fuel Trim - Bank 2 -4.69 %
    Intake Manifold Absolute Pressure 19.25 inHg
    Engine RPM 1,575.75 rpm
    Vehicle Speed Sensor 59.03 mph
    Air Flow Rate Mass Air Flow Sensor 5.33 lb/min
    Absolute Throttle Position 17.65 %

    Do any of these categories look out of whack?

  2. #2
    Senior Member JaycenK's Avatar
    Join Date
    Nov 2008
    Location
    Holiday,FL
    Age
    40
    Posts
    1,378

    Green
    1997 Camaro Z-28

    You did this at speed?

  3. #3
    Junior Member
    Join Date
    Sep 2005
    Location
    Northern California
    Posts
    42

    Arctic White
    98 Z-28

    Quote Originally Posted by JaycenK View Post
    You did this at speed?
    This was where the computer freeze framed it.

  4. #4
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    what ever happned with this? did you figure out why P0507 came up?


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issues... idle high. unplugged tps runs good?
    By okiels1 in forum Firebird / WS6
    Replies: 2
    Last Post: 12-31-2016, 04:36 AM
  2. high shift points & high idle
    By Red 99 T/A in forum General Help
    Replies: 5
    Last Post: 07-26-2010, 09:04 PM
  3. high idle
    By egod in forum General Help
    Replies: 15
    Last Post: 06-16-2010, 03:34 PM
  4. Question: high idle
    By mark21742 in forum Computer & Tuning
    Replies: 2
    Last Post: 08-27-2009, 10:13 PM
  5. High idle
    By kev70ss in forum External Engine
    Replies: 3
    Last Post: 01-27-2008, 02:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •