Results 1 to 5 of 5

Help

This is a discussion on Help within the GM Trucks forums, part of the Vehicle Specific category; Hey guys my hubby and I just picked up a 97 Yukon Gt, unfortunately we were tricked and someone unplugged ...

  1. #1
    Steph my1stss's Avatar
    Join Date
    May 2010
    Location
    NJ
    Age
    37
    Posts
    77

    Black
    2001 camaro ss #4168

    Help

    Hey guys my hubby and I just picked up a 97 Yukon Gt, unfortunately we were tricked and someone unplugged the engine light when we baught it. Anyway at idle the truck is really crappy and barely runs, the codes that came up on scaneer are P0300, P0441, P0131, and there is one more i cant recall right now. I looked them all up and they all seem to be related but before we get nickled and dimed to death i thought maybe a few of you guys might have some ideas for us to try right off the bat, any help would be greatly appreciated!

  2. #2
    Senior Member REVNORR82's Avatar
    Join Date
    Aug 2010
    Location
    NEW ALBANY
    Posts
    1,462

    silver
    2002 ws6 ta convertible

    What were the codes for

  3. #3
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    97 Yukon, I'm assuming it's a Vortec 5.7...

    p0300 is an engine miss.
    p0131 is an o2 sensor
    and p0441 is an EVAP code.

    An engine miss would be pretty obvious, and you would have noticed on a test drive. You'll have a lot of work ahead of you without diag equipment. Go through your ignition system, check all your plugs/wires/cap/rotor... etc. Engine misses are usually electrical as opposed to a fuel issue.

    Good luck!

    2008 Z06 - Velocity Yellow - OEM

    2017 Silverado Z71 5.3 - OEM

    2002 Z06 - Electron Blue Metallic - D1 - E85 - 701 rwhp 687 rwtq **sold**

    2002 Z28: M6 NBM - cam and boltons - 396rwhp 357 rwtq **sold**

  4. #4
    Member FMBL's Avatar
    Join Date
    Mar 2010
    Location
    NRH, TX
    Posts
    161

    White
    1998 Z28

    I have a 99 Vortec 5.7 had to replace the engine when I bought it. All of the ignition system was new and I still had the same problem. Mine ended up being the old poppet style fuel injectors. Another forum for your truck that you might want to check out is the one below. It started out as 67-72 but it is now 1947 - Current.

    http://67-72chevytrucks.com/vboard/f...splay.php?f=12

  5. #5
    Steph my1stss's Avatar
    Join Date
    May 2010
    Location
    NJ
    Age
    37
    Posts
    77

    Black
    2001 camaro ss #4168

    It ended up being the spider injection , got one outta the junk yard and swapped it out and runs like a charm.
    Mama Steph

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •