Results 1 to 5 of 5

GM Trans Slipping

This is a discussion on GM Trans Slipping within the GM Trucks forums, part of the Vehicle Specific category; My 2003 truck is on its 3rd trans rebuild seems to allways fail aound the first of January when cold. ...

  1. #1
    Junior Member
    Join Date
    Dec 2007
    Location
    Illinois
    Posts
    1

    maroon
    2002

    GM Trans Slipping

    My 2003 truck is on its 3rd trans rebuild seems to allways fail aound the first of January when cold. It has now started slipping again 21000 miles into rebuild. All fluids are up to spec. Trans shop beefed the trany up durring the last rebuild (8 Clutches ?) Is there any Inherint problems that could cause this?

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    yep, not letting get any heat in it before jamming on it, i have found that with GM trannies in the trucks you have to be gentle with em when it cold till the parts warm up, spun a bearing in my dads 92 suburban one sub zero day.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    usa
    Posts
    58

    Lt. pewter
    02 suburban

    Ya I Have An 02 Suburban And The First Trans Went Out @ 75,000 Miles And Gm Replace It And It Start Slipping @ 90,000 Miles... So I Added The Some Superior Servos And A Power Valve And The Truck Has 110,000 Miles And Not Slipping No More... I Shifts Quicker And Harder But That Is Better Than Dealing With Have To Replace The Trans. At That Time... I Like The Servos In My Truck... I Do Not Know If They Would Help You In The Cold Weather But They Work In The Hot Texas Summers....

  4. #4
    Ricekiller z28punk's Avatar
    Join Date
    Nov 2006
    Location
    Maple Grove, MN
    Age
    29
    Posts
    509

    Pewter
    2002 Camaro Z28

    if the slipping is all the time then thats kinda weird. thats not real common. if its only in 2nd then its the 2/4 band. gm makes good trannies, but there are a few common parts that fail if the tranny has a problem. ****cough (Forward sprag) cough****

  5. #5
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Another place you could try for answers is...

    http://www.gm-trucks.com/forums/



    BTW: Welcome!
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 4L60E trans slipping? going bad
    By FMR_TransAm in forum General Help
    Replies: 11
    Last Post: 03-07-2012, 03:39 PM
  2. OD Slipping
    By excrider121 in forum Automatic Transmission
    Replies: 6
    Last Post: 03-28-2011, 11:40 AM
  3. Slipping Trans
    By j nix in forum Automatic Transmission
    Replies: 16
    Last Post: 10-04-2010, 07:59 PM
  4. slipping while in OD
    By Z28boy2000 in forum Automatic Transmission
    Replies: 6
    Last Post: 11-07-2009, 08:59 PM
  5. Help: slipping for 1-2?
    By mr_r0bert0 in forum Automatic Transmission
    Replies: 2
    Last Post: 01-02-2009, 09:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •