Results 1 to 2 of 2

2001 8.1l po343 code

This is a discussion on 2001 8.1l po343 code within the GM Trucks forums, part of the Vehicle Specific category; I just replaced the camshaft position sensor and fuel filter on my 2001 chevy 2500hd with the 8.1L because I ...

  1. #1
    Junior Member
    Join Date
    Oct 2005

    2001 8.1l po343 code

    I just replaced the camshaft position sensor and fuel filter on my 2001 chevy 2500hd with the 8.1L because I got the code po343. After replacement code is still there. Truck will not go over 3000rpm in park, when driving in drive it runs smooth but has no power when you get close to 3000 rpm. If you let it sit and cool off it will start right away but when it is a warm it cranks a few seconds and then will start with the gas pedal to the floor. You can manually shift gears and get rpm to 5500 but not in drive. No black smoke and truck does not die or run rough like a crankshaft position sensor problem. Any advice would be appreciated. thks

  2. #2
    Member NaviDyn's Avatar
    Join Date
    Dec 2008
    St Louis

    2002 GMC Yukon

    Do you have access to DSO, like a Fluke 93? That code means the PCM did not have the expected amplitude of the signal, and sees higher than expected voltage. It doesn't necessarily mean the sensor is bad. If you can check at the sensor itself, then at the PCM, you will know where the problem is.

    It isn't really possible to generate more than the little magnet can make. That leaves a short to power reaching the PCM. But do the tests with the meter to be sure.

    edit: I just saw how old it was.
    Last edited by NaviDyn; 05-31-2009 at 05:06 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how do i get that monsoon system to unlock itself
    By purplebat66 in forum Stereo and Electronics
    Replies: 5
    Last Post: 12-10-2008, 08:33 AM
  2. 1972 Pontiac GTO - A Round-Port In The Storm
    By Ed Blown Vert in forum GTO
    Replies: 0
    Last Post: 10-04-2007, 07:40 PM
  3. Code 2 Sensor Heater Malfunction
    By matthewaqui in forum General Help
    Replies: 9
    Last Post: 09-28-2007, 08:35 AM
  4. Difference in SS/Z28?
    By SteelmanLS1 in forum Camaro / SS
    Replies: 114
    Last Post: 06-19-2007, 04:48 AM
  5. P1415 SES code HELP!
    By y2kformula in forum Computer & Tuning
    Replies: 15
    Last Post: 02-17-2006, 05:24 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts