Results 1 to 8 of 8

Need help with my Explorer XLT '00 battery or alternator?

This is a discussion on Need help with my Explorer XLT '00 battery or alternator? within the Domestics and Foreigns forums, part of the Vehicle Specific category; Driving home in sub freezing temps, the rear wiper stopped working, and the interior lights went dim at the same ...

  1. #1
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    Need help with my Explorer XLT '00 battery or alternator?

    Driving home in sub freezing temps, the rear wiper stopped working, and the interior lights went dim at the same time. TYhen the front wipers started working slower than usual. Got her all the way home block from the house the battery light started to flicker, and teh dash lights went out. Parked it, turned it off when I tried to turn back on all I get is clicking sound from the engine. Click click click click won't turn over. Sound like the alternator or battery or both??? 2000 Explorer XLT, original battery.

  2. #2
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    sounds like the alternator, if i was you i would replace the battery anyways if its 4 years or older. especially from the cold weather

  3. #3
    Member matthewaqui's Avatar
    Join Date
    Jul 2007
    Location
    Lakewood, California
    Posts
    779

    Red/Silver/Black/Red
    TA-G8-Expe-L200-Camaro

    Wink Alternator

    Seems like the Alternator is out and couldn't power the vehicle....... You could have been running off of the Battery that entire time. Don't know where you live, but the battery could have gone bad as well from the freeze.....

    I would replace the Alternator first...... vehicle would still function properly due to a bad battery. I experienced the same thing this year practically and never assumed it was the battery.

    Bad crank is battery, but if battery was not able to recharge and vehicle operation failure while driving is alternator.

    There is also a voltage regulator I believe. You may want to check that. Hope I've help in your dillema.

    Matthew
    Last edited by matthewaqui; 02-12-2008 at 07:15 PM.

  4. #4
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    thanks guys!

  5. #5
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    no prob, and you can go to any auto parts store and have your system tested, i forgot to tell ya about that

  6. #6
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    Quote Originally Posted by camarojunky74 View Post
    no prob, and you can go to any auto parts store and have your system tested, i forgot to tell ya about that
    I would, but it wont start!

  7. #7
    Senior Member camarojunky74's Avatar
    Join Date
    Jun 2007
    Location
    corona ca
    Age
    31
    Posts
    2,258

    white, white and pewter
    Rip99SSA4,74Z28M4,02SSM6

    Quote Originally Posted by Hurley711 View Post
    I would, but it wont start!
    lol, charge the battery replace the alternator and go get the battery tested

  8. #8
    Senior Member Hurley711's Avatar
    Join Date
    Jul 2005
    Location
    Earth
    Age
    41
    Posts
    3,362

    414 RWHP 395 RWTQ
    00 Black Ram Air Trans Am

    Just for closure to this thread it was the alternator

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Battery / Alternator Problem
    By cpw006 in forum General Help
    Replies: 9
    Last Post: 04-05-2010, 10:23 PM
  2. Alternator bad? or battery? or ground?
    By 96z28 in forum General Help
    Replies: 11
    Last Post: 08-21-2008, 03:01 AM
  3. alternator..now battery?
    By blackhawk01 in forum External Engine
    Replies: 7
    Last Post: 10-23-2007, 07:06 PM
  4. battery/alternator gauge...
    By bolden3 in forum General Help
    Replies: 12
    Last Post: 08-31-2007, 09:21 PM
  5. alternator vs. battery charger
    By ss~zoso~ss in forum General Help
    Replies: 9
    Last Post: 03-08-2006, 06:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •