Page 7 of 8 FirstFirst ... 345678 LastLast
Results 121 to 140 of 144
Like Tree13Likes

1987 Buick Regal Turbo

This is a discussion on 1987 Buick Regal Turbo within the Classic Muscle forums, part of the Vehicle Specific category; As always good work Jeff! I love the way it has the boost gauge set up....

  1. #121
    Yeah baby! Yeah! silverWS6's Avatar
    Join Date
    May 2009
    Location
    okc
    Posts
    2,571

    Silver 2002 WS.6
    Red 1989 Formula

    As always good work Jeff! I love the way it has the boost gauge set up.

  2. #122
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Thanks! Unfortunately, the rpm and boost gauges in the dash are all but useless. They are both digital bar graphs and not at all accurate. The boost gauge may be close, but the tach is way off the mark.

  3. #123
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,512

    Navy Blue Metallic
    98 T/A w/a little mods...

    so new gauges in the future?

  4. #124
    Senior Member cpop98ws6's Avatar
    Join Date
    May 2010
    Location
    Wilkes-Barre, PA
    Posts
    1,545

    Black/Black
    98 WS6/04 Sierra Dmax

    I think he already did gauges a few months ago.

  5. #125
    Senior Member cpop98ws6's Avatar
    Join Date
    May 2010
    Location
    Wilkes-Barre, PA
    Posts
    1,545

    Black/Black
    98 WS6/04 Sierra Dmax

    Had to look back, he did water temp and oil press. already. For some reason I was thinking there was a boost gauge in there.

  6. #126
    Member initechpeter's Avatar
    Join Date
    Apr 2012
    Location
    Iowa
    Posts
    207

    2002 Trans Am WS6 - Red
    2013 Chevy Traverse LTZ

    Nice work. I would be tempted to roll back the milage.

  7. #127
    Giant Dicks Car Club Zapper2003's Avatar
    Join Date
    Nov 2006
    Location
    Millerton, PA
    Posts
    5,145

    2005 Ram
    1978 Firebird

    He may be a lawyer but he's not that crooked!

  8. #128
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    It would be easy to do, but the proof is in the pics - same mileage is shown at the start and end of the project. I need to tear into the driver door next and free up the lock mechanism a bit.

    Chris - car came with an aftermarket boost gauge on the A-pillar.

  9. #129
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ordered up some more stuff for the Buick yesterday. I am going to update the chip with one from Turbo Tweak. Checking into things, the Kenne Bell chip that the car currently has is dated to say the least. Also going to install a Scanmaster 2.1 to keep an eye on things. It'll make up for the fact that I do not own a scan tool for OBDI - just the one I borrowed from a friend to check the IAC and such. The Scanmaster will dislay all of the following and is a simple 3 wire hookup:

    O2 - Oxygen sensor millivolts
    KR - Knock Retard
    AF - MAF Airflow in grams/sec
    LV8 - Load Value
    BAT - Voltage to the ECM
    INT - Integrator
    BLM - Block Learn Multiplier
    MPH - Miles Per Hour
    CLT - Coolant Temp
    ATS - Air Intake Temp
    RPM - Current Engine RPM
    TPS - Throttle Position in volts
    IAC - Idle Air Control motor commanded position
    CC - Oxygen Sensor Cross Counts
    MAL - Malfunction Codes

  10. #130
    Member robs98mysticZ's Avatar
    Join Date
    Mar 2011
    Location
    Waynesboro, Pa
    Posts
    256

    Mystic Teal Metallic:320c
    1998 Camaro Z/28

    What are good sites for these cars aftermarket motor goodies
    98 Z/28 Ttop M6 320C SLP lid--PMT LCA/PRB--UMI SFCs--LTs/ORY--SkipShiftElim--Pro5.0w/UMIshortstick--4.10s--D/Sfrontrotors--Whistler--BilletGrille--SSspoiler

  11. #131
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Kirban Performance and Highway Stars are two good ones.

  12. #132
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,466

    Red
    02 35th LE Camaro SS

    If you think this car looks impressive over the internet, try seeing it in person...and then driving it

  13. #133
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Thanks Jon. Dawn and I both really enjoy this car. Going to take care of some cosmetic stuff on her over the winter hopefully.

  14. #134
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Finally had a chance to work on the Regal over the holiday. Pulled the driver door panel and a little WD-40 was all it took to get the key lock working right. Things were a bit stiff, so I always unlocked the car on the passenger side. Found a build sheet for the door in damn near pristine condition - neat to find stuff like that. I elected to keep the ScanMaster mounted to the underside of the I/P surround with velcro. I had to remove the original strip I put on last year and cleaned the vinyl with some alcohol for better adhesion before slapping on a new strip. There is just no good place for it as the gauges occupy the space beneath the radio and HVAC panel. I then shampooed the carpet and floor mats before putting her up in the air to check the brakes and such. Inspection is up at the end of May so she'll be taking a trip this week to the local Ford garage where a friend works for a new sticker. We did drive it to a local cruise in last week where it received some attention.

  15. #135
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Replaced the alternator this afternoon. The original sounded like it had a dry bearing on cold startup. I debated rebuilding the original, but with so many projects on tap it was easier to just buy one. I checked out the new one to make sure all the mounting holes and such were correct and then installed it. After everything was bolted back in place, I relieved the tensioner and slipped the belt back in place only to find that it was slack. Turns out the pulley on the new alternator is around 2" in diameter and the stock pulley is almost 2-1/2". Rather than go argue with the parts store, I simply swapped pulleys and finished the installation.

  16. #136
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I fired up the Regal this afternoon and the alternator did nothing. Went for a test ride, and it still wasn't charging. Checked the factory manual and found that in addition to the main output wire, standard Regals have a two-wire connection and turbo Regals have a one-wire connection. Looked on-line and found two different part numbers, but no exlpanation as to the difference. Decided I had the wrong alternator, so went and ordered the other part number. On the ride back from the parts store... it started charging. Not a clue. I am going to run it tomorrow to see what it does.

    In other news, I finally came up with a mounting solution for the OBDI interface:











  17. #137
    Member RONS98TA's Avatar
    Join Date
    Jan 2009
    Location
    MARYLAND
    Age
    44
    Posts
    803

    BLACK
    1998 PONTIAC TA

    The last time you drove your car, the alt was working fine...correct? Then on your drive back home it started working again? It kinda sounds to me like you have a bad connection somewhere. Maybe in the wire harness that plugs into the alt? Or maybe just a bad gauge? Im sure you have already checked all of these things, because i have read plenty of your threads and i know you have an expansive amount of knowledge, but even the best sometimes forget the simplest fixes. Def not trying to insult you, just trying to help. Good luck man.

  18. #138
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Only reason I changed out the alternator was that the bearing had a dry sound on cold startup. The car always charged fine and as we do drive it I didn't want to end up stranded if it decided to suddenly give out. It ended up being the wrong alternator from the parts store. Non-turbo cars have a two wire connection to the internal regulator and turbo cars have a one wire setup. Swapped it out for the correct style alternator and all is well.

  19. #139
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I have had the Regal out since Wednesday and have been thoroughly enjoying it. This afternoon, we took a ride in it up to Watkins Glen and had dinner at Seneca Harbor right on the lake. The car ran great up and back and drew a few looks along the way. Good times.

  20. #140
    Member DarrenWS6's Avatar
    Join Date
    May 2015
    Location
    Blossburg, PA
    Age
    28
    Posts
    414

    Silver Metallic
    2000 Trans Am WS6

    I checked out the first few pages and learned a little more about the Regal. After seeing it in person and seeing these before shots of the engine bay, you put some good time into cleaning it up properly! Very nice.
    2000 Trans Am WS.6 M6

    SLP lid & bellow w/ K&N, GMMG catback w/ Corsa Clones, UMI SFC, UMI Adj. Panhard, UMI Adj. TQ arm w/ relocation kit, Eibach prokit, Bilstein HDs, Nitto NT555s, skip shift elim, whiteface overlays, 20% tint, matte black decal/overlays

Page 7 of 8 FirstFirst ... 345678 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1987 Turbo Regal
    By Redegal in forum Vehicles For Sale / Trade
    Replies: 23
    Last Post: 03-11-2010, 09:34 PM
  2. 1998 Buick Regal GS Turbo
    By casper the ghost in forum Vehicles For Sale / Trade
    Replies: 8
    Last Post: 03-03-2009, 04:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •