Page 1 of 2 12 LastLast
Results 1 to 20 of 35

Wires and plugs?

This is a discussion on Wires and plugs? within the Internal Engine forums, part of the LSx Technical Help Section category; I have a 2001 Camaro SS with 74,000 miles on it, its idling really rough at times really after its ...

  1. #1
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    Exclamation Wires and plugs?

    I have a 2001 Camaro SS with 74,000 miles on it, its idling really rough at times really after its been running for at least 10 min? The RMP's all the sudden drop under 500 and the engine shakes and acts like it wants to die?.. I'm thinking plugs and wires?? could it be other things? Thanks

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Start by cleaning the MAF and see if that solves the problem. CRC makes a MAF cleaner that you can pick up at just about any auto parts store. Next thing to look at is the hose on your PCV system to see if it is cracked and causing a vacuum leak.

  3. #3
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    Yeah thats what i thought but I just put an SLP MAf and a stainless steele lid and I still have this problem.. I have no cats or mufflers with headers also..

  4. #4
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Did you have the MAF calibrated in your computer? When ever you swap MAFs you need to get a tune so it doesn't make the engine run too lean. go ahead and grab a set of Autolite 103s and a set of wires for it to be sure

  5. #5
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    What you describe doesn't sound like a symptom of plugs and wires. Sounds like a sensor issue to me.

    No codes I'm assuming??

    Best bet would be to find someone with an OBDII diagnostic program (preferrably HP Tuners, if not Autotap or the like) and see what you can find out by recording data while the problem is happening.

    Plugs and wires won't hurt either, if they are original change them as well. I'd reccommend AC Delco or Granatelli wires and AC Delco or NGK Iridium spark plugs.

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    There is an Idle Air Control valve on the side of the throttle body -- if that gets gummed up you can experience idle issues as well. Any chance you have an air leak between the MAF and the throttle body that would allow unmetered air into the engine? May want to check your clamps as well.

  7. #7
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by Nathan01ss View Post
    Yeah thats what i thought but I just put an SLP MAf and a stainless steele lid and I still have this problem.. I have no cats or mufflers with headers also..
    Ding.

    What MAF is it? Aftermarket?

    What have you done about the O2's with the addition of the Longtubes? Extensions, home-grown splicing?

    Edit: Would be helpful if you could get it hooked up to HPTuners or a good scanner that can monitor the IAC ( Idle Air Control ) counts. Scanner available?

  8. #8
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    I have an SLP MAF, It gets really bad when I slow down and turn into a parking spot?? I got Taylor 10.5mm thunderbolt wires coming in mail.. what spark plugs should I roll with? I was thinking E3 or NGK TR6xi?

  9. #9
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    Also I don't have a tuner? I bought the car with it chiped, hearders, tuned, striaght pipes.. So by putting the SLP MAF I need to get a tuner to retune it?

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Nathan01ss View Post
    I have an SLP MAF, It gets really bad when I slow down and turn into a parking spot?? I got Taylor 10.5mm thunderbolt wires coming in mail.. what spark plugs should I roll with? I was thinking E3 or NGK TR6xi?

    E3's are crap -- go with NGK TR55 spark plugs gapped at .054".

  11. #11
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    Ok... but arent the TR6xi alittle better?

  12. #12
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    51
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    Take the maf off and put the stocker back on! then reset the computer and drive a while so it adjusts back to the stock maf.

  13. #13
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Nathan01ss View Post
    Ok... but arent the TR6xi alittle better?

    Not familiar with that plug -- is it platinum?

  14. #14
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    The website saids they work best with lightly or heavy modify engines.. Also I'm going to go ahead and get o2 sensors..

  15. #15
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Nathan01ss View Post
    The website saids they work best with lightly or heavy modify engines.. Also I'm going to go ahead and get o2 sensors..

    Bosch 13111 O2 sensors are they way to go -- but they do have a much longer wire harness than stock. Around $70 each at the parts store.

  16. #16
    Junior Member
    Join Date
    Feb 2010
    Location
    Indianapolis,Indiana
    Posts
    15

    Sunset Metiallic Organe
    2001 Camaro SS

    ok right on

  17. #17
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Yup NGK or autolite 103s, stay away from the E3 plugs

  18. #18
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Put the stock MAF back on before doing anything.

  19. #19
    Car Nut ICRAZY6's Avatar
    Join Date
    Feb 2006
    Location
    Lacon, Illinois
    Posts
    404

    Black
    2002 Trans Am WS6

    /\ I would say maf is the issue here. Why did you put the SLP one on?

  20. #20
    EVIL-LS1 EVIL-LS1's Avatar
    Join Date
    Jun 2006
    Location
    Fredericksburg,Virginia
    Age
    34
    Posts
    345

    RED
    2002/Z28

    Like said above put the stock maf back on and see if it runs better..I put a Delphi 85mm maf on my car and it ran better and even pickup at the track..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New plugs & wires
    By Redrokit8 in forum Firebird / WS6
    Replies: 5
    Last Post: 03-31-2012, 04:56 PM
  2. plugs and wires on ls1?
    By camaross9810 in forum General Help
    Replies: 12
    Last Post: 02-05-2011, 07:28 AM
  3. Plugs and wires - HELP
    By burnfibl in forum External Engine
    Replies: 17
    Last Post: 04-11-2009, 10:30 PM
  4. Question: New plugs and wires. . .
    By chrisbgood in forum General Help
    Replies: 14
    Last Post: 09-13-2008, 06:21 AM
  5. Plugs and Wires Install...MSD wires E3 plugs
    By Demon_Z28 in forum External Engine
    Replies: 13
    Last Post: 05-04-2008, 04:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •