Results 1 to 14 of 14

what Make Oil Pump would you use

This is a discussion on what Make Oil Pump would you use within the Internal Engine forums, part of the LSx Technical Help Section category; hi, I'm gonna install a Paxton SC, so I've thougt it would be a good Idea to replace the stock ...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    7

    Red
    AC Cobra

    what Make Oil Pump would you use

    hi,
    I'm gonna install a Paxton SC, so I've thougt it would be a good Idea to replace the stock OilPump with a HighVolume Pump since the SC uses the EngineOil for lubrication.
    so far I found two the Lingenfelter and the Melling, what Brand would you suggest?

  2. #2
    Jesus died to save you! Killer_bluebird's Avatar
    Join Date
    Aug 2005
    Location
    North Olmsted, OH
    Age
    43
    Posts
    508

    Navy Blue Metallic
    2000 Camaro Z28

    I've heard good things about the Melling pumps. I'm using the TSP ported LS6 pump and am very happy with it.
    2000 NBM Camaro Z28
    Mods:
    SLP Lid & K&N, AHR Headers + 3" catted Y and Mangaflow, !EGR, !AIR, BMR CM STB, ST Front 35mm and Hellwig Adj. Rear 22mm Swaybar, Adj. Rod/Rod PHB, Koni SA's, Ground Control Springs & Adj. Ride height, and HPTuners.

  3. #3
    Senior Member Wheeler99WS6's Avatar
    Join Date
    Jul 2006
    Location
    indiana
    Age
    35
    Posts
    1,018

    black, 05 Roush
    black, 99 T/A WS.6

    I plan on going with the ported LS6 but I am doing heads and cam, I would think it would be sufficient though for SC. Probably cheaper than lingenfelter and melling, but heard good things about the melling also.
    1999 T/A WS6 Black -------SOLD
    05 mustang Roush sport;
    DOB manifold, m122 SC, 47lb injectors, gt500 TB, roush TVS CAI, Detroit rocker SC grind camshafts, Mac LTs, off road x, roush off road mufflers, roush short throw shifter, kenne bell BAP, Brenspeed 93 octane tune. 479rwhp 436ftlbs SAE.

  4. #4
    Awaiting Activation
    Join Date
    Oct 2006
    Location
    Alabama
    Posts
    23

    White
    1998 Trans Am

    I have the Ls6 High Volume, High Pressure pump on my 383 and it puts out about 80 lbs at idle and when you are at wot it hits the stop peg. haha. They give you good oil pressure is what im trying to say.

  5. #5
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    I have a ported and shimmed Ls6 oil pump and w/the mods i have done, it has served me well...
    2000 SS - The Wicked Witch: °°Cammed 'n Slammed°° 458rwhp/410rwtq
    Quote Originally Posted by Bowtie_girl30
    I was hoping to just hump her up the exhaust cause she is so damn sexy....
    "Never argue with an idiot. They drag you down to their level, then beat you with experience."

  6. #6
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,129
    Retired Outlaw Sum Bitch

    I run the Lingenfelter. No issues. Great oil pressure and volume....

  7. #7
    Member lrader99's Avatar
    Join Date
    Nov 2005
    Location
    NW Georgia
    Age
    32
    Posts
    397

    flat black
    Quote Originally Posted by Lawdawg4623 View Post
    I have the Ls6 High Volume, High Pressure pump on my 383 and it puts out about 80 lbs at idle and when you are at wot it hits the stop peg. haha. They give you good oil pressure is what im trying to say.
    dude you have other issues.. you should not have 80 lbs of oil at an idle i bet if you pull your intake you got reversion all the way up your intake ports on your heads...if you really do have 80 lbs of oil pressure....are you sure your sending unit is good...?one day i had 45lbs at idle which is normal then next i had 70...electronics gave out in the oil pressure sensor...my SLP LS6 blue printed and ported has the same pressure at idle but about 10 more lbs when im getting on it... hence the high volume....volume is not pressure...you my friend have a pressue issue..

    but on the original matter...i run the SLP pump...fitment was good tech support...well its SLP if you can through they are great else your shooting blanks in the dark hoping to hit something...but its dark so you dont know they are blanks....the pump its self is great i believe all of SLP's pumps start out as melling pumps. melling has made a lot og GM's OE pumps for years. Lingenfelter is the same way they take the OE components and make them that much better...but your gonna pay for it saying lingenfelter

  8. #8
    Junior Member
    Join Date
    Feb 2007
    Location
    Germany
    Posts
    7

    Red
    AC Cobra

    Quote Originally Posted by lrader99 View Post
    Lingenfelter is the same way they take the OE components and make them that much better...but your gonna pay for it saying lingenfelter
    the Lingenfelter Pump is only $89.95 thats even cheaper then the OEM isn't it?

  9. #9
    Awaiting Activation
    Join Date
    Oct 2006
    Location
    Alabama
    Posts
    23

    White
    1998 Trans Am

    I run 10w30 in it also. i thought it was a bad sending unit also, replaced it and still have the same pressure. I have even checked under the intake and no oil is to be found. The pump works fine, I guess with the stroker kit it needs the volume. Anyways pump is a good one to go with if you need the flow.

  10. #10
    ORNGP33L 1BADDLS1's Avatar
    Join Date
    Mar 2006
    Location
    Long Island, NY
    Age
    32
    Posts
    415

    Hugger Orange
    1999 Camaro Z-28

    Quote Originally Posted by lrader99 View Post
    dude you have other issues.. you should not have 80 lbs of oil at an idle i bet if you pull your intake you got reversion all the way up your intake ports on your heads...if you really do have 80 lbs of oil pressure....
    melling you need to grind the front cover for clearance...
    stock LS6 or TSP ported/shimmed should be sufficient


  11. #11
    Visualize°Design°Create SSwt00SS's Avatar
    Join Date
    Dec 2005
    Location
    Dallas, TX
    Posts
    9,287

    '12 Silver SS 1SS
    '00 Black SS #8617

    lrader99, like the avatar pic, i would love to see the same pic taken without the bldg in the background and have it just be of your car. that would make for an awesome wallpaper pic...

    sorry for the hi-jack though i have already comment bout the oil pump...hehe

  12. #12
    Member 94 Formula's Avatar
    Join Date
    Jan 2006
    Location
    La Mesa
    Age
    37
    Posts
    505
    M3 SMG 350HP

    I have a ported LS6 and I get 50lbs at idle and 70-75lbs at wot.

  13. #13
    Member lrader99's Avatar
    Join Date
    Nov 2005
    Location
    NW Georgia
    Age
    32
    Posts
    397

    flat black
    thanks for the compliment, thee light and everything just happened to be perfect except the stupid building...someone should have told it to go away...as far as the price of the lingenfelter vs an OE unit i dont know i dont look at OE parts anymore unless its a sensor or something that cant be improved by an aftermarket part

  14. #14
    Jesus died to save you! Killer_bluebird's Avatar
    Join Date
    Aug 2005
    Location
    North Olmsted, OH
    Age
    43
    Posts
    508

    Navy Blue Metallic
    2000 Camaro Z28

    Quote Originally Posted by lrader99 View Post
    thanks for the compliment, thee light and everything just happened to be perfect except the stupid building...someone should have told it to go away
    You know that is nothing a little photoshop can't fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Pump: drop tank or make access panel?
    By GottaHaveLS1 in forum General Help
    Replies: 42
    Last Post: 08-27-2008, 08:42 PM
  2. Who's Make of Water Pump to Use?
    By seppburgh in forum LT1
    Replies: 6
    Last Post: 08-27-2008, 07:04 PM
  3. Power Steering pump leak?! new pump or seal kit?
    By JehalinTA in forum General Help
    Replies: 2
    Last Post: 03-18-2008, 11:05 PM
  4. Replies: 10
    Last Post: 01-14-2008, 09:57 PM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 10:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •