Results 1 to 4 of 4

well hi every one

This is a discussion on well hi every one within the Internal Engine forums, part of the LSx Technical Help Section category; well i have a question. about the o ring on ls1 oil pump.all of the lifters are noisy. on 2000 ...

  1. #1
    Junior Member
    Join Date
    Apr 2010
    Location
    salt lake city
    Posts
    5

    red
    2000 camaro z28

    well hi every one

    well i have a question. about the o ring on ls1 oil pump.all of the lifters are noisy. on 2000 ls1 oil pressure is 40 at idle cold. 20 hot idle about 40 at 2500 in 5 gear wondering if you think its o ring on pick up in oil pump thanks for any help oldone

  2. #2
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Welcome to the site. Start a new thread in the Internal Engine section for more replies.

    Unless the motor has been apart recently, I wouldnt guess that the oring is causing any issues.
    370 CI - Twin 6766 Turbo - Jakes stage 5 4L80E - MWC 9" - Holley Dominator

    Build in progress...

  3. #3
    She Moderator KahanaReef's Avatar
    Join Date
    Jul 2008
    Location
    So Cal
    Age
    54
    Posts
    15,590

    Arctic White
    2000 Camaro Z28

    Welcome to LS1.com!

    I moved the thread for you

  4. #4
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    Welcome. My 98 has oil pressure similar to yours. I don't give it a second thought when driving other than I'd normally do with any other vehicle I own.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •