Results 1 to 6 of 6

Replacing cam

This is a discussion on Replacing cam within the Internal Engine forums, part of the LSx Technical Help Section category; I have a 2000 ls1 ws6. the performance is degrading and I believe I have a worn cam shaft that ...

  1. #1
    Junior Member
    Join Date
    Jul 2009
    Location
    columbus
    Posts
    13

    red
    2000 WS6 TRANS AM

    Replacing cam

    I have a 2000 ls1 ws6. the performance is degrading and I believe I have a worn cam shaft that isnt allowing the valves to work properly

    I want to replace the cam any suggestions on which replacement I should get that allows me to perform a direct replacement. What else should I change on the engine while I'm doing the cam swap?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    How about a basic tune up first before you go ripping into things? How many miles on the plugs and wires, fuel filter and air filter? Has the MAF and throttle body been cleaned lately? If you are still running catalytic converters, any chance one or both have gone bad and are choking your exhaust? How about the front O2 sensors?

  3. #3
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Jeff is correct, start checking other things. The chances of your camshaft being worn to the amount you are referring to or estimating is slim to none. You need to give more information on the problem, get a good scan of the car(codes), state when the last tune up was performed; including but not limited to, fuel filter, spark plugs, plug wires, MAF cleaning, air filter (what kind and last oiling if K&N),any recent work performed and O2 sensors. Also, M6 or A4 should be included.

    State the following in your next post, and I'm sure the knowledgeable people around here can help you.

  4. #4
    Old Member, New Username BrownsMillsAntz's Avatar
    Join Date
    Aug 2011
    Location
    Browns Mills NJ
    Posts
    190

    Green
    1995 Z28 w/ LS1 Swap

    Oil pump(ported or aftermarket), pushrods, timing chain, then get a tune

    Heads/Cam/Intake/Stall.
    404 Rwhp uncorrected @ 6400

  5. #5
    Junior Member
    Join Date
    Jul 2009
    Location
    columbus
    Posts
    13

    red
    2000 WS6 TRANS AM

    I posted last year about the problems I have. Had a baby, took a new job and moved since then so the car has been sitting for a while. A4 trans am. Losing power while driving and while in park when I rev it it studders. Get o2 codes if i run it hard, but thats just due to the engine issues. No other codes. Fixed intake temp sensor, replaced plugs, oil changed, k&n filter cleaned, cleaned tb, cleaned maf, found broken weld above drivers cat at the 3 bolt flange,fixed that, cleaned intake, Car runs okay until u need to give it a bit of gas. Studders a bit when its not running right. Haven't done a compression check but took it to a shop and the guy wanted to rebuild it for 4k or sell me his z06 engine then offered to buy it....I pretty much felt like he wanted the car or 4k$ to 5k$ to fix the car. If i could drive it there and back it didn't seem like it was $5000 dollar problem.
    Last edited by mm3306; 12-02-2011 at 08:35 PM. Reason: Spelling

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Replace the fuel filter and then check your pressure at the rail. Clean the MAF with CRC Spray MAF cleaner and carefully inspect the PCV system for a vacuum leak. The rubber fitting on the side of the throttle body and the plastic tubing at the back passenger side of the engine tend to be the problem areas.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ?'s about replacing H/U
    By LS1 oldtimer in forum Stereo and Electronics
    Replies: 6
    Last Post: 09-28-2010, 09:21 PM
  2. replacing everything
    By L...S...1 in forum Stereo and Electronics
    Replies: 6
    Last Post: 10-21-2009, 04:02 PM
  3. replacing only cam. what else do i need?
    By Semperfiws6 in forum Internal Engine
    Replies: 9
    Last Post: 08-03-2007, 10:58 PM
  4. Replacing brakes
    By s022mag in forum GM Trucks
    Replies: 1
    Last Post: 11-15-2006, 02:45 PM
  5. need info on replacing cat
    By bmax327 in forum External Engine
    Replies: 2
    Last Post: 09-30-2006, 04:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •